[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 698
  • Last Modified:

Unable to install MSDE

I'm using a stand alone Window XP Home Edition and I have Acronis Timeclock Software which requires MSDE installed. First of all I get an error stating the SQL server installation is either corrupt or has been tampered with (unknown package id). Please rerun setup.  Then I went and get rid of that error and now I'm trying to install it and it gives me an error of "The path specified in a command line argument is invalid argument is invalid <Path> /x86/Setup/Setup.iss". What can I do to resolve this issue
0
shyvega
Asked:
shyvega
  • 2
1 Solution
 
mastertechncCommented:
it sounds like the installer is corrupted, just download msde from microsoft

http://www.microsoft.com/downloads/details.aspx?familyid=413744D1-A0BC-479F-BAFA-E4B278EB9147&displaylang=en
0
 
CMYScottCommented:
I'm not sure I completely agree with mastertech

yes, some part of the installer is correct and you can download MSDE direct from Microsoft

what's important is that the MSDE 'package' can be customized using an INI file included with your original software CD.  That INI file can be used to specify certain settings for MSDE.  If anything is included with the INI file which varies from the defaults, you may end up putting MSDE on your system and it not working with your app.  In which case you'll have a bigger issue because uninstalling MSDE does not work properly and almost always leaves 'residue' which prevents you from RE-installing MSDE.

My suggestion is that you find the INI file for the MSDE install on your software CD.  Then, copy the INI file to wherever you download/extract the MSDE from Microsoft.  You may have to change some path's in the INI file to get everything to work.

Its a bit more technical this way, but it give you a much better chance of success.

Good Luck
0
 
torimarCommented:
It looks to me like the MSDE installation cannot be started like any other install simply by starting a setup executable. It requires, as a commandline argument, the full path to a valid .ISS file.

If you did not create such an .ISS file yourself or don't even know what that is, try starting the install procedure like this from a command prompt in the folder where msdex86.exe resides:

msdex86.exe s a f1 "sql70ins.iss"

If this doesn't work, check your installation media for Readme files or other types of instructions, since they seem to needs be consulted in this special case.
0
 
torimarCommented:
Sorry, don't know what happened up there in my startup commandline. It was copy/paste from a MS page - possibly with some sort of strange encoding.
Instead of the exclamation marks, hyphens have to be used:

msdex86.exe -s -a -f1 "sql70ins.iss"
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now