Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Cisco 851 - Power Outage - How to bring back online?

Posted on 2008-06-24
7
1,071 Views
Last Modified: 2010-05-18
I have a Cisco 851 in one of our branch offices.
They have a 2.5 hour power outag last night (Thunder stroms...) and the 851 did not come back online.
After a 2 hour drive to the branch, I discover the router just needed a reload command.

Before I issued the reload command... this is what I saw on the router - see code snippit.

How can I setup the router so it comes back online once power has restored?
(Or was this a oddball flike??)

Thanks,

E.D.


851 con0 is now available                                 
 
 
 
 
 
Press RETURN to get started.                            
 
 
rommon 1 >          
rommon 1 > ?            
alias               set and display aliases command                                                   
boot                boot up an external process                                               
break               set/show/clear the breakpoint                                                 
confreg             configuration register utility                                                  
cont                continue executing a downloaded image                                                         
context             display the context of a loaded image                                                         
cookie              display contents of cookie PROM in hex                                                          
copy                Copy a file-copy [-b <buffer_size>] <src_file> <dst_file>                                                                             
delete              Delete file(s)-delete <filenames ...>                       
dir                 List files in directories-dir <directory>
dis                 display instruction stream
dnld                serial download a program module
format              Format a filesystem-format <filesystem>
frame               print out a selected stack frame
fsck                Check filesystem consistency-fsck <filesystem>
help                monitor builtin command help
history             monitor command history
meminfo             main memory information
mkdir               Create dir(s)-mkdir <dirnames ...>
more                Concatenate (type) file(s)-cat <filenames ...>
rename              Rename a file-rename <old_name> <new_name>
repeat              repeat a monitor command
reset               system reset
rmdir               Remove a directory
set                 display the monitor variables
stack               produce a stack trace
sync                write monitor environment to NVRAM
sysret              print out info from last system return
tftpdnld            tftp image download
unalias             unset an alias
unset               unset a monitor variable
xmodem              x/ymodem image download
rommon 2 >

Open in new window

0
Comment
Question by:edalzell
  • 4
  • 2
7 Comments
 

Author Comment

by:edalzell
ID: 21855172
Here's my config:



Using 2487 out of 131072 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco581
!
boot-start-marker
boot-end-marker
!
logging buffered 52000
!
no aaa new-model
clock timezone PCTime -5
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
!
crypto pki trustpoint TP-self-signed-1595647584
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1595647584
 revocation-check none
 rsakeypair TP-self-signed-1595647584
!
!
crypto pki certificate chain TP-self-signed-1595647584
 certificate self-signed 01 nvram:IOS-Self-Sig#5.cer
dot11 syslog
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.6.1 192.168.6.4
ip dhcp excluded-address 192.168.6.51 192.168.6.254
!
ip dhcp pool sdm-pool
   import all
   network 192.168.6.0 255.255.255.0
   default-router 192.168.6.1
   dns-server 192.168.0.225
   netbios-name-server 192.168.0.225
   domain-name domain.com
   lease 365
!
!
ip cef
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip domain lookup
ip domain name domain.com
!
!
!
username edalzell privilege 15 secret 5 $1$0Hom$xcUg7nbkMTI3eXVr/1Mow.
username kcutech privilege 15 secret 5 $1$Fhi9$F3cbQ9EXUdaflf3EuICR1.
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
!
interface FastEthernet3
!
interface FastEthernet4
 description $ETH-LAN$
 ip address 192.168.200.6 255.255.255.0
 ip access-group 100 in
 duplex auto
 speed auto
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 192.168.6.1 255.255.255.0
 ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.0.2 permanent
ip route 172.26.252.0 255.255.255.192 192.168.0.6 permanent
ip route 192.168.0.0 255.255.255.0 192.168.200.1 permanent
!
ip http server
ip http access-class 1
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip access-list extended ACL1
 remark Allow Ping
 remark SDM_ACL Category=1
 remark PING
 permit icmp any any
ip access-list extended ACL2
 remark Any!
 remark SDM_ACL Category=128
 permit ip any any
!
no cdp run
!
control-plane
!
banner exec ^Cine
We^C
banner login ^CWelcome to KCU!
^C
!
line con 0
login local
 no modem enable
line aux 0
line vty 0 4
 access-class 101 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
end

Open in new window

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 21855178
It was a fluke.  Some times the router boots into ROMMON and requires to be turned off and back on again or issued the "boot" command.  I have seen this when there is something plugged into the console port like a  modem.
0
 

Author Comment

by:edalzell
ID: 21859573
I see.
I turned the power off (using the power switch..) and while still plugged into the console, it still came up with the ROMMON prompt.
Is there anything I ccan do in the future to prevent a 2.5 hour drive? ;-)

Thanks for your help!
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 4

Accepted Solution

by:
fileinster earned 500 total points
ID: 21861534
Yes, try this:
sh ver  (look for Configuration Register near the end)
If it's not 2102 do this:

conf t
config-register 0x2102
exit

Power off the router and see if that helps.


0
 

Author Comment

by:edalzell
ID: 21861916
Ok... it says: Configuration register is 0x0
What does this do? (I'll try this next time I'm there.....)

Thanks!


Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(15)T5, RE
LEASE SOFTWARE (fc4)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Thu 01-May-08 02:07 by prod_rel_team
 
ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE
 
cisco851 uptime is 12 hours, 35 minutes
System returned to ROM by power-on
System image file is "flash:c850-advsecurityk9-mz.124-15.T5.bin"
 
 
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
 
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
 
If you require further assistance please contact us by sending email to
export@cisco.com.
 
Cisco 851 (MPC8272) processor (revision 0x300) with 59392K/6144K bytes of memory
.
Processor board ID FHK1223201V
MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
5 FastEthernet interfaces
128K bytes of non-volatile configuration memory.
20480K bytes of processor board System flash (Intel Strataflash)
 
Configuration register is 0x0

Open in new window

0
 
LVL 4

Expert Comment

by:fileinster
ID: 21867352
AH! that's your problem then. Do what I said and that'll be fixed.

The configuration register specifies where the router gets it's IOS image from. 0x0 means don't boot, while 0x2102 means boot from flash.
0
 

Author Comment

by:edalzell
ID: 21875315
Great, thanks fileinster!
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Port 808 is being blocked 9 120
Error on login Cisco RV016 1 40
Stack Switches in IOU  web V22 6 115
VOIP: SIP vs. proprietary Broadview Networks Silnet ?? 12 143
This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

792 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question