Microsoft Virus Warning, can I disable it?

I am trying to open a powerpoint presentation from a hyperlink.  I am able to open it however an annoying virus warning message keeps coming up each time I open it.  Here is the error:

Opening file: <path to file><filename>

Some files can contain viruses or otherwise be harmful to your computer.
It is important to be certain that this file is from a trustworthy source.

Would you like to open this file?

I am running Windows 2000 and Office 2000.  I have already searched Microsoft Knowledgebase and reviewed article 190270 which was no help.  Also I was unable to get article 212290 to come up.  I know there is a fix for this in Office XP and 2003 but upgrading is not an option.  Does anyone have a way to disable this warning, or workaround it?
huskerdrewAsked:
Who is Participating?
 
Echo_SCommented:
Ah, sorry, I don't have one for 2000. You might give the utility a try, though. I don't think it will hurt.

Or go the the MS article for 2003 (http://officeone.mvps.org/download/hyperlink_warning.html) and make adjustments for 2000. For example, HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common would probably be HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common

Definitely back up your registry before going that route!
0
 
dude02Commented:
I believe this should help. Check out this website:  http://www.pcw.co.uk/personal-computer-world/features/2187847/hands-hyperactive-hyperlinks

Dude02

0
 
Echo_SCommented:
You have to do a lot of registry editing in order to get this message to go away. PPT MVP Chirag Dalal created a utility that performs the registry edits for you -- makes life much easier, as far as I'm concerned. Get it here: http://officeone.mvps.org/download/hyperlink_warning.html 

There's also a link on Chirag's page that points to the Microsoft KB article about this. (For what it's worth, I also wasn't able to turn it up searching the Microsoft KB directly.)

Note that this solution won't eliminate the warning if you send the file(s) to others or run these on a different computer.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
huskerdrewAuthor Commented:
Echo,

The link you gave me refers to Office 2003 and 2007, did you have one for Office 2000?


Dude,

Thanks, I will review and see if it will help.
0
 
huskerdrewAuthor Commented:
Dude,

thanks for the article, unfortunately the workaround did not work for my issue.  I am still getting the error.
0
 
dude02Commented:
Disable hyperlink warning messages in Office 2000
When you click on a hyperlink or an object linked to an executable file, Office often
displays a safety warning message. To disable these warning messages:
1. Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common
2. Locate the Security key or create a new key if it does not exist.
3. Select the Security key and create a new DWORD value named
DisableHyperlinkWarning
4. Set the DisableHyperlinkWarning value to 1. (Set the value to 0 or delete the Security
key to enable the warning messages.)
5. Navigate to:
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\9.0\Common
6. Locate the Security key or create a new key if it does not exist.
7. Select the Security key and create a new DWORD value named
DisableHyperlinkWarning
8. Set the DisableHyperlinkWarning value to 1. (Set the value to 0 or delete the Security
key to enable the warning messages.)
9. Close the Registry Editor and restart an Office application.
0
 
dude02Commented:
This is the correct one for Office 2000. Disregard previous post. Thanks.

Disable hyperlink warning messages in Office 2000
When you click on a hyperlink or an object linked to an executable file, Office often
displays a safety warning message. To disable these warning messages:
1. Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common
2. Locate the Security key or create a new key if it does not exist.
3. Select the Security key and create a new DWORD value named
DisableHyperlinkWarning
4. Set the DisableHyperlinkWarning value to 1. (Set the value to 0 or delete the Security
key to enable the warning messages.)
5. Navigate to:
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\9.0\Common
6. Locate the Security key or create a new key if it does not exist.
7. Select the Security key and create a new DWORD value named
DisableHyperlinkWarning
8. Set the DisableHyperlinkWarning value to 1. (Set the value to 0 or delete the Security
key to enable the warning messages.)
9. Close the Registry Editor and restart an Office application.
0
 
huskerdrewAuthor Commented:
Dude,

I followed your directions in your last post and I still get the error message after making those changes to the registry.  I have been doing some other research and it seems to me that in the 2000 version of Office this is pretty much impossible to get around.  Unless anyone has any other ideas, I am about to put the "Lost Cause" stamp on this, and resort to other methods.  It seems that in Office XP and later there are fixes to this but not 2000.
0
 
GlennaShawCommented:
See: http://support.microsoft.com/kb/291912/en-us
You're only offered a work-around for Office 2000 and Office 2002 (XP):
To work around this behavior, you can view the page in a Web browser.

See also: http://www.pptfaq.com/FAQ00587.htm
A visitor to the PowerPoint Newsgroup (thank you, Ramin!) suggested linking to a web page and letting the web page contain the links to the files that trigger the warning messages in PowerPoint.
0
 
huskerdrewAuthor Commented:
Thank you Glenna, I have already tried the support article you referenced and it was no help.  Also this is not a powerpoint file that I own or can make any changes to or how it is placed on websites, so it doesn't appear that your second suggestion would work either.  Thank you for the suggestions anyway.
0
 
huskerdrewAuthor Commented:
From all that I have gathered this issue cannot be fixed in Office 2000, however the three people I awarded points to gave some workarounds that could work.  Some did not work for me because my situation did not allow me to perform certain actions.  The best solution would be to upgrade to 2003 where there are clear fixes and not just workarounds.  Thanks to all who posted some possible ideas.
0
 
huskerdrewAuthor Commented:
This issue is and issue with Windows 2000.  The only possible workaround is if you have control of the Powerpoint file in question and can change some of the hyperlink properties.  The only real solution seems to be to upgrade to Office XP or later where there is some registry edits that can be made to stop this warning from coming up.  Unfortunately I am not in a position right now to do either so I will have to sit on this for a while.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.