[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now


system32/.hal.dll missing no boot entries

Posted on 2008-06-24
Medium Priority
Last Modified: 2008-07-23
I started my computer and got this error
windows/system32.hal.dll missing or corrupt

I booted to the windows xp cd, ran the recovery consol and tried   bootcfg/list
got this error currently no boot entries available to display

I ran the bootcfg/rebuild
got this error  Failed to successfully scan disks for windows installations.  This error may be casued by a corrupt file system.  which would prevent Bootcfg from scanning use chkdsk to detect any erros.

I ran chkdsk/r  however this my current problem its just sitting there at 0% and won't move.

Not sure why, what to do or next step.

Any help would be great
Question by:WestonGroup
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
LVL 25

Expert Comment

ID: 21858243
sounds like you may well have a blown HDD especially if the chkdsk /r wont run.

try running fixmbr see if that sorts out your boot sector but i think you may be FUBAR'd here.

if teh fix mbr doesnt work try slaving the drive into a nother machien and seeing if it gets recognised

Expert Comment

ID: 21858535
Also you can download UBCD4WIN from www.ubcd4win.com and boot from the cd and run the HD diagnostic tools from there.

Author Comment

ID: 21858563
fixmbr worked fine as well as fixboot

chkdsk /p /r starts to run but so far hasn't moved past 0%...I was just going to let it run , seems like its running but stays at 0%

Once that runs awhile I will try the mast / slave setup
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

LVL 25

Expert Comment

ID: 21858809
let it run for a good couple of hours but like i said not sure if its gonna work ill check back later see if theres an update

Author Comment

ID: 21873881
Ok I ran the chkdsk and it completed but says this...not sure where to go from here

50% completed  The volume appears to contain one or more unrecoverable problems
LVL 25

Expert Comment

ID: 21873918
ok where to go from here is to order a new drive as the one you have is only useful for rifle target practice now

slave it onto a nother machine so you can extract teh data and then get yourself a new drive if your not sure how to pull your data let me know

Author Comment

ID: 21874289
How can I master slave a sata drive with a ata drive?

also I ran the drive manufacturer diagnostics tool on the drive and it passed?
LVL 25

Expert Comment

ID: 21874356
that just checks the integrity not the actual table structure etc. doing a reformat of that drive might allow it to function again but i would be inclined in this instance to just get a new drive as if a drive fails once it is liely to fail again.

to slave the dirve into another machine, open up another tower and find the spare ide lead and plug the drive you have detached out teh bad machine into the working machine. When you boot the workign machine you shoudl see the attched drive and MIGHT be able to pull the data off of it by opening files and folders in teh usual way

Author Comment

ID: 21874392
I know how to master slave a drive...but I've never done it with a sata drive....this one doesn't use ide cables...

its a Maxtor 6Y080M0

I can't seem to find the jumper setting either has its not printed on the drive...so I don't know what the correct slave jumper is

LVL 25

Accepted Solution

slam69 earned 2000 total points
ID: 21874482
Hi there is no slave jumper, just a spereate cable for each didnt realise this was a SATA hard drive!!

You should just plug them both in then check teh bios you might need to activate it there, just make sure you dont get the boot order out of sync so that it boots from teh broken one

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

cPanel is a Unix based web hosting control panel that provides a graphical interface and automation tools designed to simplify the process of hosting a web site. cPanel utilizes a 3 tier structure that provides functionality for administrators, rese…
Sometimes people don't understand why download speed shows differently for Windows than Linux.Specially, this article covers and shows the solution for throughput difference for Windows than a Linux machine. For this, I arranged a test scenario.I…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question