Solved

Need to open port 143 for IMAP traffic

Posted on 2008-06-24
9
3,752 Views
Last Modified: 2013-11-30
I am receiving a 550 error (unable to relay) through MS Outlook when I try to send an email to an address outside my domain.  MS Support states that I need to open port 143 for IMAP traffic on my firewall.
0
Comment
Question by:JSTechinLA
  • 4
  • 3
  • 2
9 Comments
 
LVL 1

Accepted Solution

by:
danstuken earned 400 total points
ID: 21858132

Hi,

Its been a while since I played email admin, but perhaps I can help point you in the right direction.

"Unable to Relay" messages when sending a 'normal' email from Outlook are unlikely to be anything to do with IMAP.  Though without more details its difficult to say.

There's a good chance the error is genuine and something is refusing to relay.  Which MTA are you using - Exchange, Sendmail, Exim, ..... ?  It could be that your local edge MTA is not configured with your correct domain details and is refusing to forward outgoing traffic through it.  Alternatively you may not have correct Reverse DNS entries for your edge MTA and the next hop MTA is refusing relaying.

Without more info. its impossible to tell.

0
 

Author Comment

by:JSTechinLA
ID: 21858252
I have an exchange 2003 server and I am use either Outlook express or Outlook 2003.  When I send in my domain it works fine but as soon as I try and go outside my domain to gmail or yahoo or probably any external address I get the 550 error.  I have a case open with Microsoft support and they insist that it is my firewall that is preventing the traffic.  
Here is the actual error message:
The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'xx@gmail.com'. Subject 'test again', Account: 'mail.myrealdomain.com', Server: 'mail.rmyrealdomain.com', Protocol: SMTP, Server Response: '550 5.7.1 Unable to relay for xx@gmail.com', Port: 25, Secure(SSL): No, Server Error: 550, Error Number: 0x800CCC79
0
 
LVL 1

Expert Comment

by:danstuken
ID: 21858575

Hmm, okay.  I could be guilty of jumping to conclusions.  It does seem very odd though that in order to send an outgoing SMTP email (which is essentially a stateless, "fire-and-forget" task) it should be necessary to open up the IMAP port.  I suspect you'll want to rule out the need to open port 143 which is something I'm unable to help you with.

I've never touch Ex2003 so I'm not going to be much help there either, I'm afraid.  My gut feeling is that something somewhere is genuinely refusing to relay your domain.  In earlier versions (5.5 & 2000) there was an SMTP - if such a thing still exists perhaps it configuration needs double-checking.  

Presumably, when you say email is working within your domain, you are referring to your Windows domain on Ex2003 with all users on Outlook? If that is the case then the email will be sent by a different (non-SMTP) mechanism so isn't really indicative of much.

Sorry I can't be of more help.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:JSTechinLA
ID: 21858651
Thanks for the help so far, it is at least explaining more of the basics.
0
 
LVL 1

Expert Comment

by:danstuken
ID: 21858808

np, hope you find some more useful answers.
0
 
LVL 1

Assisted Solution

by:tlcsupport
tlcsupport earned 100 total points
ID: 21863652
Firstly, can we confirm that you've setup Outlook with an Exchange Profile and not a POP3/SMTP profile?

If you've setup a POP3 account, chances are your client is not allowed to relay through your exchange server.

If you setup an Exchange account, however, chances are it's a problem with your reverse dns (PTR) record. Or maybe you're pointing Exchange at a smart host that doesn't know you?

To rule out a problem with your reverse DNS record, assuming you have one, try sending a test mail from your exchange server using telnet. Google "telnet smtp" and pick a result:

http://www.activexperts.com/activemail/telnet/

Pick a recipient at random, check the MX record for their domain, telnet to their mail server on port 25 and follow the instructions above.

0
 

Author Comment

by:JSTechinLA
ID: 21867402
I am setting up Outlook with a IMAP profille.  This setup will be for employees who are working on their laptops outside of the office.  Up until now we have been using OWA and it worked fine, but users want to have all of their exchange data (calendar, contacts etc) available off line.  Everything else works fine on my server either through the OWA or local exchange connection, it is just the send of email from the IMAP/SMPT configuration that errors out.  The user can receive email but they receive the 550 Unable to relay error when sending out email.  
I tried the Telnet and received the same 550 error.  I was trying to send to a gmail address.
Here is what I did:
telnet mail.mydomain.com 25
helo
MAIL FROM:  myemail@mydomain.com
RCPT TO: mygmail@gmail.com
550 5.7.1 Unable to relay for mygmail@gmail.com

The only thing odd was that I had to put in two blank spaces after MAIL FROM:     and only one blank space afrer RCPT TO:
0
 
LVL 1

Expert Comment

by:tlcsupport
ID: 21986734
So you have remote Outlook users wanting access to their mailboxes? I'd recommend using RPC over HTTPS on your Exchange server.

See
http://www.msexchange.org/tutorials/Outlook_2003_Connect_Exchange_2003.html
http://www.msexchange.org/tutorials/outlookrpchttp.html
http://www.petri.co.il/configure_rpc_over_https_on_a_single_server.htm
http://www.computerperformance.co.uk/exchange2003/exchange2003_rpc_http.htm

Your users will appreciate this a lot ;)


Opening your server up for remote IMAP and SMTP is a bad idea. For a start, you'd have to open up your SMTP server to the whole Internet which is undesirable. I'd strongly recommend the RPC option. The Daniel Petri site has some good tutorials.
0
 

Author Closing Comment

by:JSTechinLA
ID: 31470236
I had a Spam Scanner interferring with outgoing smtp traffic.  I created a new IP address for mail2.xxxxxx.com and then opened up the appropriate ports on the firewall.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
WatchGuard T50 - Internet Priority Based on VLAN or User 1 12
Email POP and IMAP questions 24 93
Junk folder 23 168
clean-up rule netscreen firewall 3 89
Hello Friends, My friends and relatives always ask me how to delete all the various types of emails at once in our g-mail  or windows live account.  So I researched this topic to find a unique solution to this query.  Here it is for those who do …
I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question