?
Solved

2008 tesrminal server printing issues

Posted on 2008-06-24
5
Medium Priority
?
240 Views
Last Modified: 2013-11-21
I just upgraded a 2003 terminal server to 2008. The main app that we use now has a printing issue. It only affects one part of the app where we select forms to be printed, all other area seem to be working correctly.  The problem is that when a user goes to print from this one screen the print job goes to the default printer regardless of which printer is selected, but only on this screen. The printer selection is done via the typical windows printer list. When a printer is selected it displays as the current printer, but after you click Print and it processes the job the display switches back to the default printer. I realize this is an app problem and I have a support call in the vendor but was hoping someone might have some suggestion as to what I can within windows that might cause this.
0
Comment
Question by:comtekso
  • 3
5 Comments
 
LVL 4

Accepted Solution

by:
darkjedi213 earned 1000 total points
ID: 21860544
Delete the default printer, restart the server, then see what happens. Then re-add the default printer and see if the behavior continues.
0
 

Author Comment

by:comtekso
ID: 21864952
I can change the default printer and the print job will go to whichever printer I set as default.
0
 

Author Comment

by:comtekso
ID: 21865020
I should also add that different users have different default printers and it works the same for all of them.
0
 
LVL 14

Assisted Solution

by:Craig Roberds
Craig Roberds earned 1000 total points
ID: 21869668
Could be a permission issue, as the program is probably trying to write to the registry when the printer is changed within the program, but if you have writing permissions locked down it cannot change it.

If that is the case the best solution would probably be to find out where that registry key is from your software company and see if you can change it for all users or add it to your logon script.
0
 

Author Comment

by:comtekso
ID: 21948411
The problem happens when I am logged in as the domain admin too and also logged in to the app as admin. I have an open support call with the software vendor but have no resolution yet.


0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
Suggested Courses

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question