Services and Event Viewer Properties pages will not display

Posted on 2008-06-24
Last Modified: 2012-06-27
I was having an issue with VSS during backup and noticed the service was stopped, I can right click on the service and start it but I want to change it to automatic. If I click on any of the services running I do not get a properties  window. After finding that out I went to Event Viewer and noticed the same issue. I have all the updates current Windows 2003 Server with SP2 and have saved and cleared (Deleted) the  Event logs with the same result.
Question by:radgears
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4

Expert Comment

ID: 21863330
When i had this problem it was some system files that needed re-registering, attached is a file that you can rename to a .bat file to run it or run the lines one by run in the start run command, a few of these may not work - depends on your IE verison. but this should fix this problem and a few others just in case.

Expert Comment

ID: 21863639

have you tried running services from command prompt??

could you check if all the required services are running...

workstation, server, computer browser, windows management instrumentation....,

have you tried restarting the server...??

any help from this link

Author Comment

ID: 21867098
I have ran the bat file as recommended I then also ran it with out the /s switch to see which ones were successful. As you mentioned 3 of them failed. the mshtml.dll, actxproxy.dll and pdm32.dll. I have the same issue but I have not restarted the server, being that it is our ERP Server I would have to do it during lunch or after work hours. Does the server need to be restarted. I have checked the services mentioned in the second response and they were all running. I can stop and start the services fine without the command line but I can not change it from manual to automatic. I know that you can start services using Net Start, is there a way to change the startup value from the command I do not know about. Thanks again in advance for any help with this.
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!


Expert Comment

ID: 21873346
you can use sc config to do it from command prompt

hope it works, but I doubt it if its not working from GUI.... but you can give it a try...

Expert Comment

ID: 21873463
From the above link...

You typically use the Services GUI in Windows to configure a services start-up type, but you can also use the SC command to set the start-up type from the command line:

sc config <service name> start=<mode>

For example,

sc config tlntsvr start= auto

automatically starts the tlntsvr service when you boot the system.

The start options are

    * auto--a service automatically started at boot time, even if no user logs on
    * boot--a device driver loaded by the boot loader
    * demand--a service that must be manually started (the default)
    * disabled--a service that can't be started
    * system--a service started during kernel initialization

Author Comment

ID: 21874342
After restarting the server last night I am still experiencing the same issue that I cannot open the properties window for any of the running services and also cannot open any of the events properties pages. My gut is teeling me this may be a permissions issue with this server. Since we deployed this a few months back I have noticed things like I can copy a file to it from another server to a share but if I then log in to the server as Domain Admin I can not copy this file to a different drive. If I click on the properties I get an additional area to with an unblock tab. I am hoping that somebody has an idea of what I can try next. I was also going to run a  SFC/scannow and I get a response from entering that "You must be an administrator running a console session in order to use the Windows System File Checker Utility". Is this normal?  

Expert Comment

ID: 21880069
are you trying to run it locally or through terminal services?? this normally comes when you are using it through terminal services....

Accepted Solution

radgears earned 0 total points
ID: 21927469
I have made a little progress on this with the VSS I found this at Microsoft.

After deleting the key and running the commands at the command line The VSSADMIN now list the writer with no error. Before I did this I would just get 2 minute nothing and the back to the comand line but it was creating this event in the event log.

I still have the issue that I cannot double click and event in Event Viewer to get the details or in the services no popup window with details and the ability to change from auto to manual.

Author Comment

ID: 21963256
After restarting the server the issue with the properties windows for Event Viewer and Services is now operating correctly, thanks for all the direction. I believe the suggestion I found at microsoft in the above post resolved this issue for me. Thanks

Author Comment

ID: 21963277
This resolved the issue I was having..

Featured Post

Are You Using the Best Web Development Editor?

The worlds of web hosting and web development are constantly evolving. Every year we see design trends change, coding standards adapt and new frameworks/CMS created. With such a quick pace of change it’s easy to get lost trying to keep up.

See if your editor made the list.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question