Solved

Remote Desktop (to a Vista PC) not connecting

Posted on 2008-06-24
12
627 Views
Last Modified: 2013-11-21
We have a client with a domain server. I have set up Remote Desktop on one of the Vista PCs so that it can be accessed remotely via the Internet (broadband). However even internally I cannot access it from another PC on the same network. So I suspect something is blocking it at the PC end?

I am very familiar with RDP, aet it up successfully many times, we use it for many of our clients and I have set it up as follows:

- Altered the default port in the Registry to 3390 (instead of 3389) [for external access, as 3389 is already allocated for the server which works fine and put in port forwarding in the router]
- Allocated a fixed ip to the machine (via the MAC address and DHCP on the server)
- Ensured Remote Desktop is enabled
- Tried to connect, internally, with 'ip-adress:3390'

- Windows firewall is off (I am pretty sure)
- The PC has a domain user password
- It uses Sophos anti-virus, but I doubt is this is blocking it, not experienceSophos blocking RDP before

Is there someting I have missed or particularly different with Vista? I've connected to my Vista PC OK.

All help gratefully received




0
Comment
Question by:gerlis
  • 5
  • 4
  • 3
12 Comments
 
LVL 2

Assisted Solution

by:dbanttari
dbanttari earned 150 total points
Comment Utility
On the Remote Desktop host [hereafter "Host"]:
- Use "netstat -an" to determine if anything is LISTENING on port 3390
-- if not, then remote desktop hasn't listened when you changed the port.  You probably don't need to change this port; the firewall should be able to redirect 3390 on its public IP to the Host's port 3389.

On another machine within the firewall:
- Attempt to remote desktop to the Host on 3390
-- If this fails, then there's a personal firewall blocking connections.

From outside:
- Try to telnet to that port: "telnet  firewall.public.ip  3390"
-- if you get "Connection Refused" or just a 30s pause before "Could not open connection..." then there's a firewall config issue.  Did you restart the router?
0
 
LVL 2

Expert Comment

by:dbanttari
Comment Utility
- Tried to connect, internally, with 'ip-adress:3390'

Did that work?
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 350 total points
Comment Utility
>>"Windows firewall is off (I am pretty sure)"
If not:
When you enable remote desktop on a PC it automatically creates an exception for the service (from the same LAN). However where you have changed the listening port, if the widows firewall is enabled, you will need to make a custom exception.
0
 
LVL 1

Author Comment

by:gerlis
Comment Utility
dbanttari

Thanks for these suggestions. I will try them tomorrow, I'm in the UK ( I have to connect with user's assitance using our UVNC 'single-click' utility), especially the netstat command.

I cannot RDP internally (within firewall) from another PC, already tried that.
RDP with 'ip-adress:3390' didn't work.

I suspect you are right re: 'personal firewall blocking connections', but nothing else on that PC that is obviously the cause.

I'll let you know tomorrow

Thanks again

 

0
 
LVL 2

Expert Comment

by:dbanttari
Comment Utility
Had you restarted the service (or, heck, the whole machine) since making the registry change?

(BTW if there's nothing "LISTENING" on 3390, check 3389...)

Personally, I think you should do the TCP port translation at the firewall, and leave the port on the actual Host machine at 3389.
0
 
LVL 1

Author Comment

by:gerlis
Comment Utility
RobWill:

Thanks. You may be right or nearly right, I will need to check this client's PC again tomorrow re: Windows firewall. I'm sure I checked the exceptions anyway, even though I am 96% certain firewall is off.

Watch this space...

0
Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

 
LVL 77

Expert Comment

by:Rob Williams
Comment Utility
Another thing to watch with the firewall, if that is the issue, is by default it allows local connections only. You often have to edit the scope options to allow remote connections:
http://www.lan-2-wan.com/RD-FW.htm
0
 
LVL 1

Author Comment

by:gerlis
Comment Utility
dbanttari:

PC re-started a couple of times, as I have to log in as administrator on the PC to have rights to make these changes, (could that be the issue?)

Re: router I see hat you mean, but there does not seem to be a way (Netgear DG834G) of specifying to redirected port, only specifying redirected ip address of the destination machine, presume you mean:

-> incoming (from WAN) port request for 3390  -> router/firewall -> ip-address of PC [with port 3389]

the "[with port 3389]" can't be done on a Netgear DG 834G, unless I am mistaken?
0
 
LVL 2

Expert Comment

by:dbanttari
Comment Utility
Just checked the manual for that particular router, and you're correct-- it doesn't look like it supports different public and private ports for inbound services.  A pity.
0
 
LVL 1

Author Comment

by:gerlis
Comment Utility
All this is very embarrassing!

I was able to check today and the firewall was indeed, on!  I was convinced originally that it wasn't.

However I would not have realised that by using a different port (3390 instead of the default 3389) I would need to open that in the Windows firewall.

With the firewall left on and opening the port in the exceptions, it all worked fine!

So I would like to award the points to RobWill assisted by dbanttari for his/her useful information and contribution
0
 
LVL 77

Expert Comment

by:Rob Williams
Comment Utility
Don't be embarrassed, I've "been there done that" :-)  Often you just need a second pair of eyes.
Thanks gerlis.
Cheers !
--Rob
0
 
LVL 1

Author Comment

by:gerlis
Comment Utility
Quite!

Thanks to you, too.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Some time ago I faced the need to use a uniform folder structure that spanned across numerous sites of an enterprise to be used as a common repository for the Software packages of the Configuration Manager 2007 infrastructure. Because the procedu…
Greetings, Experts! First let me state that this website is top notch. I thoroughly enjoy the community that is shared here; those seeking help and those willing to sacrifice their time to help. It is fantastic. I am writing this article at th…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now