error 'Could Not Start' for Server 2003 Scheduled Task


Has anyone experienced and solved a Server 2003 Scheduled Task error 'Could Not Start' where the task runs after setting the password, manually clicking 'Run', and then scheduling to run automatically within the next hour or so before the day changes?  The scheduled task is defined on a Server 2003 SP2 domain controller.

When I then set the scheduled time to be 1 day in advance, the task does not run and we get a 'Could Not Start' error.  After seeing the error, I set the password for the account the task runs under, then I can either manually run the task or schedule it to start within the next few hours and it runs fine.  I do this daily and the task will keep running under these circumstances.  I have moved the scheduled task to a different domain controller in our forest and the same circumstances happen.

Anyone see this error and it so have a solution?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

What's the task running?  
ISWSIMBXAuthor Commented:
The task is running a CMD file with Joe Richard's Oldcmp to disable AD user and server accounts.
You don't have a group policy which is applying the "Logon as a batch job" do you?  

Computer configuration -> Windows settings > Security settings > Local policies > User rights assignments > Logon as a batch job

I'm wondering if group policy is overriding it..  when you enter the username and password again it's allowing it to logon, then as the policy applies it wipes it out.
Ensure Business Longevity with As-A-Service

Using the as-a-service approach for your business model allows you to grow your revenue stream with new practice areas, without forcing you to part ways with existing clients just because they don’t fit the mold of your new service offerings.

ISWSIMBXAuthor Commented:
As a matter of fact, our internal Domain Controller's Policy actually applies the 'Log on as a batch job' policy which I determined via RsoP on the Domain Controller where the scheduled tasks are defined and run.

Explain in detail please how this would cause the issue Im seeing.
Sorry been away for a couple of days.  When you schedule a job it sticks your name into that allow list so that you can run the job as a batch user (instead of being logged on).  If you're clearing that list out with a group policy, you're clearing out the entry that was put in there by the Tast scheduler.  This means that the task can't run because this user doesn't have the permissions to logon without an interactive session.  

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Could you add the user which you're running the Task under to that GPO and see what happens?
ISWSIMBXAuthor Commented:
I added the domain account in the 'Logon as Batch Job', so give me a day or so to see the effects of this.
ISWSIMBXAuthor Commented:
That worked!  The scheduled task is running daily without error.  I very much appreciate the help here!
ISWSIMBXAuthor Commented:
Thanks for seeing this through,
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.