• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 477
  • Last Modified:

Sendmail Auto print email using LPR not working

I'm trying to setup my Linux machine to forward email to a printer.
While I found some posts describing what to do, I'm still having an issue locally with the sendmail.

I setup the local LPD service on the linux machine with a default queue named myQueue
I modified the aliases file of my sendmail  with the following line:

printout@mydomain: "|/usr/bin/lpr myQueue"

and I rebuilt the aliases

when I send an email to printout@mydomain
I get :

Jun 24 19:36:27 myServer sendmail[23417]: m5P2aRuZ023416: to=|/usr/bin/lpr myQueue, ctladdr=<printout@mydomain> (8/0), delay=00:00:00, xdelay=00:00:00, mailer=prog, pri=36493, dsn=5.0.0, stat=Service unavailable
Jun 24 19:36:27 myServer sendmail[23417]: m5P2aRuZ023416: m5P2aRuZ023417: DSN: Service unavailable

Can you help, I beleive I'm missing simple on that one
  • 8
  • 7
1 Solution
Jan SpringerCommented:
Is myQueue the name that you gave the printer in the printer configuration?

if so:

printout@mydomain: "|/usr/bin/lpr -p myQueue"

you can test the command manually first by:

cat filename.txt | /usr/bin/lpr -p myQueue
ageoffronAuthor Commented:
hi Jesper,

cat test.txt | /usr/bin/lpr -P myQueue
(Note Upper case P)
Does work from the command line, however I tried to modify the aliases and it still give sme the same error

Error: Jun 25 10:35:45 myServer sendmail[5928]: m5PHZjuZ005927: m5PHZjuZ005928: DSN: Service unavailable

Jan SpringerCommented:
Sorry, my bad on the typo and the recommendation.

Try this:

printout:           |/usr/bin/lpr - P myQueue

I don't know that the quotes are required once it hits the pipe.
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

ageoffronAuthor Commented:
I applied the change
printout@mydomain:  |/usr/bin/lpr - P myQueue

I also tried
printout@mydomain:  "|/usr/bin/lpr - P myQueue"
printout@mydomain:  "|/usr/bin/lpr - P myQueue
printout:  |/usr/bin/lpr - P myQueue

and no luck
Do I have anything to do to "allow" LPR with sendmail , like an option within the sendmail.mc file maybe? I looked but did not find anything...

For info,
I have other queues setup on that system which work... they are directed to a binary but the same principle apply.
helpdesk.xxx@mydomain: "|/etc/smrsh/cerberus-2.557.Linux-2.2.14-5.0 /etc/smrsh/config.xml F
ATAL /var/log/cerberus/cerberus.log

Still same error
Jan SpringerCommented:
You have these setup in sendmail aliases?

What are the permissions and ownership on the queues that work vs the one that doesn't?
ageoffronAuthor Commented:
Yes this the aliases from sendmail.

by permsission on the queue, I can only think of the persmission assign to the executables (LPR versus cerberus-2.557.Linux-2.2.14-5.0)
and they both are owned by root. So no difference at that level..

Let me know if you are refering to any other permissions.
Jan SpringerCommented:
If /usr/bin/lpr is chmod 755 or 711it should work.

Dumb question:  did you run newaliases?
ageoffronAuthor Commented:
Here is the permission details:

[root@myServer etc]# ls -al /usr/bin/lpr
lrwxrwxrwx    1 root     root           23 Apr  6  2004 /usr/bin/lpr -> /etc/alternatives/print
[root@myServer etc]# ls -al /etc/alternatives/print
lrwxrwxrwx    1 root     root           18 Apr  6  2004 /etc/alternatives/print -> /usr/bin/lpr.LPRng

[root@myServer etc]# ls -al /etc/smrsh/cerberus-2.557.Linux-2.2.14-5.0
-rwxr-xr-x    1 root     root      2614554 Apr  7  2004 /etc/smrsh/cerberus-2.557.Linux-2.2.14-5.0
ageoffronAuthor Commented:
and yes I issue the command "newaliases" to rebuild the aliases db.
ageoffronAuthor Commented:
I'm raising the point value of this question.
while the pb seems simple , there is something no so obvious going on wiht my sendmail..
Jan SpringerCommented:
Are you not using cups to configure the printing service and, if so, do you have lpd running?
Jan SpringerCommented:
What are the perms of /usr/bin/lpr.LPRng?
Are you using smmsp?

Have you tried to use the program /usr/bin/lpr.LPRng in the aliases file (tho this shouldn't matter).
ageoffronAuthor Commented:
LPD is running. we tested the LPR -P myQueue and it worked..
I'm not using CUPS. just LPD and sendmail locally

I finally found the issue, in my sendmail.mc I had:

A feature which restrict the binaires called through piping from sendmail.

I copied the LPR binary into that folder.. and voila it worked.

Jan SpringerCommented:
And which was why I asked about smmsp.
ageoffronAuthor Commented:
Some directions were given which help me find the solultion.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now