?
Solved

Help with Cisco Pix 501 Site-to-Site VPN

Posted on 2008-06-24
6
Medium Priority
?
297 Views
Last Modified: 2010-04-12
Can someone tell what I'm missing on my configuration. Can't seem to make  a site-to site connection. Help please.  


Router 1
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password cKPjQjC/BtcWkqME encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname vgacorpfirwall
domain-name vgacorp.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit tcp any host 66.92.23.66 eq 3389
access-list 120 permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list 130 permit ip 192.168.0.0 255.255.255.0 192.168.20.0 255.255.255.0
access-list 100 permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list 100 permit ip 192.168.0.0 255.255.255.0 192.168.20.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 66.92.x.x 255.255.255.224
ip address inside 192.168.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 1 192.168.0.0 255.255.255.0 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 66.92.23.66 3389 192.168.0.2 3389 netmask 255.255.25
5.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 66.92.23.66 1
route outside 0.0.0.0 0.0.0.0 66.92.23.65 2
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.0.2 255.255.255.255 inside
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set vgaCorp esp-des esp-md5-hmac
crypto map toRemote 20 ipsec-isakmp
crypto map toRemote 20 match address 120
crypto map toRemote 20 set peer 66.x.x.94
crypto map toRemote 20 set transform-set vgaCorp
crypto map toRemote interface outside
isakmp enable outside
isakmp key ******** address 66.93.x.x netmask 255.255.255.240 no-xauth no-conf
ig-mode
isakmp key ******** address 71.x.x.x netmask 255.255.255.224 no-xauth no-c
onfig-mode
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash sha
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:73ec202ab4ac56d97a70720ff8782885
: end
[OK]
vgacorpfirwall#
gacorpfirwall# show crypto isakmp sa
Total     : 0
Embryonic : 0
        dst               src        state     pending     created
vgacorpfirwall#

Router 2

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password cKPjQjC/BtcWkqME encrypted
passwd xDC9z8lMD5h1KVaq encrypted
hostname vgadpix
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit tcp any host 66.93.86.94
access-list 110 permit ip 192.168.10.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list 100 permit ip 192.168.10.0 255.255.255.0 192.168.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 66.x.x.94 255.255.255.240
ip address inside 192.168.10.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 66.93.86.94 3389 192.168.10.2 3389 netmask 255.255.2
55.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 66.93.86.81 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set vgaCorp esp-des esp-md5-hmac
crypto map vgaCorp 30 ipsec-isakmp
crypto map vgaCorp 30 match address 110
crypto map vgaCorp 30 set peer 66.x.x.66
crypto map vgaCorp 30 set transform-set vgaCorp
crypto map vgaCorp interface outside
isakmp enable outside
isakmp key ******** address 66.x.x.66 netmask 255.255.255.224 no-xauth no-conf
ig-mode
isakmp policy 3 authentication pre-share
isakmp policy 3 encryption 3des
isakmp policy 3 hash sha
isakmp policy 3 group 1
isakmp policy 3 lifetime 1000
telnet 66.93.86.80 255.255.255.240 outside
telnet 66.93.86.0 255.255.255.240 outside
telnet 192.168.10.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
terminal width 80
Cryptochecksum:2fe5260f93722c3ab7523b6320ba7488
: end
[OK]
vgadpix# show crypto isakmp sa
Total     : 0
Embryonic : 0
        dst               src        state     pending     created
vgadpix#
0
Comment
Question by:digipath9776
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
6 Comments
 
LVL 25

Accepted Solution

by:
Cyclops3590 earned 2000 total points
ID: 21862606
the encryption used on the crypto transform-set and the isakmp policy don't match each other on both pix's.  

basically phase 1, they negotiate to use 3des/sha, but when they get to phase 2 try using des/md5 and fail.
0
 
LVL 3

Expert Comment

by:AugustTen
ID: 21864163
The policies are fine.

Enable debugging (deb crypto isakmp and deb crypto ipsec), try to bring up the tunnel and post the result.
0
 

Author Comment

by:digipath9776
ID: 21865304
Please close
0
 
LVL 25

Expert Comment

by:Cyclops3590
ID: 21867488
This shouldn't be closed.  There were two experts helping and I gave a suggestion to solve the problem.  At the least, it should be stated what the solution was.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question