Solved

Static IP with Cisco PIX 501

Posted on 2008-06-24
11
949 Views
Last Modified: 2013-11-16
Currently, I have Road Runner, and the Cisco PIX 501 gets it external ip address via DHCP. I changed my ISP the other day to verizon, which assigns a static ip, with their DNS, Gateway and Subnet information provided to me. I would like to change the Cisco VPN from DHCP to static, but do not know the commands. Can someone write them out, substituing (ipaddress) for where the ip address would go, (DNS) for where the DNS would go, etc.  Thanks!!! :)
Result of firewall command: "write terminal"

 

Building configuration...

: Saved

:

PIX Version 6.3(5)

interface ethernet0 10baset

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password XA/BRgbbTVgXXAGK encrypted

passwd XA/BRgbbTXXC2AGK encrypted

hostname BT-MASS

domain-name bornemantusa.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list acl_out permit icmp any any 

access-list 102 permit ip 192.168.20.0 255.255.255.0 192.168.10.0 255.255.255.0 

access-list 103 permit ip 192.168.20.0 255.255.255.0 192.168.10.0 255.255.255.0 

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside dhcp setroute

ip address inside 192.168.20.254 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location 192.168.10.0 255.255.255.0 outside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 102

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

access-group acl_out in interface outside

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+ 

aaa-server TACACS+ max-failed-attempts 3 

aaa-server TACACS+ deadtime 10 

aaa-server RADIUS protocol radius 

aaa-server RADIUS max-failed-attempts 3 

aaa-server RADIUS deadtime 10 

aaa-server LOCAL protocol local 

aaa authentication ssh console LOCAL

aaa authentication enable console LOCAL

http server enable

http 192.168.20.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

sysopt noproxyarp inside

crypto ipsec transform-set myset esp-3des esp-md5-hmac 

crypto map mymap 10 ipsec-isakmp

crypto map mymap 10 match address 103

crypto map mymap 10 set peer 69.XXX.XXX.XXX

crypto map mymap 10 set transform-set myset

crypto map mymap interface outside

isakmp enable outside

isakmp key ******** address 69.XXX.XXX.XXX netmask 255.255.255.255 no-xauth no-config-mode 

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption des

isakmp policy 20 hash md5

isakmp policy 20 group 1

isakmp policy 20 lifetime 1000

telnet 192.168.20.0 255.255.255.0 inside

telnet timeout 10

ssh 0.0.0.0 0.0.0.0 outside

ssh 0.0.0.0 0.0.0.0 inside

ssh timeout 10

console timeout 0

dhcpd address 192.168.20.65-192.168.20.96 inside

dhcpd dns 192.168.10.1 

dhcpd wins 192.168.10.1 

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd domain borneman-tusa.com

dhcpd auto_config outside

dhcpd enable inside

username American password 1KQOPRXXXPmwWtww encrypted privilege 15

terminal width 80

Cryptochecksum:de175a79d23284bf8d3f1d255bf735da

: end

[OK]

Open in new window

0
Comment
Question by:SpinnerAdam
  • 6
  • 4
11 Comments
 
LVL 2

Expert Comment

by:Taurus042
Comment Utility
you need to add
ip address outside [your new IP] [your new subnet mask]
route outside 0.0.0.0 0.0.0.0 [your new default gateway]
(without the brackets)
You may also need to remove
dhcpd auto_config outside
by entering
no dhcpd auto_config outside

When it comes to DNS I do not know as I have never configured a PIX to use DNS.
0
 
LVL 10

Expert Comment

by:TekServer
Comment Utility
Also, you'll need to configure whatever's on the other end of the VPN with the new IP address.  (Looks like a site-to-site VPN, so you should just need to configure one router/pix/whatever, rather than a bunch of software clients.)

:)
0
 

Author Comment

by:SpinnerAdam
Comment Utility
If I do not put in the DNS vaules, will the computers be able to browse the internet? I thought DNS was crucial to domain name lookup (domain to ip translation). Is there a way of entering the DNS information provided by Verizon?
0
 
LVL 10

Expert Comment

by:TekServer
Comment Utility
Currently, your client workstations are receiving the following DNS info:

dhcpd dns 192.168.10.1

I presume that this IP address is a domain controller or standalone DNS server, since DNS lookup is currently working.  Changing the external IP address shouldn't affect this, though you could change the forwarder address(es) on the DNS server to the DNS info from Verizon, if you wish.  It's not required; no ISP that I know of will block your access to other ISP's DNS servers.

:)
0
 

Author Comment

by:SpinnerAdam
Comment Utility
Sorry for not answering back. I've been dealing with some family issues. Ok, so I tried the commands from Taurus042, but the PIX keeps giving the error message "not enough arugments. Below, I wrote out the vaules (Gateway, IP) that my ISP gave me, and if you can, please give me the exact commands I need to put into the PIX to erase the settings it has now, and add the ones I need:


IP Address: 34.234.112.132
Subnet Mask: 255.255.255.0
Default Gateway Address: 34.234.112.1
DNS 1: 68.233.233.222
DNS 2: 68.233.233.222

(I changed the numbers from the actual numbers)
Thanks,
Adam :)

Result of firewall command: "write teminal"

 

Usage:	write erase|floppy|mem|terminal|standby

	write net [<tftp_ip>]:<filename>

Command failed
 

Result of firewall command: "terminal"

 

Not enough arguments.

Usage:	terminal {width <columns> | [no] monitor}

Command failed
 

Result of firewall command: "write terminal"

 

Building configuration...

: Saved

:

PIX Version 6.3(5)

interface ethernet0 10baset

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password XA/BRgbbTVgC2AGK encrypted

passwd XA/BRgbbTVgC2AGK encrypted

hostname BT-MASS

domain-name bornemantusa.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list acl_out permit icmp any any 

access-list 102 permit ip 192.168.20.0 255.255.255.0 192.168.10.0 255.255.255.0 

access-list 103 permit ip 192.168.20.0 255.255.255.0 192.168.10.0 255.255.255.0 

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 51.203.190.13 255.255.255.0

ip address inside 192.168.20.254 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location 192.168.10.0 255.255.255.0 outside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 102

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

access-group acl_out in interface outside

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+ 

aaa-server TACACS+ max-failed-attempts 3 

aaa-server TACACS+ deadtime 10 

aaa-server RADIUS protocol radius 

aaa-server RADIUS max-failed-attempts 3 

aaa-server RADIUS deadtime 10 

aaa-server LOCAL protocol local 

aaa authentication ssh console LOCAL

aaa authentication enable console LOCAL

http server enable

http 192.168.20.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

sysopt noproxyarp inside

crypto ipsec transform-set myset esp-3des esp-md5-hmac 

crypto map mymap 10 ipsec-isakmp

crypto map mymap 10 match address 103

crypto map mymap 10 set peer 69.117.177.144

crypto map mymap 10 set transform-set myset

crypto map mymap interface outside

isakmp enable outside

isakmp key ******** address 69.117.177.144 netmask 255.255.255.255 no-xauth no-config-mode 

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption des

isakmp policy 20 hash md5

isakmp policy 20 group 1

isakmp policy 20 lifetime 1000

telnet 192.168.20.0 255.255.255.0 inside

telnet timeout 10

ssh 0.0.0.0 0.0.0.0 outside

ssh 0.0.0.0 0.0.0.0 inside

ssh timeout 10

console timeout 0

dhcpd address 192.168.20.65-192.168.20.96 inside

dhcpd dns 192.168.10.1 

dhcpd wins 192.168.10.1 

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd domain borneman-tusa.com

dhcpd auto_config outside

dhcpd enable inside

username American password 1KQOPRUW6PmwWtww encrypted privilege 15

terminal width 80

Cryptochecksum:372ce37a83d2070bbeac38d7cf4d161c

: end

[OK]

Open in new window

0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 10

Accepted Solution

by:
TekServer earned 250 total points
Comment Utility
Log into Pix, then type (or copy) the attached commands.

Note that the 4th line is probably optional, but I'd put it in anyway.

After the "sh run", check the config before saving it with "wri mem".

:)


ena

conf t

ip add outside 34.234.112.132 255.255.255.0

route outside 0.0.0.0 0.0.0.0 34.234.112.1 1

no dhcpd auto_config outside

exit

sh run

wri mem

Open in new window

0
 
LVL 10

Expert Comment

by:TekServer
Comment Utility
Forgot to mention, I built your config in a simulator (http://www.gns3.net/) and performed the steps I listed to verify them.  It worked fine in that very excellent simulator, so it should work fine in your Pix.

:)
0
 

Author Comment

by:SpinnerAdam
Comment Utility
Wow, your amazing!!! I am going to try it right now and see if it works. Am I able to change the DNS information to what my ISP gave me?
0
 
LVL 10

Expert Comment

by:TekServer
Comment Utility
Assuming you're running your workstations on a Windows domain, I wouldn't change the DNS.  As I mentioned earlier, the DNS setting for DHCP is apparently currently pointing to a Windows server, which is as it should be.  In a domain, if the workstations are looking to a DNS server other than the domain controller (or DNS server for the AD domain), odd and difficult to troubleshoot issues will arise (trust one who knows and spent a couple of weeks finding this out the hard way the first time I encountered it!).

If you wish to use the new DNS server settings for your new ISP, the appropriate place to do that would be in "Forwarders" on your domain DNS server.  This is not really necessary, because DNS servers really don't care who accesses them for lookups, and ISP's generally don't care what DNS servers you use.

However, if you do want to change the settings, go to your DNS server (probably your domain controller), go to Control Panel -> Administrative Tools -> DNS, right-click on the server in the left pane and select "Properties", click on the "Forwarders" tab, then enter the new DNS server IP addresses where it says "Selected domain's forwarder IP address list:" and remove the old entries.  Click "OK" and you're done!

I've attached a screen shot of the Forwarders tab so you can see what it should look like.  I left the DNS addresses visible; they're for Network Telephone and Cox Communications, respectively.

:)
forwarders.JPG
0
 

Author Comment

by:SpinnerAdam
Comment Utility
Ok. I understand now. I just finished updating the settings on the PIX (With no errors!), and next week I will hook up the PIX in my boss's office in MA (I am in NY right now). You have been really great. Thanks so much for everything! I will let you know how everything worked.

-Adam :)
0
 
LVL 10

Expert Comment

by:TekServer
Comment Utility
Glad I could help, and I look forward to a positive report.

Now I suppose I'll have to get back to the work I'm being paid for. ;)

:)
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

When I upgraded my ASA 8.2 to 8.3, I realized that my nonat statement was failing!   The log showed the following error:     %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows It was caused by the config upgrade, because t…
Optimal Xbox 360 connectivity requires "OPEN NAT". If you use Juniper Netscreen or SSG firewall products in a home setting, the following steps will allow you get rid of the dreaded warning screen below and achieve the best online gaming environment…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now