Solved

Windows Deployment Services - "No available image"

Posted on 2008-06-25
8
2,068 Views
Last Modified: 2013-11-14
Hi there all,

First post so take it easy ;)

I'm a senior tech working with a Government department in Australia, we currently have a unattended build working with RIS, build is a SOE or MOE of WinXP with SP2.

Due to some licensing issues we are are looking at using WDS to deploy our images.

I have followed MANY guides on how to set up WDS and we believe we have it set up correctly.

We can: PXE boot to WDS, successfully capture a sysprepped win xp machine and got to the deploy screen. This is where things go wrong. There is no image to deploy once getting to the Install screen from PXE boot. It just says 'No available images'.

The WDS server is a virtual server sitting in a test network we have set up, it has the usual stuff in there, dhcp, active directory, file servers etc... everything that is required to run WDS, but the WDS server is on a separate box. However the network is not 'pristine' in that there has been a lot of development work done in the environment and may not be set up to WDS's liking.

There is also an existing RIS server in the environment, however it has been disabled for the moment while we test WDS. We have updated the scope to forward the requests to the new WDS server.

The WDS is a 2003 SP1 Server box, fresh install with RIS then WDS and the AIK installed.

At the moment there is an issue with DNS not picking the server up, however we have manually added the DNS point into the dhcp/dc boxes.

I guess what i want to know is what, outside of WDS itself, can impact the ability to view or install the images?

The image is online and visible, i have removed the image and re-added it and played with various settings.

We are using a boot.wim file from a Promo version of Vista ultimate at the moment.

I will have a couple of oem copies by tomorrow to try as well.

Any ideas on where to look tomorrow? We will be double checking DNS and the domain controllers as soon as i get to work tomorrow, but I'm not sure what I would be looking for that would impact on the selection of images.

Been searching far and wide for clues, few people have similar issues but no solutions. Hope you can help!

Thanks
Matt
0
Comment
Question by:33driver
  • 4
  • 3
8 Comments
 
LVL 26

Expert Comment

by:Pber
ID: 21865005
Just to get this straight... you can boot the deploy image via PXE.  It should then prompt you for keyboard and language settings, then it will ask you to logon.  Once you do that you are display no images even though you seem active images in the WDS console.

Is the image have the same HAL as the machine you are booting?

If you have x64 or Multi processor kernels as images and if you boot a Uniprocessor kernel machine, WDS won't display images with HALs that are different.

Also make sure the ID you used to logon from the deploy image has read access to your images as WDS will only display images that a user has access to.
0
 

Author Comment

by:33driver
ID: 21869819
hi there pber,

You are on the money at what I am after. I have tried two machines to deploy to, I tried to deploy to the same one I captured from, and another newer machine which I believe has a 64bit cpu, (The one I captured of was a HP DC7100, the 2nd machine is a HP DC7800). Neither of these worked however.

The username id is a domain account so should have full permissions, I will double check that though in case something funny is going on there.

Out of curiosity, once I get this going, how do I get a single image to work accross different HALs? We have maybe 30 different models across the state we support, We really don't want to be doing an image for each machine if possible.
0
 

Author Comment

by:33driver
ID: 21871255
Anyone out there got any ideas? Getting urgent now, I'm just trying the vista ultimate boot.wim file now but I don't think its goign to make a difference
0
 

Author Comment

by:33driver
ID: 21873229
Confirmed that DNS was working after a battle with it today.
WDS is defiantely installed correctly as it is deploying a vista image with no problem.
Looks like we found the problem in the way image captured, even though we captured and deployed to a the same machine,  sysprep decided it was a uniprocessor, which it wasn't, was an old P4 - Hyperthreaded cpu which reports as a multiprocessor.

We forced the sysprep.inf to use the multiprocessor type by added in a line under the 'Unattended' section telling it that the hal is MP not UP.

This was the line we added under the unatended banner:

UpdateHAL = ACPIAPIC_MP,%WINDIR%\Inf\Hal.inf 

Will close this question.
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 26

Accepted Solution

by:
Pber earned 500 total points
ID: 21876447
I don't see why I shouldn't get some points, the first thing I mentioned dealt with incorrect HAL's

"Is the image have the same HAL as the machine you are booting?"

0
 

Author Closing Comment

by:33driver
ID: 31470501
No idea how to do this sorry, let me know if this doesn't work.

THanks
0
 
LVL 26

Expert Comment

by:Pber
ID: 21882844
Worked.
Thanks for the points.
0
 
LVL 1

Expert Comment

by:jbyrd1981
ID: 24119262
33driver could you explain exactly what and how you edited to get it form uniprocessor to multiprocessor?
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

A quick step-by-step overview of installing and configuring Carbonite Server Backup.
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now