Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Disable write cache on ESX 2.5 virtual machine

Posted on 2008-06-25
4
Medium Priority
?
1,509 Views
Last Modified: 2010-04-21
I have a virtual machine (W2K3 SP2 + SQL server) running on an ESX 2.54 host. I want to disable the write cache on the disk which contains the SQL database.
The option which I normally use in the Windows OS is set to "Optimize for performance" and is grayed out to prevent change.
How can I disable the write cache.

Any help is very much appriciated!

Rob
0
Comment
Question by:robv73
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 14

Expert Comment

by:agriesser
ID: 21864886
From the virtual machine side, set the disk type to be independent/persistent, that way, all the changes are permanently and immediately written to the disk.

If you want to disable it inside the guest, you need to modify your .vmx file and probably reboot the guest too:

diskLib.dataCacheMaxSize = "0"
0
 

Author Comment

by:robv73
ID: 21865591
I added this line to the VM config (vmx) file and restarted the VM.
But when I check the "Policies" tab of the disk properties. The option is still set to "Optimize for performance"......which should mean: write cache enabled...

Is this ok?!
0
 
LVL 14

Accepted Solution

by:
agriesser earned 2000 total points
ID: 21865798
According to some forum entries at vmware.com, it shouldn't matter wheter this option is greyed out or not. Windows asks the SCSI disk driver for its features and if the driver (in this case the Virtual VmSCSI driver) does not support write caching on a per-hardware base (which it simply can't support), the option in windows is greyed out. Telling the disklib to not cache data at all should do the trick although it might seem to still be disabled inside the VM.

I don't know how to test if that works, do you see any difference with this option being set?
0
 

Author Closing Comment

by:robv73
ID: 31470511
Thanks for your quick response / help !
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

HOW TO: Install and Configure VMware vSphere Hypervisor 6.5 (ESXi 6.5), Step by Step Tutorial with screenshots. From Download, Checking Media, to Completed Installation.
When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
Teach the user how to delpoy the vCenter Server Appliance and how to configure its network settings Deploy OVF: Open VM console and configure networking:
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question