Solved

Unable to connect to the database STS_Config

Posted on 2008-06-25
10
1,421 Views
Last Modified: 2008-10-01
Running SBS 2003 sp1. Also running BES as a MSDE SQL service.I'm getting this error in my application log every 30 seconds:

Event Type:      Error
Event Source:      Windows SharePoint Services 2.0
Event Category:      None
Event ID:      1000
Date:            6/25/2008
Time:            11:10:11 AM
User:            N/A
Computer:      <servername>
Description:
#50070: Unable to connect to the database STS_Config on <servername>\SharePoint.  Check the database connection information and make sure that the database server is running.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
Comment
Question by:davefeete
  • 4
  • 4
10 Comments
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 21872025
There's all sorts of notes about this here:
http://www.eventid.net/display.asp?eventid=1000&eventno=3491&source=Windows%20SharePoint%20Services%202.0&phase=1

But essentially it points to an incorrect Service Pack installation.

Have you installed all five components of SBS SP1?  (http://sbsurl.com/sp1)
Since that article was written, Windows Server 2003 SP2, Exchange 2003 SP2 and Windows SharePoint Services 2.0 SP3 have been released.  Those can be substituted for their SP1 counterparts in the instructions.  But you still need to install SBS SP1.

Jeff
TechSoEasy
0
 

Author Comment

by:davefeete
ID: 21879441
Thanks for your comment. All those updates were already installed, except Sharepoint SP3, which is now installed. No change. Any other thougths?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 21879470
If they weren't installed in the correct order you can get this type of error.

Please post the output from running SYSTEMINFO at a command prompt.

Jeff
TechSoEasy
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Author Comment

by:davefeete
ID: 21879554
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>systeminfo

Host Name:                 <servername>
OS Name:                   Microsoft(R) Windows(R) Server 2003 for Small Busines
s Server
OS Version:                5.2.3790 Service Pack 2 Build 3790
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Primary Domain Controller
OS Build Type:             Multiprocessor Free
Registered Owner:          <owner>
Registered Organization:   <companyname>
Product ID:                74995-066-4993406-xxxxx
Original Install Date:     12/1/2004, 5:32:46 PM
System Up Time:            6 Days, 9 Hours, 54 Minutes, 16 Seconds
System Manufacturer:       HP
System Model:              ProLiant ML350 G4
System Type:               X86-based PC
Processor(s):              2 Processor(s) Installed.
                           [01]: x86 Family 15 Model 3 Stepping 4 GenuineIntel ~
3200 Mhz
                           [02]: x86 Family 15 Model 3 Stepping 4 GenuineIntel ~
3200 Mhz
BIOS Version:              HP     - 2
Windows Directory:         C:\WINDOWS
System Directory:          C:\WINDOWS\system32
Boot Device:               \Device\HarddiskVolume1
System Locale:             en-us;English (United States)
Input Locale:              en-us;English (United States)
Time Zone:                 (GMT-05:00) Eastern Time (US & Canada)
Total Physical Memory:     2,047 MB
Available Physical Memory: 349 MB
Page File: Max Size:       3,438 MB
Page File: Available:      1,422 MB
Page File: In Use:         2,016 MB
Page File Location(s):     C:\pagefile.sys
Domain:                    <domain>.local
Logon Server:              \\<servername>
Hotfix(s):                 14 Hotfix(s) Installed.
                           [01]: Q147222
                           [02]: KB867460 - QFE
                           [03]: KB886903 - QFE
                           [04]: SP1 - SP
                           [05]: KB870669
                           [06]: Q832483
                           [07]: KB926666 - Update
                           [08]: Q828026
                           [09]: Q828026 - Update
                           [10]: KB885492 - Update
                           [11]: KB889101 - Service Pack
                           [12]: KB914961 - Service Pack
                           [13]: KB831664 - Update
                           [14]: KB872769 - Update
Network Card(s):           1 NIC(s) Installed.
                           [01]: HP NC7761 Gigabit Server Adapter
                                 Connection Name: Server Local Area Connection
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 192.168.0.2
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 21879855
Well it does seem as though you are missing a ton of updates... far too many for me to try and list.

That aside, I would also want you to check to make sure that the SharePoint Timer Service is running and is configured to run under the "NT AUTHORITY\NETWORK SERVICE" account.

Jeff
TechSoEasy
0
 

Author Comment

by:davefeete
ID: 21880464
Thanks, I will check all Windows updates. You're right about STS being off, I shut it down for a while because it was taking up my whole app log and I wanted to make sure nothing else was wrong. It always has run as the network service login though.
0
 

Author Comment

by:davefeete
ID: 21884226
Ran all the windows updates, here's the current systeminfo:

Errors still happening.

----------------------------------------------------------------------------------------------
Host Name:                 <servername>
OS Name:                   Microsoft(R) Windows(R) Server 2003 for Small Busines
s Server
OS Version:                5.2.3790 Service Pack 2 Build 3790
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Primary Domain Controller
OS Build Type:             Multiprocessor Free
Registered Owner:          <owner>
Registered Organization:   J&M Realty
Product ID:                74995-066-4993406-xxxxx
Original Install Date:     12/1/2004, 5:32:46 PM
System Up Time:            0 Days, 1 Hours, 46 Minutes, 44 Seconds
System Manufacturer:       HP
System Model:              ProLiant ML350 G4
System Type:               X86-based PC
Processor(s):              2 Processor(s) Installed.
                           [01]: x86 Family 15 Model 3 Stepping 4 GenuineIntel ~
3200 Mhz
                           [02]: x86 Family 15 Model 3 Stepping 4 GenuineIntel ~
3200 Mhz
BIOS Version:              HP     - 2
Windows Directory:         C:\WINDOWS
System Directory:          C:\WINDOWS\system32
Boot Device:               \Device\HarddiskVolume1
System Locale:             en-us;English (United States)
Input Locale:              en-us;English (United States)
Time Zone:                 (GMT-05:00) Eastern Time (US & Canada)
Total Physical Memory:     2,047 MB
Available Physical Memory: 1,056 MB
Page File: Max Size:       3,438 MB
Page File: Available:      1,615 MB
Page File: In Use:         1,823 MB
Page File Location(s):     C:\pagefile.sys
Domain:                    domain.local
Logon Server:              \\servername
Hotfix(s):                 99 Hotfix(s) Installed.
                           [01]: File 1
                           [02]: File 1
                           [03]: File 1
                           [04]: File 1
                           [05]: File 1
                           [06]: File 1
                           [07]: File 1
                           [08]: File 1
                           [09]: File 1
                           [10]: File 1
                           [11]: File 1
                           [12]: File 1
                           [13]: File 1
                           [14]: File 1
                           [15]: File 1
                           [16]: File 1
                           [17]: File 1
                           [18]: File 1
                           [19]: File 1
                           [20]: File 1
                           [21]: File 1
                           [22]: File 1
                           [23]: File 1
                           [24]: File 1
                           [25]: File 1
                           [26]: File 1
                           [27]: File 1
                           [28]: File 1
                           [29]: File 1
                           [30]: File 1
                           [31]: File 1
                           [32]: File 1
                           [33]: File 1
                           [34]: File 1
                           [35]: File 1
                           [36]: File 1
                           [37]: File 1
                           [38]: File 1
                           [39]: File 1
                           [40]: Q147222
                           [41]: KB867460 - QFE
                           [42]: KB886903 - QFE
                           [43]: KB933854 - QFE
                           [44]: SP1 - SP
                           [45]: KB870669
                           [46]: Q832483
                           [47]: KB912442 - Update
                           [48]: KB916803 - Update
                           [49]: KB924334 - Update
                           [50]: KB926666 - Update
                           [51]: KB931832 - Update
                           [52]: Q936181
                           [53]: Q828026
                           [54]: Q828026 - Update
                           [55]: KB925398_WMP64
                           [56]: KB885492 - Update
                           [57]: KB889101 - Service Pack
                           [58]: KB914961 - Service Pack
                           [59]: KB924667-v2 - Update
                           [60]: KB925902 - Update
                           [61]: KB927891 - Update
                           [62]: KB929123 - Update
                           [63]: KB930178 - Update
                           [64]: KB931784 - Update
                           [65]: KB932168 - Update
                           [66]: KB933729 - Update
                           [67]: KB933854 - Update
                           [68]: KB935839 - Update
                           [69]: KB935840 - Update
                           [70]: KB936021 - Update
                           [71]: KB936357 - Update
                           [72]: KB936782 - Update
                           [73]: KB938127 - Update
                           [74]: KB938759-v4 - Update
                           [75]: KB941202 - Update
                           [76]: KB941569 - Update
                           [77]: KB941644 - Update
                           [78]: KB941672 - Update
                           [79]: KB941693 - Update
                           [80]: KB942763 - Update
                           [81]: KB942830 - Update
                           [82]: KB942831 - Update
                           [83]: KB943055 - Update
                           [84]: KB943460 - Update
                           [85]: KB943485 - Update
                           [86]: KB944338 - Update
                           [87]: KB944653 - Update
                           [88]: KB945553 - Update
                           [89]: KB946026 - Update
                           [90]: KB948496 - Update
                           [91]: KB948590 - Update
                           [92]: KB948745 - Update
                           [93]: KB949014 - Update
                           [94]: KB950759 - Update
                           [95]: KB950760 - Update
                           [96]: KB950762 - Update
                           [97]: KB951698 - Update
                           [98]: KB831664 - Update
                           [99]: KB872769 - Update
Network Card(s):           1 NIC(s) Installed.
                           [01]: HP NC7761 Gigabit Server Adapter
                                 Connection Name: Server Local Area Connection
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 192.168.0.2
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 500 total points
ID: 21887393
Well that looks much better.  But if it is still not connecting, at this point I'd remove the SharePoint extensions from the companyweb site, and then re-extend it.  Generally that will resolve issues like this.

Jeff
TechSoEasy
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Have you considered what group policies are backwards and forwards compatible? Windows Active Directory servers and clients use group policy templates to deploy sets of policies within your domain. But, there is a catch to deploying policies. The…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question