• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 361
  • Last Modified:

Exch2003 - Allow mail relaying to a single external domain

Hello -
We (companya.com) have a partner organization that we work with (companyb.com). Some of CompanyB's employees have AD accounts here with Exchange mailboxes. They then requested that their mail redirect back to their home (CompanyB) mailbox, so a contact was created for them, and the exchange settings for their account were then changed to forward mail to their contact rather than keep it locally. Not the most graceful perhaps, but should work.

The problem I am having is some people from CompanyB want to send email to one of our distribution lists (list@companya.com). This list contains some members of our domain that forward their mail back to companyB. When sending to these lists, the sender gets an SMTP 5.7.1 error indicating that relay is denied. Makes sense since companyb.com is an external domain that my mail server should not relay to by default.

To try and work around this, I created an SMTP Connector under 'Routing Groups' that lists companyb.com as the namespace, checked the box for 'allow relaying' and assigned a bridgehead server to the connection. For some reason I am still unable to send mail from outside the company to this dist list, still getting the relaying error.

How can I setup my exch environment to allow mail relaying to just this one domain?

thanks
0
JammyPak
Asked:
JammyPak
  • 2
  • 2
1 Solution
 
uid94130Commented:
Check the SMTP connector to see which servers are set to be Local bridgehead servers.

On the SMTP virtual server of the bridgehead servers: You could add the IP address of the server that sends the messages from CompanyB into the allowed relay list.
0
 
JammyPakAuthor Commented:
I've tried that now, but it still gives the same relay error...smtp 5.7.1. Any other suggestions?
0
 
uid94130Commented:
In this case, check the Internet header of a message coming from companyB and see what is the IP address of the server that sends the messages to your server. Add this IP in the allowed relay list.
The Internet header can be viewed from Outlook (open one received message and choose from the menu View / Options)
0
 
JammyPakAuthor Commented:
I found the one remaining issue that was blocking me - restrictions had been set on the dist list itself controlling who could send to it. All seems to work now, thanks.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now