Solved

1841 and NAT

Posted on 2008-06-25
3
1,282 Views
Last Modified: 2012-08-13
Hi,

I have a problem with setting Nat to work on Cisco 1841. I've tested the configuration with ios: c1841-adventerprisek9-mz.124-19.bin and c1841-entbasek9-mz.124-19.bin. I include configuration of the router. Whats more command debug ip nat does not show any traffic and it should - on XP i'm getting timeout when i ping a host in the internet. Can you please help me?

One other think maybe it will be helpful command debug all gives me a couple of lines i'm worried about this:

*Jun 25 22:35:04.039: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.039: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.251: CEF: background resolution thread state:
*Jun 25 22:35:04.251: Thread fast_thread: Empty
*Jun 25 22:35:04.251: Thread todothread: Empty
*Jun 25 22:35:04.251: Thread slow_thread: Empty
*Jun 25 22:35:04.251: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_data_syslog: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_syslog_event_match: num_matches = 0
*Jun 25 22:35:04.251: fh_fd_data_syslog: num_matches = 0


Router#show run

Building configuration...
 

Current configuration : 975 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash c1841-entbasek9-mz.124-19.bin

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

!

!

!

!

!

bridge irb

!

!

interface FastEthernet0/0

 ip address XXX.XXX.XXX.XXX 255.255.255.224

 ip nat outside

 duplex auto

 speed auto

!

interface FastEthernet0/1

 ip address YYY.YYY.YYY.YYY 255.255.255.0

 ip nat inside

 duplex auto

 speed auto

!

interface Serial0/0/0

 no ip address

 shutdown

 clock rate 2000000

!

interface Serial0/1/0

 no ip address

 shutdown

 clock rate 2000000

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 ZZZ.ZZZ.ZZZ.ZZZ

!

ip http server

no ip http secure-server

ip nat source list 10 interface FastEthernet0/0 overload

!

access-list 10 permit any

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

 login

scheduler allocate 20000 1000

end

Open in new window

0
Comment
Question by:kamsuj
3 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 21871344
Change line 57 from

ip nat source list 10 interface FastEthernet0/0 overload

to

ip nat inside source list 10 interface FastEthernet0/0 overload
0
 
LVL 2

Expert Comment

by:rtptucks
ID: 21874324
you need to specify an IP rang to NAT

such as


ip nat inside source list 100 interface Fastethernet0/0 overload
!
access-list 100 permit ip 192.168.0.0 0.0.255.255 any


obviously changing the 192.168.0.0 to your correct LAN subnet

Regards
0
 
LVL 3

Author Closing Comment

by:kamsuj
ID: 31470796
This worked. Thank you.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Internet Speed Test 5 101
Multicast in a layer 2 to layer 3 migration 1 52
WAN Site Edge Routers 15 50
Classlful vs Classless subneting 18 63
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now