Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2962
  • Last Modified:

How to remove "outdate java runtime environment" warning?

I am using an application that requires JRE 1.5.0_xx. If a valid JRE 1.5.0_xx is installed but not necessary the highest JRE 1.5.0_xx and JRE 1.6 is installed when I go to the website application that needs to use 1.5... I will get the following error popup box. See Attachement. This box will continue to popup everytime an java call is made.

"outdated java runtime environment" would you like to install the lasted 1.5.0 JRE... This would be fine except users are not admins of their workstations and can not upgrade. Is there a way to disable the warning that seems to be coming from java 1.6 being installed. I am not looking to just uninstall 1.6. It is possible that 1.6 and 1.5 is needed on the system.
javaerrorbox.bmp
0
jrmcnulty
Asked:
jrmcnulty
  • 3
2 Solutions
 
Christopher MartinezCommented:
Try to open up the console and see if you can disable the Notifications. If that doesnt work, im afraid there is no real solution. Pulled from Sun.com

When a JRE family is specified, the Java Plug-in software looks for the latest release of that family that is currently installed. The Java Plug-in software prefers a release that is equal to or later than the security baseline for that JRE family.

The security baseline consists of the version number of the latest release for each JRE family that is available when the latest JRE family is built. For example, when the JRE 5.0 Update 7 release was built, the security baseline for the 5.0 JRE family was 5.0 Update 7. For the 1.4.2 JRE family, the security baseline was 1.4.2_10. Starting with the JRE 5.0 Update 7 release, the security baseline information is included in each release of the most current JRE family.



http://java.sun.com/javase/6/webnotes/family-clsid.html
0
 
MicheleMarconCommented:
Look here:

http://java.sun.com/developer/technicalArticles/javase/java6u10/index.html#dt

If you have something like this on the html, then the html page itself is declaring 1.6 as a requirement for the applet.

  deployJava.runApplet({codebase:"http://www.example.com/applets/",
     archive:"ExampleApplet.jar", code:"Main.class",
     width:"320", Height:"400"}, null, "1.6");

Change the 1.6 to 1.5.
0
 
jrmcnultyAuthor Commented:
Bahpoopie,
That is what I was afraid of. I was reading that information from Sun as well.

MicheleMarcon,
I get what you are saying, but the sites are thired party vendor sites. I don't have the ability to tell them to use one java over another.

I am going to leave the question open for a little while longer then close it.... Thanks for the information so far.
0
 
jrmcnultyAuthor Commented:
Split the points, because nobody was wrong, just not really the solution that I was looking for. Thanks again.
0
 
jrmcnultyAuthor Commented:
Okay, closed the question. Split up the points because each was right, but not the answer I was hoping for.

Thanks again.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now