• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 381
  • Last Modified:

Why won't my scheduled task run?

Hi
I have 2 scheduled tasks. Only Task A works.
Task A calls .net program that extracts data into a csv file and places on C drive.
Task B calls .net program that  takes the extracted data and uploads to an internet site.

Both tasks did run before the administrator password was changed. I have since changed password on both these tasks and only the first one works.

Things I've tried:
run manually  - Task B works if run manually from command line.
setup Task A in same directory as Task B - Task A worked.
re-added Task B - still did not work.
Checked security on Properties - Task B  has full access.

My question is how do I get Task B to work and where should I look Re security issues etc.
Thanks
0
cmrnp
Asked:
cmrnp
  • 3
1 Solution
 
Christopher MartinezCommented:
Anything in system log with a error report?
0
 
cmrnpAuthor Commented:
Nothing in Event viewer at all after I run Task B.
The reason I know it has run or not is it produces a text file with results.
0
 
greyknight17Commented:
Are the two tasks running at the same time? if so, try to give task A more time to extract the data before scheduling task B to run.
0
 
cmrnpAuthor Commented:
No. - They are half an hour apart.
The file for Task B already exists and is run by itself.
0
 
cmrnpAuthor Commented:
I placed Scheduled task Commands within a batch file instead then ran the batch file as the task.

This worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now