Solved

How to change OWA address so I don't have to type /exchnage?

Posted on 2008-06-25
28
386 Views
Last Modified: 2011-10-19
Usually when I use OWA, I type http://mail.mydomain.com/exchange
Is it possible that just by typing http://mail.mydomain.com/ and I go to the login page?

I use ISA as my firewall. I am wondering I should do the configuration there...
0
Comment
Question by:wuitsung
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 13
  • 11
  • 2
  • +1
28 Comments
 
LVL 19

Expert Comment

by:bevhost
ID: 21871291
So you don't have a web page at the top level?
in IIS Manager right click on default web site and choose properties
Goto Home director Tab
Change to "A redirection to another URL"
Enter the http://whatever/exchange

0
 

Author Comment

by:wuitsung
ID: 21871323
Thank you for your reply. Are we suppose to have a top page within exchnage? I tried to type in hostname/exchange insdie my network, i got nothing there
0
 
LVL 19

Expert Comment

by:bevhost
ID: 21871342
No you certainly don't have too and there isn't one by default.
You might put something there if you wanted to.
But it sounds like you didn't.
0
Backup Solution for AWS

Read about how CloudBerry Backup fully integrates your backups with Amazon S3 and Amazon Glacier to provide military-grade encryption and dramatically cut storage costs on any platform.

 
LVL 19

Expert Comment

by:bevhost
ID: 21871350
You may need to use name.servername.local/exchange internally.
Of you may prefer to make the external name work internally.
0
 

Author Comment

by:wuitsung
ID: 21871365
By the way, after I enter into redirect to http://whatever/exchange, there is a window pop up asking for the inheritance overrides. Should I select all or just the specific folder or nothing?

0
 
LVL 19

Expert Comment

by:bevhost
ID: 21871380
I just chose default.htm
0
 
LVL 19

Expert Comment

by:bevhost
ID: 21871389
If your server has mor ethan one name or if you use the IP address then you should redirect to /exchange as " a directory below the URL entered"
0
 

Author Comment

by:wuitsung
ID: 21871418
By the way, I think I screwed up one thing.. Do you know what's the default Exadmin path? I think I changed it accidentally..
0
 
LVL 19

Expert Comment

by:bevhost
ID: 21871453
\\.\BackOffice\Storage
0
 

Author Comment

by:wuitsung
ID: 21871493
I think it's \\.\BackOfficeStorage Not "\\.\BackOffice\Storage"

And here is the setting I did.. still not working.


ex.JPG
0
 

Author Comment

by:wuitsung
ID: 21871505
It show the Under Construction page

0
 
LVL 19

Expert Comment

by:bevhost
ID: 21871606
You're right it is BackOfficeStorage with no slash,
sorry about that.
BTW, It doesn't redirect to that, it should come from...
"a folder located on this computer"
0
 
LVL 19

Expert Comment

by:bevhost
ID: 21871627
try changing it to be redirected /exchange
and tick the boxes
a folder below the entered URL
permanent redirect
0
 

Author Comment

by:wuitsung
ID: 21871780
you mean in "Redirect to", just type in "/exchange" ?

I just did this... nto working.. Have you tried the same thing on your exchange? Is it working?
0
 
LVL 19

Accepted Solution

by:
bevhost earned 300 total points
ID: 21871827
see pic
exchange.JPG
0
 

Author Comment

by:wuitsung
ID: 21871858
Did you chnage this only on the property of "Exchange" folder or the "Default web page" ? I just tried it on the "Exchange" folder .. still not working..

I tested using the http://exchnage_server.domain.local

also I tried the internet namespace http://exchnage_server.domain.com

I still get "Under Construction"...
0
 

Author Comment

by:wuitsung
ID: 21871873
same for trying the IP address of my exchnage server http://10.0.1.1 (My exchange server ip)
0
 
LVL 19

Expert Comment

by:bevhost
ID: 21872068
You must redirect the Default Web Page, not the exchange page.
0
 
LVL 19

Expert Comment

by:bevhost
ID: 21872073
Your exchange properties needs to point to

a folder on this computer
\\.\BackOfficeStorage\yourdomain.whatever\MBX
0
 
LVL 3

Expert Comment

by:prav007
ID: 21872189
Step 1

On the Exchange server open up the Internet Service Manager In the Default Web Site Properties
choose a redirection to the URL

in the URL path type in "http:\\<your exchange server name>\exchange

Second option on the ISA box

Open up the Default Web site properties and try to do the same thing mentioned in step 1
0
 
LVL 3

Expert Comment

by:prav007
ID: 21872268
Also in the future if you goof up your Exchange OWA/IIS folder paths refer to this article

http://www.msexchange.org/tutorials/Resetting-OWA-Folder-IIS-security-permissions-Exchange-2003.html
0
 
LVL 3

Expert Comment

by:vsganesh
ID: 21872373
Hi wuitsung,

1) Create filename called "redirect.htm" using notepad and type "redirect" (without quote) in the content of the file and save the file in the "Default webstie root" folder. (c:\inetpub\wwwroot)

2) Go to IIS Manager -> Default website -> Look for the redirect.htm" file and goto properties of the file.
    - Choose "A redirection to a URL
    - Type /exchange under "Redirect to" and click ok

3) Go to properties of "Default website", select "documents" and click on "Add" button under the "Enable default content page".  Here type redirect.htm and make sure this page name (redirect.htm) is in the top/first and should be above Default.htm.

4) Restart the IIS

Thats all, now you try by FQDN, or IP address and you will be able to acces OWA with putting "/exchange"...
0
 
LVL 3

Expert Comment

by:vsganesh
ID: 21872377
Thats all, now you try by FQDN, or IP address and you will be able to acces OWA without putting "/exchange"...
0
 

Author Comment

by:wuitsung
ID: 21877012
Thank you bevhost!! It's working now!!
But I am still not clear with the way you are doing..
1)When you type in "Redirect to a URL" -> /exchnage
Because you also checked the "A directory below URL entered".... Does this mean in the Inetpub\wwwroot ?  But Exchange files are not here.

2) What does a permanent redirection for this resource mean?
0
 
LVL 19

Expert Comment

by:bevhost
ID: 21879513
1. /exchange is what you want added to the url that is typed in the browser.
2. permanent means that the change can be cached, ie not a temporary redirect.
0
 

Author Comment

by:wuitsung
ID: 21879600
it's cached to where? on the user's computer?

And if  I want to avoid typing https, is it the same mthod that I can use to accomplish?
0
 
LVL 19

Expert Comment

by:bevhost
ID: 21880236
It would normally only be cached at a proxy server as far as I know.
You don't need to worry about the https.
The /exchange folder has content that redirects to https anyway.
0
 

Author Comment

by:wuitsung
ID: 21881195
Hi bevhost, I just installed SSL certificate. But when I type in my server name srv-1 in the address bar, it still ask me to type in https.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
In-place Upgrading Dirsync to Azure AD Connect
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question