Strange Maxtor disk problem

i have a very strange problem with this maxtor IDE disk model 91301U3  capacity 13 Gb

if i set the jumper to MASTER or CABLE SELECT  it has following problems :
-it takes about 30 seconds to detect /or show the ide disk in the post screen, or to get into the BIOS setup
-it displays normally, proper model, size, etc...
-it does NOT boot from disk, but displays "Reboot and select proper boot device"

IF I SET THE JUMPER TO SLAVE, everything is normal (fast bios access, it boots without problems after displaying "No master ide drive found")

when i try this with 2 other Maxtor 40 GB disks, they work normal with Master /slave settings
i am upgraded to the latest bios version, and try the default settings also

Any ideas ?



LVL 94
nobusAsked:
Who is Participating?
 
Gary CaseRetiredCommented:
The most likely issue here is a defective cable => try another cable (you could also unplug/replug the current cable at both ends to be sure it's not just a "seating" problem).   This could also be caused by a very unlikely failure of the drive to respond to the Master setting ... or by an equally strange failure of the IDE controller (although you've eliminated this possibility by successfully testing with other drives).

Whether it's a 40 or 80 pin cable doesn't matter --> at least not for the drive recognition issue (a 40 pin cable WILL slow down the transfer speeds from UDMA66 to UDMA33 ... but won't have any impact on the drive's recognition).
0
 
dbruntonCommented:
Position on cable?  Is it at middle or end of cable?
0
 
nobusAuthor Commented:
end of cable
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
nobusAuthor Commented:
i must add that the short and long diagnostic of maxtor tests the drive without problems as healthy !
0
 
dbruntonCommented:
40 or 80 pin cable?

For 80 pin cable at end it should be master and not slave.

For 40 pin cable at end it should be slave.  Check for twist in cable.
0
 
dbruntonCommented:
Ignore  "Check for twist in cable."  Mind was elsewhere.
0
 
Gary CaseRetiredCommented:
... also look very carefully at both the motherboard and the drive to see if any pins are loose and/or not projecting fully on the connections.

In the FWIW category, there's no technical issue with simply running the drive as a slave => you can probably even eliminate the "no Master found" message by turning off auto-detect in the BIOS and simply setting the parameters for the drive on the slave channel (16 - 63 - 12407).   But I'd certainly try another cable first ... that's very likely to resolve the problem.
0
 
nobusAuthor Commented:
>>  The most likely issue here is a defective cable => try another cable    <<   i tried that already with the idea 'you never know'
>>  a very unlikely failure of the drive to respond to the Master setting    << it is recognised in the bios correct as master, BUT the maxtor diag did NOT see it as master also
>>  Whether it's a 40 or 80 pin cable doesn't matter    <<   correct imho
>>   also look very carefully at both the motherboard and the drive to see if any pins are loose   << i did; nothing wrong at close inspection

**i had just tested it on an older mobo with the BIOS 'Auto detect IDE drives'  and it does the same, so it is definitely the disk which is NOT identifying the drive as M or C/S, but OK as Slave

never had that before -  any last thoughts before closing this weird  issue?

btw - thanks to all for twisting the mind over this one !
0
 
nobusAuthor Commented:
>>   simply setting the parameters for the drive    <<   will try this later as M and S too
0
 
Gary CaseRetiredCommented:
Clearly since the drive exhibits the same issue on another PC the problem is the drive is simply not responding correctly to Master or Cable Select settings.   Assuming you need to use this drive [rather than simply replace it with a more modern much larger drive :-) ]  I'd simply set it to the Slave setting and either live with the "No Master ... found" message, or see if you can eliminate that by setting the BIOS to Manual for that channel and specifying the drive's parameters on the slave channel (as I looked up for you earlier).
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.