Solved

LTPA cookie not set

Posted on 2008-06-26
6
810 Views
Last Modified: 2013-12-10
I am  trying the SSO using LTPA. I have Websphere 6.1 ND and created two profiles and each has the same LDAP as the Federated Repository. I enabled LTPA as per the documentation.
The servers are running on 9080 and 9081 ports.
I installed the PlantsByWebsphere sample application and changed the URL for a link within the page to point to other server.
For example, Assuming I am on 9080/PlantsByWebsphere, the link to 'Help' within the page is '9081/PlantsByWebsphere'.

I noticed that after authentication by first server, the LTPA cookie is not set. Hence, the SSO is not working.  

I could not find any help for this in the internet - for the reason that LTPA is not set. Did I miss any step?

Have been sruggling with this for about a day.

 


0
Comment
Question by:pattabi23in
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 41

Expert Comment

by:HonorGod
ID: 21882508
0
 

Author Comment

by:pattabi23in
ID: 21898809
Yes. verified and I just followed the steps. BTW, I am not using a separate HTTP Server.
I have not enabled SSL for the server. Would that matter?
0
 

Author Comment

by:pattabi23in
ID: 21899017
I noticed that the LTPA cookie is set only when accessing the Admin Console but not while running the application
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 41

Expert Comment

by:HonorGod
ID: 21921601
No, LTPA does not require either SSL, or a stand-alone web server.

However, I presume that you are using this as a learning experience, rather than as
a "real" (i.e., production) system environment.  Right?

0
 

Author Comment

by:pattabi23in
ID: 21923996
It is for PoC as we wanted to go real after this. I have opened a Websphere ticket and it is in Level 3 now.
0
 

Accepted Solution

by:
pattabi23in earned 0 total points
ID: 22233384
The IBM support has come back saying that the LTPA is set only for a protected resource and would not be set for unprotected even when the authentication is forced.  IBM says it is by design though - http://docs.sun.com/source/816-6688-10/websphere.html - states that as a limitation.
0

Featured Post

Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

-Xmx and -Xms are the two JVM options often used to tune JVM heap size.   Here are some common mistakes made when using them:   Assume BigApp is a java class file for the below examples. 1.         Missing m, M, g or G at the end …
Most of the developers using Tomcat find it easy to configure the datasource in Server.xml and use the JNDI name in the code to get the connection.  So the default connection pool using DBCP (or any other framework) is made available and the life go…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question