Solved

VMware internet connection problem

Posted on 2008-06-26
6
1,843 Views
Last Modified: 2013-12-27
My main operating system is windows xp sp2
I installed vmware workstation 5, and installed in it solaris 10 from sun,
my problem that i can't connect to the internet from this solaris hosted OS. and always see that the ip in the solaris system is 127.0.0.1 means its always looking local not to the net connection

i attached some screen shots and .vmx file for the vmware.


Thanks,
solaris10.txt
1.png
2.png
3.png
4.png
5.png
6.png
7.png
8.png
9.png
10.png
0
Comment
Question by:amrelgarhy
  • 3
  • 2
6 Comments
 
LVL 10

Expert Comment

by:Casey Herman
ID: 21876629
I would honestly look at your sun install and check to see what adapters that the sun solaris is seeing.
If you use bridge mode in vmware it pretty much always passes the right info for the network adapter to the guest os.

Casey
0
 

Author Comment

by:amrelgarhy
ID: 21877346
so, what can i do?
11.png
0
 
LVL 11

Expert Comment

by:donmanrobb
ID: 21892857
On the page of screenshot 7, make a new bridge that uses your NIC directly say VMNet2. Then change the VM to use VMNet2 as its connection. Can't remember the menu but on the bottom right there will be a picture of a NIC, right click and choose properties and it should be under there.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 

Author Comment

by:amrelgarhy
ID: 21894535
sure you meant screen shot 7? didn't find what you said?
please help
0
 
LVL 11

Accepted Solution

by:
donmanrobb earned 160 total points
ID: 21894563
Under Host Virtual Network Mapping

Right now VMNet2 should say Not bridged, if you click the drop down you should have a choice of VMware adapters and your real NIC, choose your real NIC and click OK.

Then when your starting your VM on the bottom right there will be a NIC icon, right click and choose properties then choose VMNet2 as the connection. This will bypass NAT and all that good stuff, if it still doesn't work we might need to have a look into the Solaris config.
0
 
LVL 11

Expert Comment

by:donmanrobb
ID: 21894574
You can also do the last step from screenshot 4 on the settings window. Change from NAT to custom and choose the new connection.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
It Is not possible to enable LLDP in vSwitch(at least is not supported by VMware), so in this article we will enable this, and also go trough how to enabled CDP and how to get this information in vSwitches and also in vDS.
Teach the user how to convert virtaul disk file formats and how to rename virtual machine files on datastores. Open vSphere Web Client: Review VM disk settings: Migrate VM to new datastore with a thick provisioned (lazy zeroed) disk format: Rename a…
Teach the user how to install log collectors and how to configure ESXi 5.5 for remote logging Open console session and mount vCenter Server installer: Install vSphere Core Dump Collector: Install vSphere Syslog Collector: Open vSphere Client: Config…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now