[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Setting a logon.bat to change My Documents Target

Posted on 2008-06-26
5
Medium Priority
?
1,480 Views
Last Modified: 2013-11-05
I've got Windows Server 2003 running as a primary Domain Controller and when it comes to setting up users, i've got a logon.bat that attaches network drives/printers to the target user. As i wish the files stored in My Documents to be located on a remote server via Network Drive, would it be possible to add a line in the logon batch file that automatically changes the client PC's My Documents target folder to a network drive?

Thanks
All help appreciated
0
Comment
Question by:pbninja101
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 13

Expert Comment

by:TheCapedPlodder
ID: 21876014
I'm not sure if this can be done via batch scripting.

You can definitely do it with a group policy object using the following setting:

User Configuration\Windows Settings\Folder Redirection\My Documents

Cheers,

Plod
0
 
LVL 8

Expert Comment

by:rjwesley
ID: 21876193
User Configuration > Windows Settings > Folder Redirection > Right click My Documents. I alway recommend not to use the default domain policy

I've got mine at Setting Basic - Redirect everyone's folder................
and the Target folder location - set to Redirect to the user's home directory..........

In AD Users and Computers > right click a username > Profile tab > Set the Home folder (\\servername\sharename\username) (using %username% - will create the directory and set permissions automatically), also type in the name of your logon.bat in the User profile > Logon script location and do this for all users.

Rob

0
 
LVL 8

Accepted Solution

by:
rjwesley earned 500 total points
ID: 21876234
One other item:

Your logon.bat file should include the line:
NET USE U: /HOME
U being the same drive letter you chose in the Home folder setting for all users (use the same drive letter for all users).

Rob
0
 
LVL 4

Expert Comment

by:Wiired
ID: 21876249
net use H: /home
0
 
LVL 1

Author Comment

by:pbninja101
ID: 21876328
Thanks Rob, problem sorted.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After seeing many questions for JRNL_WRAP_ERROR for replication failure, I thought it would be useful to write this article.
Microsoft Office 365 is a subscriptions based service which includes services like Exchange Online and Skype for business Online. These services integrate with Microsoft's online version of Active Directory called Azure Active Directory.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question