Solved

SSL certificate is wildcard and non-windows browsers show as invalid certificate

Posted on 2008-06-26
5
510 Views
Last Modified: 2013-12-07
Our mail exchange administrator via GoDaddy purchased our SSL certificates as *.companyname.com

instead of servername.companyname.com

I can see the reasoning so that the certificate can toggle between various servers, yet FireFox and Safari browsers cannot identify the trusted certificate *.companyname.com with the sites defined servername.

Somewhere I read that via PowerShell in Exchange we can run a command so that *.companyname.com reflects as a trusted certificate
0
Comment
Question by:PROJHOPE
  • 2
  • 2
5 Comments
 
LVL 5

Accepted Solution

by:
danengle earned 400 total points
ID: 21877124
You need to ensure those non-windows browsers have godaddy.com added as a trusted root CA.

http://en.wikipedia.org/wiki/Certificate_authority
http://en.wikipedia.org/wiki/Root_certificate
0
 
LVL 17

Assisted Solution

by:fgrushevsky
fgrushevsky earned 100 total points
ID: 21877148
we use wildcard certificates with no problem , the Firefox that I am using identifies certificates as valid "SSL Server Certificate". where exactly do you see as "non trusted" when you use FF?
0
 

Author Comment

by:PROJHOPE
ID: 21877745
I am on the new Firefox 3.0 and trying to get to our sharepoint site I am stopped when I enter in the URL and hit enter

I do not get the pop up to allow or trust.  

I went to the Exchange server I exported the Trusted GoDaddy Ceritificate and also the private key (pfx)

In Firefox I went to preferences security and tried to import the Trusted GoDaddy.cer file...stated it already existed...

Ok so it isn't GoDaddy but our servers...so I go to Personal and import the private key

Successful.  When I close and reopen the browser I am shown again the untrusted certificate.


0
 
LVL 5

Expert Comment

by:danengle
ID: 21877890
when you close and reopen the browser, is the private key still present?  

Did you upgrade to FF3.0 from an older version or a clean install?  If upgrade, try a clean install and see if that remedies the situation.  It's possible some setting from the old version isn't working properly.  
0
 

Author Comment

by:PROJHOPE
ID: 21903058
The problem is our *.companyname.  We are a mixed environment and thus to keep everyone happy we are going to pay the $30.00 to get server specific SSL certificates.

Thanks All
0

Featured Post

Want to promote your upcoming event?

Attending an event? Speaking at a conference? Or exhibiting at a trade show? Easily inform your contacts by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Since pre-biblical times, humans have sought ways to keep secrets, and share the secrets selectively.  This article explores the ways PHP can be used to hide and encrypt information.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now