Solved

During drive rebuild; drive status goes into que state.

Posted on 2008-06-26
9
436 Views
Last Modified: 2011-10-19
I have a Novell 6.5 server that had a failed drive; I replaced the drive and the rebuild proceeded as normal. At about the 21% of the rebuild the drive goes into a que status and then back to a ready for recovery in the HP Smart Array Online Config Util. It is showing no failed drives and all drives are present. Could this be a firmware related issue?

Queued-Snapshot1..doc
0
Comment
Question by:smartin36
  • 3
  • 3
9 Comments
 
LVL 35

Expert Comment

by:ShineOn
ID: 21880141
NetWare 6.5.

Novell is a company - it doesn't come in numeric versions.

That said, NetWare 6.5 is incidental to this issue, in my humble opinion.  This is a hardware thing, and might actually not be a problem.  Hard to say for sure without a tad more info.

What is the RAID controller model?  What is the RAID level you're using?  How many drives?  Any hot spares?  Have you checked the array by booting to the RAID controller utilities rather than via the online utility?
0
 

Author Comment

by:smartin36
ID: 21970108
I was able to upgrade the firmware and that resolved my issue.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 21977169
Technically speaking, if the fix was a firmware update, presumably on the RAID controller, then the statement in my comment "This is a hardware thing ..." is correct, and the Asker did not answer any pertinent questions about the hardware, or whether they tried the RAID controller utilities at boot time rather than via the online utility - answers to which might well have led directly to a harware provider's support site and an answer of "update the firmware."

It's not beyond imagination that the Expert questions asked prompted the Asker to follow that path, resulting in the firmware update.

Unless the rules have changed on questions/answers and how to close, I don't see that deleting it is a valid request.  It would be better to post back controller model and original/new firmware rev level (assuming it was the controller's firmware) and PAQ it for posterity.
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Accepted Solution

by:
smartin36 earned 0 total points
ID: 21984095
The firmware issue was related to the MB. The firmware on the array was up to date. I went on and updated the firmware that was required. I then rebooted the server and proceeded to check the array utility and the drive was in the process of rebuilding. I assumed the drive would fail to rebuild because it had failed to rebuild previously with the up to date firmware on the array. But to my suprise the drive rebuilt successfully. I used the firmware maintance CD  ...firmware 8.00 zip Feb 11, 2008 for Netware 6.5. I did not follow the experts questions to determine the path to follow I had already presummed it was firmware related and was only looking for a yes or no response to confirm what I had already suspected.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 21985113
Recommend {http:#a21984095} for paq with refund, and thank you to smartin36 for posting back the actual situation.

smartin36 - just to be clear, I understand you asked if it could be firmware-related, but didn't indicate what type of firmware or exact hardware beyond server model.  If you already did all that legwork and just wanted to use E-E as a sounding-board to see if your suspicion of server mainboard firmware/BIOS update was on the right track, saying so up front would've been helpful to reduce confusion.
0
 

Author Comment

by:smartin36
ID: 21986698
Thank you!

ShineOn - I believe I did indicate which hardware I was having the issue with and that would have been where I said (I  have a Novell 6.5 server that had a failed drive; I replaced the drive and the rebuild proceeded as normal. At about the 21% of the rebuild the drive goes into a que status and then back to a ready for recovery in the HP Smart Array Online Config Util. Could this be a firmware related issue?) I believe that would indicate HARD DRIVE not MB so the actual situation was indicated in the question. At the time I had asked the question I had not checked the firmware that was on the server. It was only after I decided to run the firmware CD did I determine that the MB firmware needed to be updated and that the firmware on the array was already up to date. I do not beieve I used E-E as a sounding board to see if my suspicion of server mainboard firmware/BIOS was on the right track that was only determined after I ran the firmware CD. So at the end of the day could this be a firmware related issue the answer is yes. Just because I suspected firmware does not mean that I already knew which firmware I suspected. In the end make sure all of your firmware is up to date.
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VMWare & and Storage 10 102
Windows Server failure RAID 31 77
Disk clean up on Server 2012 R2 6 43
Linux kernel panic ext3-fs error 14 32
Solid State Drive Performance Tips: Solid state storage technology is now a standard.  After testing and using several different brands and revisions of SSD's over the years I have put together a collection of tips,tools and suggestions that I ha…
Having issues meeting security compliance criteria because of those pesky USB drives? Then I can help you! This article will explain how to disable USB Mass Storage devices in Windows Server 2008 R2.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question