Cisco 2950 %LINEPROTO UPDOWN Message

I currently have my lan connecting by trunk fiber on port 28 on the cisco 2970.  Then I have 3 2950 switches connected to the 2970 with vlan 6. I configured switches all to access vlan 6 which is the only vlan used on the connected workstations.    My problem is I keep getting %lineproto - 5 - updown or %lineproto - 3-  updown messages, below is the config for both the cisco 2970 and 2950:
Please let me know what i'm doing wrong, again I only need to use vlan 6 on the workstations connected to the 2950 but looks like native vlan is 1, would that cause the updown which seem to be random?  How can I troubleshoot?
Again it's LAN -(Dlink L3 Switch) by- fiber --> Cisco 2970 --> Cisco 2950 --> workstations

cisco2970config.TXT
cisco2950AConfig.TXT
rjung2008Asked:
Who is Participating?
 
rjung2008Connect With a Mentor Author Commented:
On the 2970 Port 28 should the be:
!
interface GigabitEthernet0/28
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 6
 switchport mode trunk
!
If i'm attaching the 3 2950 to 2970 on ports 1, 3, 5 how should those interface ports be configured?
Should they be the same?
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 6
 switchport mode trunk
!
Then on the 2950 switches would those ports be configured on the gb port as:
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 6
 switchport mode trunk
!
I need to disable the vlan 1 by sh vlan 1 on 2950 since they will only need to use vlan 6.  
Please confirm these are correct, thanks,

0
 
AmericanBridgeConnect With a Mentor Commented:
First off, you don't need spanning for something like this AND you don't need pvst configured for one VLAN.

Secondly, it's best practice to configure the ports that are connecting two switches as trunk ports. Although a trunk is not needed, the switches should be a separate vlan from the clients. try this config.

Set all switches to use Vlan 6
-on each switch shutdown vlan 1
-on each switch assign a different ip to vlan 6
-on each switchport attached to a switch (both sides) do a 'switchport mode trunk' 'switchport trunk encapsulation dot1q'  ' switchport native vlan 6'
-make sure STP and PVST is turned OFF

try this config with two switches, then ping the address of vlan 6 from and to each device. Finish the topology.

NEXT:
add client vlan 7
any switchports that clients attach to will need 'switchport mode access'  and  ' switchport access vlan 7'  

Post your new config once you get the switches pinging each other.

Key*
disable vlan 1
reboot switches
ip address to vlan 6
trunk mode between switches.

Let me know how it goes.
0
 
rjung2008Author Commented:
Thanks for the speedy reply, let me try to confirm what you suggested:
1. I need to set each 2950 to use vlan 6, I thought i did that b/c I set each interface to access vlan 6, do I need to set native vlan to 6
2. each 2950 that connects to the 2970 needs to be a trunk port?  on each switchport attached to a switch (both sides) do a 'switchport mode trunk' 'switchport trunk encapsulation dot1q'  ' switchport native vlan 6' , so your suggesting the 3 ports on the 2970 need to be switchport trunk also?
3. what do you mean by: ip address to vlan 6, are you saying each 2950 needs it's own ip?   didn't think you need to do that on a layer 2 2950 switch?  Is that only for the trunk port?
4. is the vlan 7 just for testing that the trunk is working?
5. is there a way to pass IPX using a 4th 2950,after i get the following working without the updown error logs, then I need to add IPX on vlan 6 for Novell IPX Printer,
I need to try to test tonight in a few hours so please the sooner you reply the better,
thanks in advance,
0
 
nrpanchalConnect With a Mentor Commented:
There is something wrong with your configuration of interface gi 0/28.
Remove line "switchport access vlan 6" . If possible allow all vlans from a trunk for testing purpose.

How are you managing your switch? I see no management IP configured as well. Please think about that. If you are not using any separate vlan for management, you can no shut vlan 1 and assign it some ip to remotely manage the switch.

# interface vlan 1
#ip address x.x.x.x y.y.y.y

Let us know your observation.  HTH

 nayan
0
 
rjung2008Author Commented:
Should my 28 port on Cisco 2970 trunk be:

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 6
 switchport mode trunk
or
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
0
All Courses

From novice to tech pro — start learning today.