We help IT Professionals succeed at work.

Need to setup a Site to Site VPN between 2 Pix Firewalls and need some help

ncomper
ncomper asked
on
704 Views
Last Modified: 2012-05-05
Hi All

I am currently trying to setup a site to site VPN between our main office and a branch office but have not got a clue how to do it as i have  only ever done basic single site configs before.

I have attached a network Diagam that shows the 2 sites and pasted my configs so far below

Any Help would be much appreciated

Thanks

Nick

For Head office

Pix Internal Int - 10.0.0.254 /24
Pix Extrnal Int - 200.200.200.254 /24
ISP Router - 200.200.200.1

Branch Office

Pix Internal Int - 192.168.1.254 /24
Pix External Int - 100.100.100.254 /24
ISP Router - 100.100.100.1


Head Office Config

Headoffice> en
Password:
Headoffice# sh run
: Saved
:
ASA Version 7.2(3)
!
hostname Headoffice
domain-name office.local
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.0.0.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 200.200.200.254 255.255.255.0
!
interface Vlan3
 shutdown
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name office.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any interface outside eq smtp

access-list outside_access_in extended permit tcp any interface outside eq 3389

access-list outside_access_in extended permit tcp any interface outside eq pptp

access-list outside_access_in extended permit gre any interface outside
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit tcp any interface outside eq https

pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 10.0.0.1 smtp netmask 255.255.255.255

static (inside,outside) tcp interface 3389 10.0.0.1 3389 netmask 255.255.255.255

static (inside,outside) tcp interface pptp 10.0.0.1 pptp netmask 255.255.255.255

static (inside,outside) tcp interface https 10.0.0.1 https netmask 255.255.255.2
55
static (inside,outside) tcp interface www 10.0.0.1 www netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 200.200.200.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.0.0.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:7bd702e5019d8561ff3ddaa601fc5356
: end
Headoffice#


Branch Office


ciscoasa# sh run
: Saved
:
ASA Version 7.2(3)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.100.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 100.100.100.254 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 100.100.100.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:7747acf6d0ab1f5e275cce655be9dd03
: end
ciscoasa#

Network-diag.jpg
Comment
Watch Question

CERTIFIED EXPERT

Commented:
Head office;

crypto isakmp policy 10 encryption 3des
crypto isakmp policy 10 hash sha
crypto isakmp policy 10 authentication pre-share
crypto isakmp policy 10 group 2
crypto isakmp policy 10 lifetime 86400
crypto isakmp enable outside
crypto isakmp identity

crypto ipsec transform-set VPNSET esp-3des esp-sha-hmac
crypto map VPN 10 match address 101
crypto map VPN 10 set peer 100.100.100.254
crypto map VPN 10 set security-association lifetime seconds 86400 (one day)
crypto map VPN 10 set pfs group2
crypto map VPN interface outside

accesss-list 101 permit ip 10.0.0.0 255.255.255.0 192.168.1.0 255.255.255.0

reverse engineer for other office

harbor235 ;}

Author

Commented:
hi

thanks for the reply, do i need tp specify a pre shared key somewhere?

also for the line below do i specify the remote pix public IP address?

crypto isakmp identity

Regards

Nick

CERTIFIED EXPERT

Commented:
Sorry forgot that;

tunnel-group 100.100.100.254 type ipsec-l2l
tunnel-group 100.100.100.254 ipsec-attributes
pre-shared-key  
 
harbor235 ;}

Author

Commented:
Hi Haror

When i add this line below i get an invalid input detected, I substituted that for the remote ip so it was crypto isakmp identity 100.100.100.254

crypto isakmp identity

I take it i must be doing somthing wrong

Thanks
CERTIFIED EXPERT

Commented:
Thats what I intended for you to do, add the remote peer ip. At some point i was trying to be generic then later on  in the answer I became spefic with your IPs. Sorry, my mind forgets what I typed previosly sometimes.


harbor235 ;}

Author

Commented:
Ok i just itried that but got the error below

Headoffice(config)# crypto isakmp policy 10 encryption 3des
Headoffice(config)# crypto isakmp policy 10 hash sha
Headoffice(config)# crypto isakmp policy 10 authentication pre-share
Headoffice(config)# crypto isakmp policy 10 group 2
Headoffice(config)# crypto isakmp policy 10 lifetime 86400
Headoffice(config)# crypto isakmp enable outside
Headoffice(config)# crypto isakmp identity 100.100.100.254
                                                                             ^
ERROR: % Invalid input detected at '^' marker.

Any Ideas?

Thanks
CERTIFIED EXPERT

Commented:
Sorry again, mixing up versions of code;

Try this "crypto isakmp identity address"

It get your peer address from other configuration parameteres.


harbor235 ;}

Author

Commented:
Thanks for all the help, im just having a couple of issues, On the Head office Pix all the commands went in ok however it gave me a warning that Cryptomap has incomplete entries

On the branch office i put the exact same thing in but it does not like the tunnel-group command, it places the marker under "type" on that line

I have pasted both the relevent pix outputs from Hyperterm below


Headoffice(config)# access-list 101 permit ip 10.0.0.0 255.255.255.0 192.168.1.0 255.255.255.0
Headoffice(config)# crypto isakmp policy 10 encryption 3des
Headoffice(config)# crypto isakmp policy 10 hash sha
Headoffice(config)# crypto isakmp policy 10 authentication pre-share
Headoffice(config)# crypto isakmp policy 10 group 2
Headoffice(config)# crypto isakmp policy 10 lifetime 86400
Headoffice(config)# crypto isakmp enable outside
Headoffice(config)# crypto isakmp identity addres
Headoffice(config)# crypto ipsec transform-set VPNSET esp-3des esp-sha-hmac
Headoffice(config)# crypto map VPN 10 match address 101
Headoffice(config)# crypto map VPN 10 set peer 100.100.100.254
Headoffice(config)# crypto map VPN 10 set security-association lifetime second 86400
Headoffice(config)# crypto map VPN 10 set pfs group2
Headoffice(config)# crypto map VPN interface outside
WARNING: crypto map has incomplete entries
Headoffice(config)# tunnel-group 100.100.100.254 type ipsec-l2l
Headoffice(config)#
Headoffice(config)# tunnel-group 100.100.100.254 ipsec-attributes
Headoffice(config-tunnel-ipsec)#
Headoffice(config-tunnel-ipsec)# pre-shared-key Password123




Branch Errors


ciscoasa(config)# access-list 101 permit ip 192.168.1.0 255.255.255.0 10.0.0.0 255.255.255.0
ciscoasa(config)# crypto isakmp policy 10 encryption 3des
ciscoasa(config)# crypto isakmp policy 10 hash sha
ciscoasa(config)# crypto isakmp policy 10 authentication pre-share
ciscoasa(config)# crypto isakmp policy 10 group 2
ciscoasa(config)# crypto isakmp policy 10 lifetime 86400
ciscoasa(config)# crypto isakmp enable outside
ciscoasa(config)# crypto isakmp identity address
ciscoasa(config)# crypto ipsec transform-set VPNSET esp-3des esp-sha-hmac
ciscoasa(config)# crypto map VPN 10 match address 101
ciscoasa(config)# crypto map VPN 10 set peer 200.200.200.254
ciscoasa(config)# crypto map VPN 10 set security-association lifetime seconds 86400
ciscoasa(config)# crypto map VPN 10 set pfs group2
ciscoasa(config)# crypto map VPN interface outside
WARNING: crypto map has incomplete entries
ciscoasa(config)# tunnel-group 200.200.200.254 type ipsec-l2l
^
ERROR: % Invalid input detected at '^' marker.
ciscoasa(config)# tunnel-group 200.200.200.254 ipsec-attributes
CERTIFIED EXPERT

Commented:
Do you have different versions of code on the ends?

forgot the following command;

crypto map VPN 10 set transform-set VPNSET

harbor235 ;}

Author

Commented:
i think they are the same, they were both purcahsed together and have same version of IOS

i have pasted the full running config of the brach one thats not working just in case tat will shed any light

Thanks

Nick

ASA Version 7.2(3)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.254 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 100.100.100.254 255.255.255.248
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
access-list 101 extended permit ip 192.168.1.0 255.255.255.0 10.0.0.0 255.255.
255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 100.100.100.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set VPNSET esp-3des esp-sha-hmac
crypto map VPN 10 match address 101
crypto map VPN 10 set pfs
crypto map VPN 10 set peer 200.200.200.254
crypto map VPN 10 set security-association lifetime seconds 86400
crypto map VPN interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
tunnel-group 200.200.200.254 type ipsec-l2l
tunnel-group 200.200.200.254 ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:7747acf6d0ab1f5e275cce655be9dd03
: end
ciscoasa(config)#
CERTIFIED EXPERT

Commented:
Hmm, both tunnel-group commands are in the config, what did it not like?
 
harbor235 ;}

Author

Commented:
it didnt like the word type

But as you say they are both in there, although i am not able to establish a vpn tunnel, i have tried pinging an IP on the other side but with no Joy

Is there any logging i can turn on to see why its failing

Thanks

Nick
CERTIFIED EXPERT
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.