We help IT Professionals succeed at work.

LAN not working through Ethernet 169.254.XX, Wireless working OK

1,458 Views
Last Modified: 2013-11-09
Hi,
I am having a bit of trouble with my local area network. Previously, I have running a Belkin Wireless Router and a Belkin Wireless Network Card into my desktop. This has all been working fine. However, I now want to hard wire my internet connection into my machine through the ethernet cable to increase download speeds.

My problem is that when I connect the cable initially, I get a 169.254.XX ip address. So I have check all the Ip addresses through ipconfig - DHCP is enable and everything seems as though it should be working fine. I then go into the connection properties and set up a static ip address (I use a static ip address on my wireless connection already) but when I go to close out the changes I have made, the system hangs. So then I have to do a manual reboot - the changes have all been saved, but now I get a lengthy - aquiring address message and when it eventually does connect I get a little yellow warning triangle telling me the network is slow. The packets are around 26 sent 2 recieved and never increase. In addition, my wireless network connection has now been knocked out - so I can't get internet.

So I go through all the network connection settings again and change back everything I have done (again, the system hangs) and eventually manage to get my wireless connection back.

But I do want to use ethernet for this machine. So that is where the problem lies.

My machine is a Shuttle XPC SD32P2. I have an Asus laptop, and connect it successfully through both the ethernet and wireless devices, so I know its not the router that is the issue.

I am pretty stumped as to where to go from here - does anyone have any suggestions??
Comment
Watch Question

CERTIFIED EXPERT

Commented:
The laptop connects just fine using that same cable?

Because my first thought is 'replace the cable'.

Have you checked for updated LAN drivers on Shuttle's download page?
I looked at the barebones systems and couldn't find SD32P2... I found an SD37P2, and SD32G2 so you might want to double check those numbers before going to the site, so you don't end up with the wrong files.
You might also consider pulling the wireless card before enabling & configuring the wired NIC.

:)

Author

Commented:
Hi, yep sorry it is an SD37P2 - my typo sorry. I downloaded all the braodcom latest drivers and reinstalled them, doesn't make any difference - i still have the same situation.

As for pulling the wireless card, I've tried that one too (I have been trying this for a looooong time)

Its causing nightmares. Why would the system hang when I try to update the network configuration page also??
What about updating the chipset drivers?  It's possible that older chipset drivers could cause issues with newer NIC drivers.

If the chipset drivers don't fix the problem, you might want to use the drivers from Shuttle's site (http://global.shuttle.com/download03.jsp?PCI=19&PI=187) rather than direct from Broadcom.  They may be older, but they may also be customized for the onboard version of this Broadcom NIC chipset.

:)

Author

Commented:
Well I've tried doing all that... and still no luck... This is about where my knowledge and understanding of computers reaches its limits. Any other ideas as to what could be causing it?? Could it be a fried network adapter?? Is there any way to check that??
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT

Commented:
If it's the wireless card that came with the laptop it should be compatible with the NIC.

I have seen wireless cards that did not want to play nice (like, disabling the NIC) when on the same PCI bus as the NIC daughterboard in laptops, but those were add-ins, not from the factory like that.
Darr, with all due respect:

1)  This is not a laptop.  http://global.shuttle.com/product_detail.jsp?PI=187

2)  hunniebunnie79 has already tried removing the wireless NIC, with no change in the symptoms.  (See the third post down.)

Note that when I say "with all due respect", I mean it earnestly.  Your point total tells me you've earned your place here, so I'm sure you can understand that I'm just trying to keep the issue as clear as possible for hunniebunnie79.

Thanks!
:)

Author

Commented:
Ok, I will try putting another network card in the system (as scary as that is going to be) Will probably be in a couple of weeks tho. So thanks for your help thus far and I shall let you know what happens!

Author

Commented:
Thanks - you really helped me explore all the options - people like you make this site very worthwhile.
Thanks, and glad I could help!  Don't sweat the NIC install.  As long as you use a fairly standard NIC (Intel, 3Com, etc.), it should be very straightforward:  pop the case, put the card in the slot, put the case back on, fire up the computer; install drivers if Windows doesn't detect and install automatically.

If opening the case is daunting or otherwise not feasible, you can go with a USB NIC, so you don't even have to open the computer or even turn it off.  Just "plug & play"!

:)

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.