Trouble with driver for Toshiba eStudio 3510c, Win XP x64

jtgerdes
jtgerdes used Ask the Experts™
on
We recently acquired a client with a Toshiba eStudio 3510c network copier and there is an issue with the driver on one of the workstations.  This particular workstation is a home-built system running XP Professional 64 bit edition.  Anytime the user tries to print to the Toshiba printer, a RUNDLL error box pops up with this message:

---------------------------------------
Error loading C:\Windows\System32\Spool\Drivers\x64\3\es3cccfg.dll

This application has failed to start because the application configuration is incorrect.  Reinstalling the application may fix this problem.
---------------------------------------

I've tried uninstalling/reinstalling all the drivers, manually adding the 64bit drivers, etc.  Supposedly, the previous technician tried to work with Toshiba tech support, but wasn't able to solve the issue, so now we've inherited the problem.

I've also tried running the Cleanspl.exe utility from the Windows Resource Kits and setting everything up again, but to no avail.

Does anyone have any other ideas to run by?  We're open to anything to get this working.

Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi jtgerdes,

The first thing I would suggest doing would be to go into the 'Device Manager' and uninstall the device.

Next, download CCleaner (http://www.ccleaner.com/) and 'Scan for Issues' within your Registry, (then fix).

Then, uninstall all the software associated with the device using 'Add/Remove' and run CCleaner Registry 'Scan for Issues' and "fix" again.

Now, within CCleaner, go to tools, and see if any of the Toshiba software still exists. If it does, 'Delete Entry' on each Toshiba item. (This will remove its registry key).

'Scan' and 'Fix' one more time.

Try installing the drivers/software at this point and see if it works.

If not, go back into the Registry by hand and try to delete everything associated with that Toshiba driver. Then run 'Scan' and 'fix' one more time.


Hope this helps.

-Bevo-geek.

Author

Commented:
Thanks for the suggestion, but nothing is working.  I've cleaned through the registry and reinstalled nearly everything possible.  The interesting part of this issue is that it will print after clicking through the error dialog box.  But there hasn't been a way to eliminate the error.

Based on the fact that this particular 64-bit machine has been nothing but a lemon, it doesn't surprise me that I can't find an answer.  However, I have found a workaround by using a utility to automatically push the OK button on specified dialog boxes.  I know this doesn't treat the source problem - whatever it may be -  but it eliminates the annoyance factor of having to manually click that silly button.

Thanks!
PAQed with points refunded (500)

Computer101
EE Admin

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial