We help IT Professionals succeed at work.

windows xp hangs in Setting up personalized settings for internet explorer

15,941 Views
Last Modified: 2013-12-12
I have an image I need to deliver for a customer as a sysprepped clone deployment.  After the image is deployed and our other software is installed, the user is supposed to create local accounts for the users that will be on the system.  Lately we have discovered that when we create a new user account (member of the User group) and try to login as that user, the system will hang while running the "Setting up personalized settings for:  Internet Explorer".  We have found that we can use Ctrl Alt Delete and then force a reboot and login again, which usually allows it to continue.  I have also found that I can run Task manager to see that the process that is hanging is running with the command line "shmgrate.exe OCInstallUserConfigIE".

I've searched all over Google and tried monitoring it with Procmon and I haven't been able to find a previous solution or identify a file/registry problem.  ANyone have any ideas on this?  Anyone know exactly how shmgrate sets up the user profile?  Or maybe about User Profiles in general?
Comment
Watch Question

Delphineous SilverwingGood Ol' Geek
CERTIFIED EXPERT

Commented:
What is the longest that you have waited before forcing a reboot?  I have seen this on some machines that were sysprepped, you may have to wait up to ten minutes.  I haven't figured out the cause, it tends to be inconsistent.

Have you installed XP Service Pack 3 on the image?

Author

Commented:
No its just SP2 with hotfixes, not even the most recent.  We have waited as long as 45 minutes with no apparent activity.  When I check in the task manager the machine is idle for the whole time.  If I kill shmgrate it continues, but I have to deliver a deployment procedure along with the image, and killing a process will not be accepted by the customer as a valid procedure.
ThinkPaperIT Consultant

Commented:
i'm wondering if the machine was imaged and deployed properly. Sometimes a pc just doesn't take the image correctly or the image was corrupt to begin with. Does this happen to all the machines you imaged or is this an intermittent thing?

i found this.. not sure why it should be active when all you're doing is creating local accts..
http://support.microsoft.com/kb/931498

the other thing is I've had issues with pushing out IE7 to client machines.  It uses different processes than IE6 and caused some pcs to just hang. A removal of IE7 back to IE6 cleared up the issue. Try seeing if a reversal 'fixes' the issue.
Delphineous SilverwingGood Ol' Geek
CERTIFIED EXPERT

Commented:
Excellent point ThinkPaper!

Are you using the most recent version of SYSPREP ?

Author

Commented:
Thanks, but its a standalone machine in a workgroup, not logged into any servers.

Only IE6 SP1 is installed with security updates.

What sysprep is more recent for XP than 5.1.2600.2180?

Author

Commented:
Also we are using UIU 3.7.0.11 rev 28, if that matters any.  It is running sysprep automatically after it loads its driver set.  As far as I can tell sysprep.exe is the latest version for XP SP2 dated 8/4/2004.

We also have this problem on another image that was sysprepped without UIU.  The other image was built completely separate from the one I am working on now.    I have a feeling its something in our own software install that is causing the problem, but I can't figure out how to track it down since I have no idea what could cause this type of problem.  Our software loads a nummber of security temapltes and makes some other system changes, but it has never caused this problem before.

Author

Commented:
So no ideas?    I've been all over the web looking for answers and there are lots of pages that mention shmgrate.exe because it shows up in HijackThis logs since its in the startup programs for every windows machine.  It makes finding answers a needle in a haystack.  
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Commented:
I LOVE this site, but often get annoyed at what moderators accept as a "fix".  The above fix is like saying you removed the dilithium crystal from the warp drive.

What registry key was modified? "I finally deleted the stub path values for IE and OE and Browser Customization"  Sounds like a technical discussion by programmers who coded IE 7.

THIS solution I found was much more satisfactory - not an explanation as for WHY it works or the technical details, but a FIX nevertheless. (i.e. do THIS and it will FIX it.)

http://www.wsus.info/forums/index.php?showtopic=10752
Quoted from the above link:
"I have had this happen twice on SBS server 2003 boxes. Both tmes I fixed it easily. I usually give it a few minutes to make sure I'm not just being impatient.....and then hit Ctrl+Alt+Del and "log off" and then log back on. Works right away usually."

AND if definiitely worked for me!
THANKS for everyone who posts fixes to their problems!
Trying to give something back,
~John



Author

Commented:
I was aware of the logoff/logon multiple times workaround, but it isn't acceptable in my situation.  My images get sysprepped and cloned out to multple workstations and used by a lot of different users who may not be all that savvy, so the setup process has to be seamless.  Problems like this one can't be addressed by a tedious workaround or I will never hear the end of it.

That being said, the stubpath values can be found in registry keysunder HKLM\Software\Installed Components\<various GUIDs>.  There are lots of them and I'm not sure the GUIDs are the same on every system, but you should be able to go down the list and find Internet Explorer, Outlook Express, and Browser Customizations in the Display Name value under each GUID key.  These are the ones that cause the hang.  Rename or delete the stubpath values under each of these and the problem will go away for all users, for good.  And little harm will be done
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.