We help IT Professionals succeed at work.

Group Policy Software Deployment using DFS Share - Installation Source Unavailable

1,913 Views
Last Modified: 2012-06-21
I am attempting to deploy software via Group Policy (MSI files) using a DFS share however my workstations are unable to locate the installation source (the DFS share) before a user has logged on.

If I modify the GPO to use a server share (not over the DFS) the installation completes with no problem - but if I am attepting to deploy the software using the DFS share UNC path I receive "installation source for this product is not available" errors in RSOP.

I know that the NTFS permissions are correct for the actual share on the server but I've run out of ideas as to where I need to be looking.  My guess is that the issue is permissions related on the DFS but I would appreciate it if someone could direct me in configuring my DFS root share and software deployment share with the correct permissions and let me know about anything else I may have missed.

Thanks!
Comment
Watch Question

Kevin HaysIT Analyst
CERTIFIED EXPERT

Commented:
Only thing I can think of is permissiosn on the root of the DFS.  Here is a link, just make sure everything was followed.
http://www.windowsnetworking.com/articles_tutorials/Windows2003-Distributed-File-System.html

You are assigning the msi like this right in the gpo?  
\\servername\share\file.msi   ??

Author

Commented:
Thanks - That is actually the article I used to setup the DFS share in the first place - I have gone through all of the steps listed there.  Nothing that I've seen so far indicates what the share/ntfs permissions need to be on the DFS root.  

For assigning the MSI in the GPO I'm using this format:

\\domain\dfsroot\share\file.msi

If I use \\server\share\file.msi everything works just fine, but the whole point of setting up the DFS is so that I don't have to bind the share to one specific server in case things need to be moved around.
Kevin HaysIT Analyst
CERTIFIED EXPERT

Commented:
Ahh, ok.  I can't get to the my dfs until Monday though, but I would imagine you would want the share(everyone=full control) and NTFS with authenticated users or domain users = read.  They have to be able to read from the dfs on the root in order to get it applied.  I would check the permissions on the share and ntfs and compare it to you server where it works at.  Like I said, I won't be able to get to see my permissions on the DFS share until monday.  If nobody has posted a solution by then I will post what I have then.

Regards,

Kevin

Author

Commented:
Does anyone have any further suggestions?  I've increased the point value to 500 on this one.
Thanks.
Kevin HaysIT Analyst
CERTIFIED EXPERT

Commented:
Ok, well on my actual root here are the permissions.
Share:
- Everyone(full control)
NTFS
- Everyone(List and read)
- Administrators (full control)
- IT(full control)

On the folders under the root they just have the permissions of whatever department that is associated with that folder.

I don't actually store any of my packages on a DFS to be deployed by GPO's though.  I have these in a seperate shared folder.

Author

Commented:
Where are you setting "root" permissions?  Through the DFS console, or just the DFS share directory itself?

Based on your description, other than the fact that my MSI packages are located on the DFS share I've got the same exact setup so I'm not sure what the missing piece is here.
Kevin HaysIT Analyst
CERTIFIED EXPERT

Commented:
I'm setting it on the share itself.  Not in the dfs console.

Yeah, I can create a package tomorrow and have it reside in the dfs and get back to you if you would like.

Kevin
Try to activate on the computer node. Administratvie Model/System/logon/Always wait for network at computer startup...
When you try to manuly install the msi from the DFS. Are-you getting a Security warning windows? About the source off this file is unsafe or the publisher coud not be idnetify.

Author

Commented:
absolunet:

Thanks for the reply.

The GPO option you mentioned (always wait for network at computer startup) is enabled automatically for all workstations except notebooks - though all workstations are exhibiting this issue, not just the notebooks.

Manually installing the MSI files from the DFS works just fine.  The issue only occurs when the PC attempts the installation via GPO prior to the user logging on to the PC.

Unfortunately publishing these packages for installation upon first use ( as opposed to automatically assigning them ) isn't an option in our environment either.
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.