We help IT Professionals succeed at work.

Urgent - Very annoying desktop problem

619 Views
Last Modified: 2008-08-04
Users' desktop backgrounds are disappearing sparatically.
Here's whats changed...
We recently implemented ISA 2006 and had to setup some new group policies for proxy, exceptions, etc.  One of the group policies is applied to all OUs but one. I setup a separate group policy for the remaining OU. I only setup the proxy under connections -- Nothing else.

To test, I removed the GPO from 3 of the OUs and a day later (and after rebooting), they are still experiencing the problem.

When I look at settings on ALL GPOs, I don't see anything regarding desktop backgrounds.

I have another EE Ticket open but am hoping that by adding new tags, this will get solved faster.  
Please see (https://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23549940.html)

I cannot turn off all group policies that that will severely hinder our employees to work.  This started soon after implementing ISA 2006 and a group policy that forced users to use a proxy. I don't think ISA caused it but it was soon after the implementation that users starting telling us about the problem.
Comment
Watch Question

Commented:
Does this error sound like your error?
http://www.mcse.ms/message2716894.html

Author

Commented:
No, this happens sparatically and the desktop background simply goes to a solid color (typically blue depending on what the user has set under the 'Desktop' Tab in Display properties.  Then, just as sparatically, the users image desktop comes back.

Commented:
What service pack are you running

Author

Commented:
on the desktop?  SP2

Commented:
There have  been problems with RD and SP2:

http://www.lan-2-wan.com/2003-SP2.htm

I hope this helps.

Author

Commented:
we are now using RD

Author

Commented:
sorry...we are NOT using RD
Hi, this is my first post here.

I found a page were a guy describes having the same problem you described.. He wrote "the next day after turning on the PC the wallpaper does not appear and all the buttons in the background tab of the properties of the desktop are disabled (grey) and so is the web tab. The "show web content on my active desktop" in the Web Tab is checked and disabled, I can't do anything with it. I removed the item that was added from my customized desktop but no use.". His solution would not be practical for you, unless you are willing to edit the registry on the PCs, but he wrote that it worked for him. I'll post the link at the end.

I looked at your other post on this. My guess is this is the problem, or part of the problem. Disable Active Desktop is set to Disable. If you want to require active desktop, that is the correct setting. If you want allow the user to choose, you could change that to not configured.

Here is the link I mentioned above.
http://www.softwaretipsandtricks.com/forum/windows-nt-2000-2003/32365-cant-disable-active-desktop-windows-2000-cant-put-wallpaper.html

Commented:
Have you tried doing
gpupdate /force

on a client and see if this resolves the problem?

Also, you say the desktop background is gone - is it not displayed as background (while remaining set in the options), or is it re-set from options?

Also, are those backgrounds Active Desktop? If so, it would mean that the network may not be available during boot-up. To resolve this, enable "Always wait for network" policy under Computer Configuration\Administrative Templates\System\Logon

Author

Commented:
yes, gpupdate /force does not fix the problem.  It does however bring the users desktop back but I believe F5 may do the same thing...I have not tried yet.

Options stay set however it goes back to the standard blue background.  The backgrounds are not Active desktop and are stored on the C:\.

Commented:
Is putting a short logon script (which would run minimized) with just gpupdate (without /force) in it an acceptable workaround ?

Also, please try setting the "Always wait for network" on one PC locally (you can do this via gpedit.msc) and check if this resolves the problem. This should make Windows happy about any proxy connections (and remember that in win2k, any desktop backround in format other than BMP uses IE components for being displayed, hence it is wise to test "Always wait for network").

Commented:
Could this be your issue?

http://support.microsoft.com/kb/909444

Where is says:

""You may experience various problems after you install the Microsoft Security Bulletin MS05-051 for COM+ and MS DTC""

and also says:

""Authenticated users cannot log on, and a blank screen appears after the users apply the October Security Updates""
This started right after forcing users to use a proxy. Is your internal DNS the primary DNS? If not, try moving it to the top in DHCP scope.

Author

Commented:
pjasnos - I can try the login script but this happens throughout the day -- Not just during login.  Also, we have several XP boxes where this is occurring but I will still try the 'Wait for network' setting. Thx

Commented:
One think worth testing is to do a test install of SP3 on one of those boxes and seeing if that resolves the problem.

Author

Commented:
I really don't like the idea of install SP3 b/c I know it will cause other issues.  Besides, the problem just occurred so I don't know that it would fix it anyway.  I have not had a single problem with my desktop disappearing.  I too am running XP Pro with all current updates.  I have replaced one computer with a test computer to see if it is user related or hardware related.  I've had the user login and am going to let it go until the end of the day to test. I'll keep you all posted

Author

Commented:
I gave one of the  users a new desktop and it has now been in place over night with no problems. I am now attempting to delete a user's profile from the computer and see if that fixes the problem.  

Author

Commented:
Scratch that...the user's desktop just changed.  I noticed an event in his Event log System. I've searched a bit but I'm not sure if they are related

Event Type:      Error
Event Source:      TermDD
Event Category:      None
Event ID:      50
Date:            7/15/2008
Time:            9:05:24 AM
User:            N/A
Computer:      ITLOANER
Description:
The RDP protocol component X.224 detected an error in the protocol stream and has disconnected the client.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 05 00 02 00 54 00   ......T.
0008: 00 00 00 00 32 00 0a c0   ....2..À
0010: 00 00 00 00 32 00 0a c0   ....2..À
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0028: 0b 00 00 00 80            ....€  

Author

Commented:
I should add, he was not trying to use RDP...he actually wasn't even at his desk when it happened. He came back and it was that way.

Commented:
A few pieces of advice worth trying:

http://eventid.net/display.asp?eventid=50&eventno=606&source=TermDD&phase=1

I would bet on the corrupt server certificate - even if you don't RDP to it, it may still check if its ok when you browse the network. Re-installing network drivers may also be a good idea (but I doubt it will help).
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Commented:
As you have resolved the problem on your own, you may want to ask the moderator to close the question and refund the points. You may do this by clicking on the "Request attention" link at the bottom of your original question. :-).
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.