We help IT Professionals succeed at work.
Get Started

Print jobs getting stuck in queue unless generated from user logged into print server and/or user has Domain Admin permissions.

1,146 Views
Last Modified: 2013-12-15
My question has two parts:
In relation to printing, I need to figure out:
What a user account has access to when logged on to server that it doesn't when logged onto a user machine.
&
What is it a Domain Admin has access to remotely that a normal user account doesn't?

While these questions are fairly impossible to answer without looking at the environment hands on, can anyone offer pointers around what I can check or how I could go about narrowing this down.

The actual problem is a bit of a weird one so I'll keep it simple but try and describe it as best I can....
We have an environment with two domains setup with trusts, I'll refer to as A and B

On domain A we have an HP Color LaserJet 2600n setup as a network printer using a standard TCP/IP port, it is installed and shared from a Windows 2003 server with the drivers currently available from HP website, and installed following their instructions.

Myself and some other engineers have tried reinstalling the printer and/or drivers several times and no-one can figure this one out.

We are having issues with documents and test pages not printing.
They spool to the queue and show up as printing but will remain there.
When trying to delete the document at top of queue it will say it's deleting but stay there untill print spooler is restarted.

No errors are generated.

However this issue only affects certain accounts in certain ways.

Normal user accounts are unable to print to it from any remote locations/machines (Domain A or B).

However I can log an A domain user account into the server and print fine.
I can print to it with my A domain admin account from anywhere.
So I don't think it's a driver/configuration issue.

All the accounts I've used to test with have had permissions added to the printer allowing them to print/manage docs etc so I don't think it's a permissions issue (not on the printer itself anyway)

I have a seperate admin account on domain B that can login and print on the print server, but not from any of the remote locations on either domain A or B.
So I thought an admin account in itself is not enough to print.
Then I added the testuser account to Domain Admins and voila, it could print from locations it previously could not. O_o

I've setup network printers many times before and never encountered anything like this, ...driving me crazy.

To try and explain my tests see the attached chart...

...any ideas much appreciated.


printtests.JPG
Comment
Watch Question
Commented:
This problem has been solved!
Unlock 1 Answer and 3 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE