Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

cannot mount information store after restore of database

Avatar of ilguybob
ilguybobFlag for United States of America asked on
ExchangeWindows Server 2003VMware
17 Comments1 Solution1549 ViewsLast Modified:
I am doing some disaster revovery planning for our exchange server. I captured a vmware image of the exchange server, and set it up as a virtual machine (disconnected from our LAN). The vm exchange server came up fine and all exchange services will start, however, the store will not mount. I figured that in a disaster recovery scenario, we would have to restore the most recent tape backup of the exchange information store anyway, I took the latest such backup and restored it to the vm exchange server. Again, the store would not mount. I am getting the following error in the event log:
Event Id 457
Source: ESE
Category: logging/recovery
"The log signature of the existing logfile E00.log doesn't match the logfile from the backup set. Logfile replay cannot succeed unless all signatures match."

I read Microsoft article KB823016, which states that this can happen if the Exchange information store service is not running when the restore was performed. I was pretty sure it was running, but to be sure I once again took a backup of the "real" exchange server and restored it to the vm exchange server, this time making sure the service was running. Afterwards, I had the same result and the same event errors.
I also have alot of other errors in the event logs:

Event ID: 904
Source: ESE Backup
"callback fnction call ErrESECBRestoreComplete ended with error 0xC8000262 existing logfile has bad signature."

Event ID: 9175
Source: MSExchangeSA
"The MAPI call 'openmsgstore' failed with the following error. The Microsoft Exchange server computer is unavailable"

Along with a whole slew of other errors relating to exchange.

NOTE:
I also tried running exchange setup with the /domainprep switch.
Also reapplied Exchange SP2 and Windows SP2.

OUR ENVIRONMENT:
Exchange server 2003 SP2 on Windows 2003 SP2
Two domain controllers, which are also running as vm servers on the same box as the vm exchange.
There appears to be good communication between the vm servers on that box.
Any ideas?
ASKER CERTIFIED SOLUTION
Avatar of rakeshmiglani
Commented:
This problem has been solved!
Unlock 1 Answer and 17 Comments.
See Answers