We help IT Professionals succeed at work.

Cisco 2600 ping to internet drops after FA 0/0 line protocol comes up

skilzygw
skilzygw asked
on
689 Views
Last Modified: 2012-05-05
Hello all, I am having some issues with a Cisco 2600 router i am trying to configure for a T1.  I was able to get the T1 interface up and can ping external site such as google.com yahoo.com. The issue occurs when I plug in anything into the 10/100 Ethernet 0/0 interface I am no longer able to ping from the router.

To test i set up a 500 repeat ping to google.com from the console of the router.  It was pinging fine until I proceeded to connect the Fast Ethernet port to a Switch using a straight through cable.  My ping suddenly just drops as if it cant find it anymore.

Has anyone come across any issues like this?

Thank you for any help.

Here is my current Config:

Current configuration : 1741 bytes
!
version 12.2
service tcp-keepalives-in
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname #####
!
logging buffered 4096 debugging
no logging monitor
enable secret #####
enable password ######
!
ip subnet-zero
no ip source-route
no ip routing
!
!
ip tftp source-interface FastEthernet0/0
ip name-server ####
ip name-server ####
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool dhcp-pool1
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server #.#.#.# #.#.#.#
!
no ip bootp server
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 

no ip route-cache
 no ip mroute-cache
 duplex auto
 speed auto
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 16 ppp Virtual-Template1
!
interface Virtual-Template1
 ip address negotiated
 ip nat outside
 ppp chap hostname #####
 ppp chap password 7 ########
 ppp ipcp accept-address
 ppp ipcp dns request
!
ip classless
ip route 0.0.0.0 0.0.0.0 #.#.#.#
no ip http server
!
access-list  1 permit any
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 #####
 login
!
end
Comment
Watch Question

you are missing your nat statement and your nat inside on fa0/0


interface FastEthernet0/0
ip nat inside

!
route-map RMAP_1 permit 1
 match ip address 104
ip nat inside source route-map RMAP_1 interface fa0/0 overload
access-list 104 permit ip 192.168.1.0 0.0.0.255 any

Author

Commented:
Thank you Melaleuca.  I added those commands verbatim and it still does not work.  Do I need to have a statement for my ip nat outside comman in my virtual template 1?

Ex..
ip nat iOUTSIDE source route-map RMAP_1 interface fa0/0 overload

Thanks.
ahh yes, sorry my bad it should be interface virtual template1 not fa0/0

Author

Commented:
So the FastEthernet 0/0 interface does not need any NAT at all?

It is a basic setup the design looks like this

LAN ->(Fast Ethernet) Router (Serial)-> Wan

Can you tell me which interfaces would need a NAT statement?

Thanks.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
I made the changes and it is still not pinging from the router to the internet.  Here is the current running config.  Thanks for all the help.

Current configuration : 1787 bytes
!
version 12.2
service tcp-keepalives-in
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname #####
!
logging buffered 4096 debugging
no logging monitor
enable secret 5 #####
enable password 7 #####
!
ip subnet-zero
no ip routing
!
!
ip tftp source-interface FastEthernet0/0
ip name-server ####
ip name-server ####
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool dhcp-pool1
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server #.#.#.# #.#.#.#
!
no ip bootp server
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 16 ppp Virtual-Template1
!
interface Virtual-Template1
 ip address negotiated
 ip nat outside
 ppp chap hostname ####
 ppp chap password 7 ####
 ppp ipcp accept-address
 ppp ipcp dns request
!
ip nat inside source route-map RMAP_1 interface Virtual-Template1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
no ip http server
!
access-list 1 permit any
access-list 104 permit ip 192.168.1.0 0.0.0.255 any
route-map RMAP_1 permit 1
 match ip address 104
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 ####
 login
!
end

When you ping are you pinging from a source address, because it will ping with the highest ip on the router. so ping 4.2.2.2 sou Virtual-Template1

Author

Commented:
Thanks for the help.  This issue is still open I have just not had the time to fully test.
I tried your changes and it still didnt work.  I was pinging without a source address.  Also Virtual-Template can not be used as source since it is always DOWN DOWN and the Virtual-Access connection is the actual interface that is up.  But my IOS does not allow using virtual-access as a source port.

Does the issue sound like a natting problem?
are you getting a public ip address on your virtual-access port. can you post your show ip int brief.

Author

Commented:
Hello it is still not pinging.  I have a switch attached to the FA port and a workstation on the switch.  Workstation with an ip of 192.168.1.10 can not ping any public addresses but can ping the Fast Ethernet IP address and the T1 virtual-access IP Address.  Any ideas what this issue sounds like or could be?  Im pretty much stumped.  Thanks

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.1     YES NVRAM  up                    up
BRI0/0                     unassigned      YES NVRAM  administratively down down
Serial0/0                  unassigned      YES NVRAM  up                    up
Serial0/0.1                unassigned      YES unset  up                    up
BRI0/0:1                   unassigned      YES unset  administratively down down
BRI0/0:2                   unassigned      YES unset  administratively down down
Virtual-Access1            69.3.109.#    YES IPCP   up                    up
Virtual-Template1          unassigned      YES NVRAM  down                  down

Author

Commented:
Winters03#sh ip route

Default gateway is not set

Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty

Author

Commented:
Current Running Config, removed subinterface s0/0.1 and kept it simple.:


Building configuration...

Current configuration : 1503 bytes
!
version 12.2
service tcp-keepalives-in
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname ######
!
logging buffered 4096 debugging
no logging monitor
enable secret ############3
enable password ##############
!
ip subnet-zero
no ip routing
!
!
ip tftp source-interface FastEthernet0/0
ip name-server ############
ip name-server ############
ip dhcp excluded-address 192.168.1.1
!
no ip bootp server
!
no call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip mroute-cache
 fair-queue
 service-module t1 timeslots 1-24
 frame-relay interface-dlci 16 ppp Virtual-Template1
 frame-relay lmi-type ansi
!
interface Virtual-Template1
 ip address negotiated
 ppp chap hostname ######@###
 ppp chap password ###########
 ppp ipcp accept-address
 ppp ipcp dns request
!
ip nat inside source route-map RMAP_1 interface Virtual-Template1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
no ip http server
!
access-list 1 permit any
access-list 104 permit ip any any
route-map RMAP_1 permit 1
 match ip address 104
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password #############
 login
!
end
So you don't have a gateway from what i can see. you might change your route either to the sub interface on the serial if you are using it, the gateway on the virtual-access scope

Author

Commented:
Just an update since its been a little while.

I needed to run the
IP Route command to turn on ip routing.  Even though i dont need to specify the route protocol it seems it wasnt enabled.

Now to configure NAT.  THanks for the help.

Author

Commented:
Points awarded for being extremely helpful getting me to thefinal config.  Answer to last issue was ip routing had not been enabled.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.