We help IT Professionals succeed at work.
Get Started

Secondary IP address

netdoc01
netdoc01 asked
on
886 Views
Last Modified: 2008-09-10
Hello,

Please see a sample of my config below. What I want to do is to add another secondary IP address (171.1.0.0/16) to vlan1 and to DHCP scope 0. Will it work? I've never done it so I am not sure if if will work or not. If it works what is the drawback of having multiple secondary IP addresses.

My subunets:
10.1.21.0/24
192.128.1.0/24 secondary
171.1.0.0/16 secondary (THIS IS WHAT I WANT TO ADD!!!)


--------------------------------
ip dhcp excluded-address 10.1.21.1

ip dhcp pool 0
   network 10.1.21.0 255.255.255.0
   network 192.128.1.0 255.255.255.0
   network 171.1.0.0 255.255.0.0     (WILL THIS WORK??)
    default-router 10.1.21.1
!
interface FastEthernet0/0
 description Uplink to router
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 spanning-tree portfast
!
interface FastEthernet0/1/1
 spanning-tree portfast
!
interface Serial0/0/0
  bandwidth 1544
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type ansi
!
interface Serial0/0/0.1 point-to-point
 bandwidth 768
 ip address 10.1.4.74 255.255.255.252
 frame-relay interface-dlci 30  
!
interface Vlan1
 ip address 10.1.21.1 255.255.255.0
 ip address 192.128.1.0 255.255.255.0 secondary
 ip address 171.1.0.0 255.255.0.0 secondary  (WILL THIS WORK?????)
!
router eigrp 1
 passive-interface default
 no passive-interface Serial0/0/0.1
 network 10.0.0.0
 network 192.128.1.0
 no auto-summary

Comment
Watch Question
This problem has been solved!
Unlock 2 Answers and 3 Comments.
See Answers
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE