STOP Error while installing XP on new desktop build

I have finished a desktop build which will be used as a simple server.  Hardware specs are listed below.  While trying to install either XP Pro SP3 or Server 2003 R2, it goes as far as "Setup is Loading Windows" (after loading all of the drivers) and then displays the following STOP error:

STOP: 0x0000007B (0xF78D2524,0xC0000034,0x00000000,0x00000000)  [on 2003 Server, the error code is 0x0000000a].

Both OS install disks are legal; the XP disk is the one I use at work on countless machines, and I've never had a problem with it, and the 2003 disk is the one I purchased with the parts.  The eventual goal is to have 2003 server running a very small domain and sharing out a few important files.  RAID is built onto the SATA controller and I have two identical drives, which I plan on mirroring for data redundancy.  For troubleshooting purposes, I'm simply installing XP Pro (since somewhere I read that 2003 Server "doesn't support" Intel boards) and have turned off the raid controllers, instead setting the SATA controllers to AHCI.

SPECS:
- CPU: Intel Core 2 Quad - Q6600 Kentsfield 2.4GHz
- MB: Asus P5K3 Deluxe/WIFI-AP
- Graphics: EVGA GeForce 6200LE
- Memory: 2x 2GB Corsair XMS2 DHX DDR2 800 (PC2 6400) (4 GB total)
- Storage: 2x Seagate Barracuda 250GB 7200 rpm 32MB cache SATA 3 gbps

I have a very good amount of experience building and configuring desktop pc's both on the hardware and software sides, and I've never spent as much time on a single computer as this project has taken so far, so thank you in advance for any help you can provide.

~ Jonathan
LVL 4
jonnyz0109Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joinaunionCommented:
I belive you need to install third party drivers when setup prompts you for them.
jonnyz0109Author Commented:
The RAID controller is disabled, so what would I need third party drivers for?

I made the following adjustments in BIOS and it got to the setup screen for the first time on any OS:

SATA Confiration: [Compatible]
      Configure SATA as: [IDE] (Previously was "AHCI")

J-Micron eSATA/PATA controller: [Disabled]

Do I need third party drivers as long as the J-Micron controller is enabled?  I previously loaded drivers from Asus' website onto a floppy but was unable to load them during setup.  Any suggestions?
Aaron FeledyDrupal Developer and ConsultantCommented:
You might have some bad RAM. Try booting a Memtest86+ disc and checking for errors.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Aaron FeledyDrupal Developer and ConsultantCommented:
jonnyz0109Author Commented:
I suspect that joinaunion is on the right track, as simply setting SATA Configuration to "RAID" and creating a RAID set is now crashing the install.  I am NOT using the J-Micron controller but Intel one.  I think I need to create a floppy that can be read during installation... I have to run out more but will try more later.  Any ideas or guidance as to your experience with loading RAID drivers during setup would be appreciated.  A friend who has worked with RAID in the past said simply, "RAID *never* works with XP" and he sighed.

There must be an answer out there, since it's such a commonly used technology.  :)

Also, an additional bit of information - I do not have a RAID set separate from a boot drive, simply because I didn't want to pay for an extra drive, and the amount of data will be so small, it'd be an incredible waste.  These are about the smallest drives that I could find as it was.
aleghartCommented:
>A friend who has worked with RAID in the past said simply, "RAID *never* works with XP" and he sighed.

I have Promise SATA controllers running RAID 1 on 3 XP machines.

Make the manufacturer's floppy disk.  Hit F6 during install.

Sighing optional.
Aaron FeledyDrupal Developer and ConsultantCommented:
I've never had such problems with a RAID installation. If the drivers aren't defined, windows simply doesn't see the hard drives. I've never had a crash before. But, you must create the RAID driver floppy disc for windows to get the drivers. These usually come on the motherboard's driver CD. Once you start the windows installation, you press F6 (if i remember correctly) to load the drivers from the floppy.
joinaunionCommented:
trust me third party drivers.
rjt82Commented:
is there a pci dialup modem card in there? if so pull it out

basicly pull out any hardware you dont need for the install (so drop down to 2gig of ram) then once its installed (hopefully) put them back in 1 by one (at which point they will probably detect and install fine)
rjt82Commented:
another thought pull the HDD out put it in another PC and run a full checkdisk on it
jonnyz0109Author Commented:
From Asus' website, I downloaded the following file and created a 64-bit floppy disk:

Make Intel ICH9 RAID Driver Disk Version 7.5.0.1017 for Windows 2000/XP/2003 & 64bit XP/2003/ Vista/ 64bit Vista.

When setup first launches, pressing F6 does nothing (though F2 works fine when that message is displayed).  Regardless, a message comes up prompting me to press S to load additional drivers.  I press S and provide the floppy, and get the following error message: File txtsetup.oem caused an unexpected error (1024) at line 1896 in D:\nt\base\boot\setup\oemdisk.c.  Press any key to continue.

Any ideas?
sandybridgeCommented:
Have you cross checked whether you are using the drivers for 32-bit OS 64-bit OS. After extracting the RAID drivers, you get 2 folders for 32 & 64 bit OS.
If you have a 64-bit system, use F6flp64.exe.
If you have a 32-bit system, use F6flp32.exe.

However, if you have selected the correct driver, then the files might be corrupted. Try downloading it once again.

RockChalkCommented:
Without question, your issue is that you need the drivers.  You 0x7B stopcode means inacessable boot device.  This is consistent with what you did-- you installed Windows in IDE mode, and then you switched to AHCI mode.  When you switched mode, the SATA controller reconfigures itself and reports itself to Windows as a completely different device.  XP doesn't have the drivers for the AHCI controller.  When it tries to boot, it doesn't have the drivers to acces it.  The early boot process relies on the BIOS INT13 calls, which do not requier a driver, which is why you see it start to boot before the BSOD.

Joinaunion is correct that you need the F6 drivers to get the install to work.  Also note that you cannot change the setting after you install windows, so if you'll ever want to use RAID, set it to RAID before you start.  The F6 process is the same.

You said you created a 64-bit floppy disk (the 64-bit driver is different from the 32-bit driver).  Are you running XP64?  If you're not running the 64-bit version of XP, you should not be using the 64-bit driver, it will not work.

jonnyz0109Author Commented:
sandybridge: Yes, I'm using the correct version.  I had switched to trying to get 2003 Server to install, and was using the 64-bit drivers for that, as I have Server 2003 Standard x64; I've got 32-bit XP SP3 back in now, with the 32-bit drivers, and the error is only slightly different: "File txtsetup.oem caused an unexpected error (1024) at line 1747 in d:\xpsp\base\boot\setup\oemdisk.c.  Press any key to continue."

RockChalk: You've made me feel like you're too important and/or too busy to read the entire thread.  "you installed Windows in IDE mode, and then you switched to AHCI mode" -  If you read up, you'll see that the installation has not succeeded once, the RAIDED volume is completely empty and I'm trying to get the installation to go.  You'll also see that we've already determined that I need drivers, that I've already set it to RAID, and that I'm already trying to load drivers via F6.  Also, as I mentioned in my last post, pressing the F6 key doesn't do anything - I have to wait for it to fail and ask me for device drivers before I can load them from the floppy.

Also, the downloaded files are not corrupt.  I have repeated the download at least 3 times with the same result.

Any ideas guys?
jonnyz0109Author Commented:
Arrow 1:  I downloaded MemTest86+ and ran it with just one stick of ram at a time.  For the first, It boots into the utility and immediately the second line goes to 7% then stops - Nothing else seems to happen.  After switching out to the other stick of ram, the test is moving along on it's own.  So does that mean I have a bad stick of ram?
jonnyz0109Author Commented:
And I tried running both XP and 2003 installations with just this one stick of ram, and I'm getting the STOP error again, instead of it asking me for the third party drivers.  So I guess I'm resetting my bios options, recreating the raid, and starting over...
joinaunionCommented:
Can you put the drivers on a cd ?
aleghartCommented:
> Can you put the drivers on a cd ?

Not with Microsoft.  They use floppy drives only.  If you don't have a floppy drive, you can buy a USB model that can be used on multiple machines.  Not all USB floppy drives work with Windows boot installation.  Iomega doesn't.  My TDK does.

If you have done it before, you can create a slip-streamed installation CD...where the OEM drivers are written onto a new installation CD.  I've used nLite with mixed success for Server2003.  Highpoint RocketRAID drivers never seemed to work, even after 6 attempts (resulting in 6 coasters and 12 hours of lost productivity).  Ended up leaving the 1u case open with CD-ROM and floppy drive dangling outside for the installation.
jonnyz0109Author Commented:
Just to keep updated info here... I don't need to slipstream drivers into a custom install disk because I have a working floppy drive, and it's loading the drivers.  The problem is that those drivers are causing an error and aren't working.  I suppose I can try nLite tomorrow but I'm beginning to think a support call to Asus is in order.
Chris BRetiredCommented:
F6 doesn't appear to do anything when you hit it, but is will ask for the driver a short time later. Your floppy setup looks suspect. Along with textsetup.oem you should have a couple of .cat's a couple of .inf's and a .sys. The .c file you have sounds compressed. Please review the instructions for creation of the floppy.

Chris B
sandybridgeCommented:
Yup, Chris B is absolutely right. When you press F2 it actually looks for the floppy however, it is only for Automated System Recovery (ASR) and not driver installation. As you said the files used are correct. So, after pressing F6 wait for sometime and it will give the option to press S. Then check if you face the same issue.

Some more information for reliability:
-Windows 2003 is not tested on this motherboard (so think before you use):
http://www.asus.com/products.aspx?modelmenu=2&model=1645&l1=3&l2=11&l3=534&l4=0
-And please check Validated memory list (I doubt whether 2GBs are validated):
http://www.asus.com/999/download/products/1645/1645_10.pdf
jonnyz0109Author Commented:
burrcm: Thank you for the clarification on F6, I assumed that there would be some sort of visual feedback when pressed, but now I can see that the option to press "S" to load additional devices only comes up after I've pressed F6. What I don't understand is why you say my floppy system looks suspect? It looks to the floppy drive and loads the files, returning a file that is actually on there. Also, the .c file has a path pointing to the CD Rom, not the floppy, so I don't think that is related. As for creating the floppy, I've read it 5 times and it couldn't be easier. Download the file, insert a formatted floppy, and double click the floppy creation app.

Following is the file listing of the floppy I have been using (I think this one is at 32-bit as I was working with XP last).

  • iaahci.cat
  • iaahci.inf
  • iastor.cat
  • iastor.inf
  • iastor.sys
  • license.txt
  • readme.txt
  • txtsetup.oem
sandybridge: I get the 'txtsetup.oem' error after pressing "S" to load additional devices.  Also, we can take 2003 server out of the mix, because XP Pro won't even install - something I've never had happen to me in 8 or so years of building and supporting computers.

Obviously this isn't something that is easily solved, so I'm bumping the points up to 500.
joinaunionCommented:
If you go here http://support.asus.com/download/download.aspx?SLanguage=en-us
Then select motherboard then socket775 then p5k deluxe/wifi-ap then click search then click chipset,scroll to win xp and download then scroll to bottom download win xp version 8.3.0.1013

*Just to note in the specs you provided your board is p5k3 deluxe/wifi-ap,this board only comes in deluxe or premium wifi-ap.Is your specs typo)*
joinaunionCommented:
Chris BRetiredCommented:
The listed files look fine, so the d:\xpsp\base\boot\setup\oemdisk.c. reference is something it is looking for on the CD. The discussion here http://www.thetechguide.com/forum/lofiversion/index.php/t9620.html 
points to a long string error in txtsetup.oem, might be worth a look. Sure you aren't using the 64 bit version? I will upload a floppy to my website in a bit which should work for you. EE won't allow the .cat even in a zip. Rats.

Chris B
Chris BRetiredCommented:
If you go here - http://www.cburrage.bigpondhosting.com/Downloads.htm and grab intel.zip, expand and copy to a floppy, it should work fine.

Chris B
sandybridgeCommented:
I hope you have tried the RAID 1 re-configuration and initialization (Important after RAID configuration).
Basically it seems to be an issue related to RAID drivers. The filenames will be the same for both 32 & 64 bit drivers. So please select them wisely.
BTW, were you able to try the drivers uploaded by Chris?
I guess you are able to install XP in non-RAID mode.
Have you tried configuring RAID 0 and test the same with the RAID drivers?
jonnyz0109Author Commented:
I haven't tried Chris's drivers yet as I never got a chance to work on the box last night.  But to respond to your comment - what do you mean by "RAID 1 re-configuration and initialization?"  I booted into the RAID BIOS (or whatever it is) by holding CTRL+I at boot.  Then I created the array by selecting RAID 1 and adding the two drives to the array.  In that area, everything displays as working normally.  I am able to install XP in non-raid mode, and I have not tried RAID 0 at all (I can try that tonight).

- Jon
jonnyz0109Author Commented:
burrcm: I tried loading the files in intel.zip onto a floppy, and it produces the same error message when I try to load additional devices.  Should I have left all three folders on the disk (intel, via, silicon)?

Sandybridge: I'm curious to hear about what you meant by "RAID 1 re-configuration and initialization."

Also, creating a RAID 0 array between the two drives produces the same results when I try to install XP Pro.  Again, for reference, the error is: File txtsetup.oem caused an unexpected error (1024) at line 1747 in d:\xpsp\base\boot\setup\oemdisk.c. Press any key to continue.

>A friend who has worked with RAID in the past said simply, "RAID *never* works with XP" and he sighed.

I have Promise SATA controllers running RAID 1 on 3 XP machines.

Make the manufacturer's floppy disk.  Hit F6 during install.

Sighing optional.

You're awefully quiet now... :(
aleghartCommented:
> You're awefully quiet now... :(

[chuckling]
I'm fighting my own nightmare...getting Server 2008 installed on a test platform.  Highpoint is less than helpful with 2008 drivers.  They will issue press releases, but not the actual drivers mentioned in the press release.

All I did was re-format RAID and put in the 2008 DVD.

My apologies for not being much more help.

On a good note...I ran 2003, 2003R2, and XP Pro in this chassis with two different RAID cards.

I'm still standing by my comment...it's not XP OS that is not "RAID compatible".  It's a problem among mobo, controller, driver (specific to OS).

I'm painfully reminded of that every time I reboot this test box.
Chris BRetiredCommented:
That multi disk should offer choices from memory. I have just found a solution to a similar issue, the only one so far, so maybe there is something in it. The indication is that a program crash is occurring to to a bad reading floppy drive (on a new build). Have a look - http://www.planetamd64.com/lofiversion/index.php?t7719.html

Chris B
sandybridgeCommented:
jonny, really sorry to sound confusing here ("RAID 1 re-configuration and initialization"). I just missed the CTRL+I part in your POST and thought for a moment that it was CTRL+E configuration :)

Actually I have adoubt here. After you press S, do you get the error message immediately? Aren't you getting the list of available adapters? If yes then you must select the following adapter
Intel® 82801IR/IO SATA RAID Controller (It is for ICH9R)
You can again review the steps for RAID configuration from ICH9R (Matrix Storage) here:
http://www.intel.com/support/chipsets/imsm/sb/CS-020670.htm

Well, if you are too sure about the steps (as well as RAID drivers) you have performed then I think that there might be an issue with the RAID controller. You can give a try with J-Micron to isolate this issue.
jonnyz0109Author Commented:
burrcm: I'll grab a floppy drive from work today and see if that makes a difference.

sandbridge: no problems!  I get the error message immediately after it reads the disk - no list of adapters is displayed.  The J-Micron controller is external only (I think) but I suppose it's worth a try.

Thanks again for your continued help.
jonnyz0109Author Commented:
I had forgotten this question was still open.  I never got this to work, but instead I disabled RAID altogether and am simply running automated DriveImage XML backups onto the second drive.  Thanks to all of you who tried helping, but obviously at some point it's not worth continuing to bang one's head against the wall when there are alternatives that are easy to setup.

I guess I'll ask for a refund of points on this one.  Thanks again to everyone who helped.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joinaunionCommented:
Well sorry to hear that it did not work out for you I was trying my best but oh well.

jonnyz0109Author Commented:
Joinaunion: yes, thank you so much for all the work you put into it.  I still to this day have no idea why something so simple never worked, but oh well.  Automated backups is (sort of) good enough, it just means I have to restore a backup if one drive dies, as opposed to the spare just jumping in.
joinaunionCommented:
Just to note after reading your motherboards manual there is alot of steps to take to get this to work so if you are intrested again let us know.I will attach your manual so you can review it.
e3328-P5K3-Premium.pdf
jonnyz0109Author Commented:
Hi, thanks for that, but I spent hours buried in that manual, to no avail.  It seems to be a problem with Windows more than the motherboard, as I had no problems with Ubuntu.  And, if I had a third drive in there for the OS, everything would have worked, but then that defeated the purpose of a RAID for me - one drive fails but everything continues working until I can get a new drive installed.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Desktops

From novice to tech pro — start learning today.