We help IT Professionals succeed at work.

Can READ, but Cannot WRITE to USB Drives Connected to TeraStation Live

craiggold
craiggold asked
on
4,883 Views
Last Modified: 2013-11-14
This sounds simple, but I've tried everything short of calling Buffalo Tech Support...

I have a 2GB Terastation live connected to my network. To that TeraStation, I have two Ximeta Netdisk drives connected, both in USB mode.

On both of my machines (1 is Win2K, the other XPSP2) I can read all of the files on the drives.  But I cannot copy to either drive -- I keep getting an access denied message/no permissions/file may be in use.

This happens for any/all files I try to copy.  The file is not in use...

Permissions are turned off -- everything should be "open" on the network.

Access to the drives worked fine the first few days, but I've been getting this message for about two weeks now.

I've rebooted the computers, the router and the TeraStation. No luck.

Now this was strange: Just for fun (and because I had exhausted everything else), I turned permissions on, and gave all of the users read/write access. But now I cannot log into the USB Shares with the required network credentials (yes, I am changing the username to the correct one and using the correct password with each username)

Turned permissions off, mounted the drive, can read but cannot write.

I've looked at every screen on the Web Admin interface.  All of them tell me there's write access.

Any ideas you may have are appreciated.  Thanks for reading this far.

-- Craig

Comment
Watch Question

Author

Commented:
The disks are not full, either, each has about 50GB remaining...
Retired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
... one other question:  I assume the answer is Yes; but just to confirm ... does the TeraStation work correctly (i.e. read/write access with no issues) when accessing the internal drives?
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
... and a couple final thoughts before I hit the sack:  

=>  Is your TeraStation at the most current firmware level?  [214_102]

=>  You noted you've "...  tried everything short of calling Buffalo Tech Support..."  ==> An e-mail to Buffalo would seem a reasonable thing to do here :-)   There may very well be some simple reset action that's not obvious when perusing the web admin screens.   (although if you're not at the current firmware level, I'd do that upgrade first ... it may simply resolve the issue)

Author

Commented:
garycase--

Thanks for your thoughts.  Here are some replies:

-- The TS itself works just fine.  Read/Write/create dirs/move -- everything seems great with the device itself!

-- I did not reformat the drives before plugging them into the TS.  They worked fine with the TS the first few days I had it.  If nothing else works, I'll try that.

-- I have not tried another external USB drive.  I have a friend bringing one over tonight. I'll let you know how that goes.  Great idea.

-- My current firmware is 2.14 per the admin screen.  I don't see the additional "_102," so if the alternate USB drive doesn't work, I'll try new firmware. Keep your fingers crossed for me on that one!

-- The Ximeta's do work fine over ethernet, and while that may be a preferable mode for internal use, I'd just like to avoid their software.  There seems to be a conflict with their software and my system.  With the Ximeta software on my machine, it crashes every 6 hours or so.  When I removed it, the crashing stopped.  Besides, the less proprietary software I'm tied to, the better I feel ;)

I'll write again later this evening after I've had a chance to try your suggestions.  Thanks for your time.  Hope you got some sleep!

-- Craig



Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
Interesting to know the XiMeta NDAS software isn't reliable ... they sure do a nice job of making it sound like it's the best thing since sliced bread :-)   [although I'm always skeptical of marketing claims]

I suspect your v2.14 firmware is indeed the latest (there's only one 2.14.xxx download on their site -- although it's always possible they had multiple releases at that level).

I'd guess that the XiMeta's may not be fully MSC compliant in USB mode (since most folks who buy them probably use them via ethernet -- although your experience with NDAS may mitigate that assumption).   It will be interesting to see if another USB drive works differently.    Also, do the XiMeta drives work fine if you directly connect them to a PC via USB??

The real question here, of course, is whether or not the issue is with the XiMeta drives or the TeraStation.   If the symptoms don't change with a "standard" USB drive, I'd certainly send Buffalo a note.

Author

Commented:
Just an update.  I finally plugged-in a non-Ximeta drive to the TeraStation.  Actually, this new drive is  made by Buffalo.

Same result. No write access.  But when I plug either the Ximeta or the Buffalo directly into my local machine, I have write access just fine.

So moving on to your next suggestion: Letting the TeraStation format the drive.  I'll do that now.

Author

Commented:
garycase --

You were correct in your very first post:

'on page 37 of the TeraStation Live manual it notes "... Some USB hard drives must be reformatted from within TeraStation before they can be assigned shares." '

Turns out that my version of the TeraStation only likes XFS, FAT32 and EXT3 filesystems.

Both of my Ximeta drives are formatted NTFS.

I still have no idea how I was able to copy files TO the drive, but I was. I have since copied 2 or 3 other files, but those were the exception, not the rule. Reformatting to XFS solved the problem, and made write access the rule and not the exception.

Thank you.

-- Craig Gold

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.