We help IT Professionals succeed at work.

ASA5505 vpn clients can't talk to inside hosts

ASGWichita
ASGWichita asked
on
735 Views
Last Modified: 2010-05-18
My ASA5505 is configured and working as a firewall, however, I am having issues with the VPN and need an expert's eyes and input.  I can successfully connect via vpn, but once connected, I cannot talk to anything inside.  No ping, no intranet, no RDP, no telnet....  The weird part is that the config that I am running was copied from another ASA5505 (the IP's changed and the RADIUS settings changed and verified as working) that is working just fine.

The installation is as follows:
************************                ****************************             ***************************
*  ISP  - IP #2          * -----------* ASA VLAN2 Port 0/0* \\\\\////// *ASA VLAN1 Port 0/1* -------> INTERNAL
************************                ****************************             ***************************
Cisco VPN Client 5.0 is being used.
RADIUS is operating fine.
VPN connects to the defined interface IP (OUTSIDEIP2)
Services connect to (OUTSIDEIP1)

ASA Running Config (security trimmed)
---------------------------------------------------------------------------------------------------------------------------


: Saved
:
ASA Version 8.0(3) 
!
hostname ASGASA
domain-name asg.int
enable password ************** encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.50 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address OUTSIDEIP2 255.255.255.224 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd *********** encrypted
boot system disk0:/asa803-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns domain-lookup inside
dns server-group DefaultDNS
 name-server 192.168.0.51
 name-server 192.168.0.53
 domain-name asg.int
access-list ASG_VPN_splitTunnelAcl extended permit ip 192.168.0.0 255.255.255.0 any 
access-list inside_outbound_nat0_acl extended permit ip 192.168.0.0 255.255.255.0 172.16.2.0 255.255.255.0 
access-list outside_cryptomap_dyn_20 extended permit ip any 172.16.2.0 255.255.255.0 
access-list Outside_access_in extended permit tcp any host OUTSIDEIP1 eq smtp 
access-list Outside_access_in extended permit tcp any host OUTSIDEIP1 eq https 
access-list Outside_access_in extended permit tcp any host OUTSIDEIP1 eq www 
access-list Outside_access_in extended permit icmp any any echo-reply 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool IP_Pool 172.16.2.1-172.16.2.254
ip verify reverse-path interface outside
ip audit attack action alarm drop
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-603.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp OUTSIDEIP1 smtp 192.168.0.51 smtp netmask 255.255.255.255 
static (inside,outside) tcp OUTSIDEIP1 https 192.168.0.51 https netmask 255.255.255.255 
static (inside,outside) tcp OUTSIDEIP1 www 192.168.0.52 www netmask 255.255.255.255 
access-group Outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 24.249.22.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa-server RADIUS protocol radius
aaa-server RADIUS host 192.168.0.51
 key **************
aaa authentication http console RADIUS LOCAL
aaa authentication ssh console RADIUS LOCAL
aaa authentication serial console RADIUS LOCAL
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 20
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
ssh version 2
console timeout 0
management-access inside
 
threat-detection basic-threat
threat-detection statistics
webvpn
 enable outside
 svc image disk0:/anyconnect-win-2.2.0128-k9.pkg 1
 tunnel-group-list enable
group-policy SSLVPN internal
group-policy SSLVPN attributes
 dns-server value 192.168.0.51
 vpn-tunnel-protocol svc 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value ASG_VPN_splitTunnelAcl
 default-domain value asg.int
 address-pools value IP_Pool
 webvpn
  svc keep-installer installed
  svc keepalive 60
  svc dpd-interval client 30
  svc dpd-interval gateway 30
group-policy ASG_VPN internal
group-policy ASG_VPN attributes
 dns-server value 192.168.0.51
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value ASG_VPN_splitTunnelAcl
 default-domain value asg.int
group-policy WebVPN internal
group-policy WebVPN attributes
 vpn-tunnel-protocol webvpn
username xxxxxxxxx password ************** encrypted privilege 15
username xxxxxxxxx password ************** encrypted privilege 15
tunnel-group ASG_VPN type remote-access
tunnel-group ASG_VPN general-attributes
 address-pool IP_Pool
 authentication-server-group RADIUS LOCAL
 default-group-policy ASG_VPN
tunnel-group ASG_VPN ipsec-attributes
 pre-shared-key **************
tunnel-group SSLVPN type remote-access
tunnel-group SSLVPN general-attributes
 address-pool IP_Pool
 authentication-server-group RADIUS LOCAL
 default-group-policy SSLVPN
tunnel-group SSLVPN webvpn-attributes
 group-alias SSLVPN enable
tunnel-group WebVPN type remote-access
tunnel-group WebVPN general-attributes
 address-pool IP_Pool
 authentication-server-group RADIUS LOCAL
 default-group-policy WebVPN
tunnel-group WebVPN webvpn-attributes
 group-alias WebVPN enable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 1028
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect http 
  inspect icmp 
  inspect icmp error 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:b95e0ce7bc2eb8687b1819a596b49c13
: end
asdm image disk0:/asdm-603.bin
asdm location 192.168.0.51 255.255.255.255 inside
asdm location 192.168.0.52 255.255.255.255 inside
no asdm history enable

Open in new window

Comment
Watch Question

CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Arnold is correct...  It is likely the line:  no crypto isakmp nat-traversal that is the problem.  If you are connecting from behind a NAT firewall, NAT traversal must be enabled....

Author

Commented:
That is weird...   I saw that line and thought it was out of place, but it was present after I did two factory restores...   1 via ASDM and the second via CLI.    

Seems to have fixed the problem.  Thank You!!!
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.