We help IT Professionals succeed at work.

Problem creating link server - to oracle db

deNZity
deNZity asked
on
713 Views
Last Modified: 2012-05-05
I get the following error msg when trying to create a linked server...

TITLE: Microsoft SQL Server Management Studio
------------------------------

"The linked server has been created but failed a connection test. Do you want to keep the linked server?"

------------------------------
ADDITIONAL INFORMATION:

An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

------------------------------

Named Pipes Provider: Could not open a connection to SQL Server [53].
OLE DB provider "SQLNCLI" for linked server "GHWPRD" returned message "Login timeout expired".
OLE DB provider "SQLNCLI" for linked server "GHWPRD" returned message "An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections.". (Microsoft QL Server, Error: 53)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=09.00.3215&EvtSrc=
MSSQLServer&EvtID=53&LinkId=20476

I can connect to the oracle database using Oracle net manager and via ODBC connection,
But when I try creating the linked server from within management studio...

Linked_Server :   'XXX'
Provider: 'Microsoft OLE DB Provider for SQL Server'
Data Source: 'XXX'

security tab has  Be made using this security context and a username and password that definetly work.

I have also tried creating linked server using the 'Microsoft OLE DB Provider for ODBC Drivers'

which results in a different error.

I have created a working linked server on another sqlserver2005 box using the same criteria but for some reason not
successful with this server.

Comment
Watch Question

This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Thanks That was the provider I was using,just typed the wrong one here. The issue was the datasource, I had missed out a letter in the name.

thanks for the reply points are yours
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.