We help IT Professionals succeed at work.
Get Started

Problem importing a certificate

1,331 Views
Last Modified: 2008-07-22
A user is trying to import a certificate (.p12 file) to access the English National Concessionary Travel System (ENCTS)
This certificate has been successfully imported by many of our users (and myself as a test)
She runs through the installation wizard, entering the password when required and using the defaults, and at the end gets the error message -
"An internal error occured. The private key that you are importing might require a cryptographic service provider that is not installed on your system"

I'm pretty certain that the problem is user specific, she mentioned that she had tried on a couple of PCs. I had look on one of them and I could import the same certificate file (although I am domain admin). I have tried making her a local admin on the PC and it made no difference so I don't think it is a machine security issue, nor do I think it is a problem with installation of components on the PC.
The PC is running Windows XP SP2

Any ideas?
Comment
Watch Question
Commented:
This problem has been solved!
Unlock 1 Answer and 5 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE