We help IT Professionals succeed at work.

logon script wont load via GP

phrea84
phrea84 asked
on
431 Views
Last Modified: 2011-10-19
Hi

I recently made a logon scrtipt and configured it via GP.  i have manually tested the script and it runs fine, but it will not run as configured under GP.

i have rebooted, forced a gpupdate, and tried many times.  i have verified the script is in the proper location.

please assist.  i am not sure why this wont load.

Thanks
Comment
Watch Question

Commented:
Run gp modeliing wizard and see policies are applying to the OU

Author

Commented:
looks good via the wizard.  i have this configured on a GPO i created instead of default domain policy.  does this matter?

any idea why it wont run?

Author

Commented:
i beleive i have found the problem, but am not sure how to fix.  the GPO for user settings was not applied because it's n/a   how do i get this to get applied?


Microsoft (R) Windows (R) XP Operating System Group Policy Result tool v2.0
Copyright (C) Microsoft Corp. 1981-2001

Created On 7/14/2008 at 9:46:48 AM



RSOP results for POSS\XXXXX on POSS-LAPTOP1 : Logging Mode
------------------------------------------------------------------

OS Type:                     Microsoft Windows XP Professional
OS Configuration:            Member Workstation
OS Version:                  5.1.2600
Domain Name:                 POSS
Domain Type:                 Windows 2000
Site Name:                   Default-First-Site-Name
Roaming Profile:            
Local Profile:               C:\Documents and Settings\XXXXX
Connected over a slow link?: No


COMPUTER SETTINGS
------------------
    CN=POSS-LAPTOP1,OU=2000/XP/VISTA  -Aspen,DC=XXXXX,DC=com
    Last time Group Policy was applied: 7/14/2008 at 9:43:33 AM
    Group Policy was applied from:      XXXXX
    Group Policy slow link threshold:   500 kbps

    Applied Group Policy Objects
    -----------------------------
        WSUS - Aspen

    The following GPOs were not applied because they were filtered out
    -------------------------------------------------------------------
        Local Group Policy
            Filtering:  Not Applied (Empty)

    The computer is a part of the following security groups:
    --------------------------------------------------------
        BUILTIN\Administrators
        Everyone
        Debugger Users
        BUILTIN\Users
        NT AUTHORITY\NETWORK
        NT AUTHORITY\Authenticated Users
        POSS-LAPTOP1$
        Domain Computers
        Printers
       

USER SETTINGS
--------------
    CN=XXXX,CN=Users,DC=XXXX,DC=com
    Last time Group Policy was applied: 7/14/2008 at 9:43:47 AM
    Group Policy was applied from:      XXXX
    Group Policy slow link threshold:   500 kbps

    Applied Group Policy Objects
    -----------------------------
        N/A

    The following GPOs were not applied because they were filtered out
    -------------------------------------------------------------------
        Local Group Policy
            Filtering:  Not Applied (Empty)

Commented:
As long as the GPO  is applying to the right items its fine.

To test you can disable the second gpo you made and update the default domain policy and test.  If it still doesnt work then try and troubleshoot.  Logon scripts should be under the user config not the computer config and the scripts need to be in the sysvol/scripts directory

https://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/Q_20922065.html

Commented:
Ah - did you link the gpo to the user OU?

Author

Commented:
yes it is liked.  just to double check, i am suppossed put the place of the script in the USER configuration, NOT computer, correct?

i just tried to re-link and it told me it is already linked.  it loads the setting of the GPO for the computer part, just not for the user.

Author

Commented:
here is a pic of the gpo

thanks for the help.  i know i am close to getting this.
gpo.JPG

Commented:
Correct log on scripts go in user config look in the link I provided

Commented:
The rest of the GPO works Ok or no?
If yes then I would try another simple startup script to see what happens.

I would create a very simple batch file maybe to map a drive and see if it works.
This will obviously rule out the script

@Echo Off

REM **** Map Network Drives


net use s: /delete
net use s: \\servername\share
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
ryansoto, im not all that great at scripts.  the rest of the gpo works great (WSUS server is pointed correctly)

ive created a new GPO just for this logon script.  ill attach a pic of the location of the script and the location if GPO.  

thanks
gp1.JPG

Commented:
Scripts go here

\\servername\SYSVOL\domain name\scripts

Put the script in this location and it will replicate it to the right place on the other servers.
Now test outside of group policy
Open active directory users and computers and in the profile tab and under logon script type in the the name of your logon on script.
IE logon.vbs

Do this for one user then reboot and see what happens

Author

Commented:
grrrr....i feel retarded. the script was already under that location.

when i added the logon.vbs to the profile, it worked.  is there a wayh i can get to work without having to go to each account and add logon.vbs?

Commented:
Here is a good article on how to build logon scripts through group policy.
http://www.rlmueller.net/LogonScriptFAQ.htm

Another good article - although this one does it through the default domain policy, which is fine as well
http://windowsitpro.com/article/articleid/81246/jsi-tip-8215-how-do-i-configure-a-logon-script-via-group-policy.html

Author

Commented:
thanks for the links.  i have done the steps in both exactly.  

do you think the problem lies with GP not seeing a GPO for users?

Commented:
Explain?  

Author

Commented:
ill put ******************* around the line.  see below.



Microsoft (R) Windows (R) XP Operating System Group Policy Result tool v2.0
Copyright (C) Microsoft Corp. 1981-2001

Created On 7/14/2008 at 9:46:48 AM



RSOP results for POSS\xxx on POSS-LAPTOP1 : Logging Mode
------------------------------------------------------------------

OS Type:                     Microsoft Windows XP Professional
OS Configuration:            Member Workstation
OS Version:                  5.1.2600
Domain Name:                 POSS
Domain Type:                 Windows 2000
Site Name:                   Default-First-Site-Name
Roaming Profile:            
Local Profile:               C:\Documents and Settings\xxxx
Connected over a slow link?: No


COMPUTER SETTINGS
------------------
    CN=POSS-LAPTOP1,OU=2000/XP/VISTA  -Aspen,DC=billposs,DC=com
    Last time Group Policy was applied: 7/14/2008 at 9:43:33 AM
    Group Policy was applied from:      POSS01-MX-01.billposs.com
    Group Policy slow link threshold:   500 kbps

    Applied Group Policy Objects
    -----------------------------
        WSUS - Aspen

    The following GPOs were not applied because they were filtered out
    -------------------------------------------------------------------
        Local Group Policy
            Filtering:  Not Applied (Empty)

    The computer is a part of the following security groups:
    --------------------------------------------------------
        BUILTIN\Administrators
        Everyone
        Debugger Users
        BUILTIN\Users
        NT AUTHORITY\NETWORK
        NT AUTHORITY\Authenticated Users
        POSS-LAPTOP1$
        Domain Computers
        Printers
       

USER SETTINGS
--------------
    CN=xxxxx,CN=Users,DC=billposs,DC=com
    Last time Group Policy was applied: 7/14/2008 at 9:43:47 AM
    Group Policy was applied from:      POSS01-MX-01.billposs.com
    Group Policy slow link threshold:   500 kbps

  ************************  Applied Group Policy Objects*************************************
    -----------------------------
   **********************     N/A*******************

    The following GPOs were not applied because they were filtered out
    -------------------------------------------------------------------
        Local Group Policy
            Filtering:  Not Applied (Empty)

    The user is a part of the following security groups:
    ----------------------------------------------------
        Domain Users
        Everyone
        BUILTIN\Users
        BUILTIN\Administrators
        NT AUTHORITY\INTERACTIVE
        NT AUTHORITY\Authenticated Users
        LOCAL
        xp
        Domain Admins
        Public Folder Admin
        All Users
        Remote Users - Poss01-TS-01
        RADIUS
        Enterprise Admins
        Schema Admins
        Printers

Commented:
Yeah arent getting applied for some reason.....

What happens if you do the setup in the default domain policy instead of a new one.

Author

Commented:
man.  this doesnt make any sense.  i know this is all set up properly, but it wont apply the gpo settings for the users.

im stuck :(

Author

Commented:
same thing.  it doesnt load the default domain policy, but the one called wsus - aspen.

im confused as to why it matters.

Commented:
Can you see what is applying on the wsus policy?
Since that one seems to be working ok its possible that loopback processing is enabled with user settings disabled.  This would not allow user settings to apply.

If loopback isnt enabled on the wsus policy why not unlink that policy then test again.

Maybe wsus policy is blocking the rest is my though.  Maybe default domain policy has this policy applied...?
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
how do i check if loopback processing is enabled?

Commented:
Also after you make changes from the server you need to run gpupdate /force
then restart the client

Commented:
In the group policy MMC click the policy in the left hand pane then click the settings tab on the right hand pane and then expand all
My screen shot shows
settings-tab.jpg

Author

Commented:
ok.  i got it working.  i made a rookie mistake and when i created a new OU, i added the computers to the OU, but not users.  this explains why computers processed fine, but the users never did.

I will award points in a moment.  where do i check the setting for loopback processing?

Commented:
Loopback is under computer config>admin templates>system/group policy

Author

Commented:
thanks

Author

Commented:
thanks a bunch
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.