We help IT Professionals succeed at work.
Get Started

Bonding T-1's with MLPPP - routing on Multilink

itcinc
itcinc asked
on
1,299 Views
Last Modified: 2012-05-05
I realize this question has been asked and answered many times here but I must be missing some of the details.

I have 2 routers at locations A and B that I want to link using two Point-to-Point T-1's.  Location A has a 1720 with IOS 12.1 and has ONLY a connection to location B.  Location B has an 1841 with IOS 12.3 connected to location A and the LAN.  The LAN at location A has another router that provides Internet access for both location A and B.  Both T-1's are up and running between the sites but are not yet bonded.   This link is in production so down time has to be after hours - don't you just love the IT work schedule.

I know that the 1720 is not recommended for T-1 bonding.  However, the bonding and routing are the only functions being performed on this router - no NAT or FW.  In addition, it is a low usage link but the 3Mb bandwidth is desirable because of data input peaks during remote application usage.

I have seen and tried configuration examples using both Multilink and Virtual Template methods.  So far I can't get the right combination of events to make either of them work.  Must not be holding my mouth right.8)  However, I have managed to come up with a couple of questions.

With the current hardware/IOS combination which configuration (Multilink or VT) is preferred or is easiest?

The current configuration has "ip route 0.0.0.0 0.0.0.0 Serial0" to use the original T-1 interface to route from location A to B.  How to I change this statement when using a Multilink or Virtual Terminal config?

When using a Multilink config I see a "Virtual Access 1" interface with sho int.  It is up but my Multilink interface is down.  Where does this "Virtual Access 1" interface come from and how do I use or not use it?

Below is the code I have tried when using VT.

! Location A
 
multilink virtual-template 1
!
interface Virtual-Template1
 description virtual interface to bond Serial0 and Serial1 to Location B
 ip unnumbered FastEthernet0
 ppp multilink
!
interface Serial0
 description connection #1 to Location B
 no ip address
 no shutdown
 encapsulation ppp
 no fair-queue
 ppp multilink
!
interface Serial1
 description connection #2 to Location B
 no ip address
 no shutdown
 encapsulation ppp
 no fair-queue
 ppp multilink
!
interface FastEthernet0
 description connected to EthernetLAN
 ip address 10.13.3.1 255.255.255.0
 no shutdown
 speed auto
!
router rip
 version 2
 passive-interface Serial0
 network 10.0.0.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Virtual-Template1
 
***********************************
 
! Location B
multilink virtual-template 1
!
interface Virtual-Template1
 description virtual interface to bond Serial0/0/0 and Serial0/1/0 to Location A
 ip unnumbered FastEthernet0/0
 ppp multilink
 service-module t1 remote-alarm-enable 
!
interface Serial0/0/0
 description connection #1 to Location A
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 pulse-time 3
!
interface Serial0/1/0
 description connection #2 to Location A
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 pulse-time 3
!
! Route to Internet
ip default-gateway 10.13.2.1
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.13.2.1
ip route 10.13.3.0 255.255.255.0 Virtual-Template1

Open in new window

Comment
Watch Question
Systems Architect
CERTIFIED EXPERT
Top Expert 2008
Commented:
This problem has been solved!
Unlock 1 Answer and 5 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE