We help IT Professionals succeed at work.
Get Started

having problem sending sms via microsoft smssender

1,462 Views
Last Modified: 2013-12-27
hi, We are using a database program that has a bolt on to send sms messages via microsoft smssender. which then send via a mobile phone connected into the USB point on the server.

smssender sends fine via the graphics interface, but not via the dos prompt. This is a problem because the database program uses the dos prompt to send the sms.

What happens is that in command i type :-

smssender /p:mobile no. /m:"test" /i

p = mobile no.
m = message
i = log sent

I then get the message :-

there is no device previously used by smssender. use the graphical mode by running smssender.exe to select a device.

Reading the help section on ms website. it mentioned that when you go into the smssender it should default to the last modem used. This doesn't happen. I have spoken to the software firm and they think that it should place an entry in the registry in reference to the last modem.

I have been through the reg and cannot find any lines to do with this.

any advice grateful
Comment
Watch Question
Commented:
This problem has been solved!
Unlock 1 Answer and 3 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE