Avatar of RichardPWolf
RichardPWolf
Flag for United States of America asked on

WSUS fails install / reinstall

When trying to install/reinstall WSUS receive error (Wsus setup failed (Error 0x80070643: Fatal error during installation.) A little background is that everything was working fine until about a month ago when this server quit reporting everything. At that time the update service would start and then stop.
The server configuration is;
This is on a Win2k3 DC.
Downstream WSUS server.
All patches current (SP2)
Latest WSUS download.
All prerequisites are met (IIS, .Net 2, Report viewer 2005, etc)
No drives on system are compressed.
It appears to fail either during or just after it's trying to install the WSUS event service.

I have tried the following from many websites including this one;
basic reinstall of WSUS
removed IIS and reinstalled
removed .Net and reinstalled
lodctr /r
deleted all references in the registry for WSUS and MSUS
checked drive for errors
defragged etc
ran registry tools to verify registry integrity
As I'm at my wits end I've attached my WSUSSetup.log and WSUSSetupmsi*.log

Thanks in advance.

Richard

WSUSSetup.log
WSUSSetupmsi-080716-1056.log
Windows Server 2003

Avatar of undefined
Last Comment
RichardPWolf

8/22/2022 - Mon
SOLUTION
AutoIt_Airwolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
SOLUTION
sk_raja_raja

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
SOLUTION
MSE-JNegus

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
-Airwolf- Yes, based on a previous article I have deleted the WSusCertServer entries. The install failed before I deleted those entries. I would have figured that they would be put back after a successful install so if that's the cause then how do I get them back as I don't have them anymore. Now if the keys were the same as on the other servers I'd export them and move them to the failed server.

-raja- Not easily as this is a remote server at one of our branches. BTW; I've got a main and 3 other remotes working fine.

-JNequs- I've done that also. During one attempt from a few days ago I had cleaned the registry and directories completely.

Reference the other article about psfsip.dll  and renaming it. I can't because it's in use. During one of my attempted installs it referenced that file as being newer than the install that I was attempting. That was when I found I wasn't on the latest version.

If I have to rebuild the server I can ...but... it will take some time to keep down time to a minimum.


SOLUTION
AutoIt_Airwolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
Yes, I've ran that also. That did allow me to get farther as some of the entries for WSUS3 were still in there. I've also thought of the windows installer itself but so far haven't found the "lates" verseion to install and what I did find wouldn't install becasue it kept telling me that the current is newer than the one I was trying to install.

I know, I'm grasping also. Again and again I keep going back to what's going on when it's saying it's installing the WSUS even service.
SOLUTION
AutoIt_Airwolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
I've let WSUS install it and from what I can see it looks like it installs ok. Also during the first part of the install it connects to the MSDE ok. I run it also on this machine as it is a remote server and I wanted to keep network traffic down.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
SOLUTION
MSE-JNegus

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
Yes, I just deleted it again. Do you want me to try another installation?
MSE-JNegus

Sure, lets give it another try.
RichardPWolf

ASKER
I'll do first thing in the morning and get back with you. Thanks.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
Good Morning, After cleaning everything up the install still failed. Now I've got a question, seeing as the last message I received before the install failed was that it was loading the event catagories there is a eventcatagories.dll in the common folder of the update services that is locked by another program and I can not delete it or rename it. Could this be the cause and if so would unregistering it help so I could delete it?
SOLUTION
AutoIt_Airwolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
I do have anti-virus running but I've stopped it before without success but will stop it again after unregistering this .dll.
SOLUTION
MSE-JNegus

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
OK. Could not unregister the dll. Received error message stating that it was loaded but the unload point could not be found. Unloaded virus scanner and tried again without any luck. Neither FileMon or Process explorer could not find this dll. If this is the culpret looks like I will need to make a trip to the remote site to be able to reboot into safe mode to remove it. Unless I can find it in the registry.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
SOLUTION
MSE-JNegus

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
SOLUTION
AutoIt_Airwolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
OK next step. I found two references to the event catagory dll in the registry and removed those. After reboot was able to delete the dll. Reinstalled and it got farther ....but.... what I see in the WSUSsetup.log file I think indicates that the psfsip.dll is now the culpret. I am attaching both the WSUSsetup and the WSUSsetupmsi log files again so please look them over and see if I'm on the right track.

Again thank you.
WSUSSetup.log
WSUSSetupmsi-080717-1043.log
RichardPWolf

ASKER
I've ran lodctr /r several times and I usually rebooted afterwards.
SOLUTION
AutoIt_Airwolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
amait

This is great information. RichardPWolf I am in the same boat you are. I even have a posting here also under "WSUS 3.0 SP1 Fails to install" (https://www.experts-exchange.com/questions/23522746/WSUS-3-0-SP1-Fails-to-install.html)

I will keep looking at this posting. The things I did were

1. Delete the temp files from the administrator profile\temp director (held the two log files)
2. Delete the two "user" in AD WSUS Administrators and WSUS Reporters
3. Uninstall WID
4. Delete C:\Program files\update servers folder
5. Delete Any instance of WSUS OR update services from Registry
6. I would then reboot.

Still ended up with a roll back then and unsucessful install....roll back.
I also notice that when looking at IIS you actually see (through refreshing) the custom WSUS site come into the tree..until roll back inwhich is leaves.

Frustrating.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
Unfortunately no-go. Removed WID as the article described and the only key under ...\server\setup was SetupFailure and everything in that was set to 0.
RichardPWolf

ASKER
Also reinstall MSXML4SP2
amait

Just did that two. I am also installed SP1 for .NET Framework 3.0.
I also tried. Stopping IIS while trying the install. It always feels like its going to install, you are crossing your fingers, and then it starts roll back. #$%#%!
Your help has saved me hundreds of hours of internet surfing.
fblack61
RichardPWolf

ASKER
The one thing I can't do is remove the WSUS users as I have 3 other WSUS sites setup i.e. Master and 3 other downstream sites that are working fine.
When I went through the WSUSSetup.log I noticed that it couldn't find psfsip.dll which of course from a previous attempt had been deleted. So I copied it over from one of the other sites. still no-go.
SOLUTION
AutoIt_Airwolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
amait

How do you re-extract the installation files? I guess I am confused. Re-dload?

Thanks

(sorry richardpwolf. I am mooching off of your question.
RichardPWolf

ASKER
That's ok amait,

-airwolf- I had downloaded a new copy of WSUS and copied to the destination server so it would be a local load. I am logged as the domain admin. Let me see if I can log in as another administration account to be able to delete the profile. I'll get back shortly.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
Was able to log in as another administrator (remote) and remove the profile. Tried again without success.
SOLUTION
AutoIt_Airwolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
Apparently somewhere along the line there was an update to the RDP and it changed the switch from /console to /admin and just to verify I'm trying the /console switch again.

And it just failed again. This is bizarre as I've never had an application be this stubborn. And I've raised the points to max as this has turned into an extremely difficult problem.
MSE-JNegus

Just incase I missed something.  Have you tried logging on as another administrator and installing it as that account?
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
amait

I just tried that....still failed.

Dm
MSE-JNegus

Do you have any virus software or any other kind of software running on this server?
RichardPWolf

ASKER
-JNequs- I just walked in this morning and saw you suggestion. I haven't tried another admin account but I have deleted the profile that I was using and then created a new one but that didn't solve anything. Yes there is anti-virus software running but on several occasions I have disabled it to do the install. What I'm wondering is what you and other have seen in the logs. It still seems to be an issue with adding the event service to the system. Could there be a connection between installing WSUS and the event service itself? I'm grasping here but I can't see any reason why this isn't working.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
Yeah I have success. I went back and looked at some earlier suggestions and also did some digging on the last operation that was being performed "eventlog...." anyway I found two instances of wsus certserver and deleted them. Installed ok.

Now the follow-on is that I'm getting .ASP errors and can not connect to the update service console. So far I've restarted IIS but that didn't work.
RichardPWolf

ASKER
The follow on is I'm reciveing these type of messages in the application log;

Event Type:      Warning
Event Source:      ASP.NET 2.0.50727.0
Event Category:      Web Event
Event ID:      1310
Date:            7/18/2008
Time:            10:14:35 AM
User:            N/A
Computer:      BELTONDC
Description:
Event code: 3007
Event message: A compilation error has occurred.
Event time: 7/18/2008 10:14:35 AM
Event time (UTC): 7/18/2008 3:14:35 PM
Event ID: d53786c8c9b24d2fb8096f51452b26f4
Event sequence: 3
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1961192208/ROOT/ApiRemoting30-2-128608676751383018
    Trust level: Full
    Application Virtual Path: /ApiRemoting30
    Application Path: C:\Program Files\Update Services\WebServices\ApiRemoting30\
    Machine name: BELTONDC
 
Process information:
    Process ID: 3820
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: HttpCompileException
    Exception message: (0): error CS0016: Could not write to output file 'c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\apiremoting30\1f9be86c\afc97076\App_global.asax.wf_ktsco.dll' -- 'Access is denied. '
 
Request information:
    Request URL: http://beltondc:8530/ApiRemoting30/WebService.asmx 
    Request path: /ApiRemoting30/WebService.asmx
    User host address: 192.168.4.3
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 1
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at System.Web.Compilation.AssemblyBuilder.Compile()
   at System.Web.Compilation.BuildProvidersCompiler.PerformBuild()
   at System.Web.Compilation.ApplicationBuildProvider.GetGlobalAsaxBuildResult(Boolean isPrecompiledApp)
   at System.Web.Compilation.BuildManager.CompileGlobalAsax()
   at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
   at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
 
 
Custom event details:

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
SOLUTION
AutoIt_Airwolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
Should I restart IIS afterwards?
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
amait

RichardPWolf....

How did you get rid of WSUS Certserver instances? In Registry or somewhere else?

thanks
RichardPWolf

ASKER
Restarted IIS but no-go. Tried both 8530 and 8531 ports to connect to WSUS server and receive the same message.
RichardPWolf

ASKER
-amait- yes registry. You will come accross a key labeled "legacy wsus certserver" which you can not delete and that's ok.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
amait

I had already deleted anything that said WSUS" in the registry after a failed install. This included the "wsus certserver" key. So now when I look for it, its not coming up at all.

It still wont install. DAMN.
amait

I cant help but notice AutoIt_Airwolf's post 2nd from the top

"When you deleted entries in the registry, you deleted the WSusCertServer entries - this is why your install is failing"

I confused. I thought that deleting this entry would make it fail? You are telling me we DO need to delete it?

MSE-JNegus

For test puposes, have you tried installing it on another server?
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
RichardPWolf

ASKER
-amait- I've found many references to delete all occurances of WSUS in the registry. It is always a good idea to at least export the keys before you delete them so that if anything goes wrong you can recover easily.

-jnequs- I currently have three other servers with WSUS on and they are running fine. I've toyed with the idea of creating a temporary WSUS server at this location until I could get the DC rebuilt. Since the installation completed successfully it appears I now have a .ASP issue or an IIS issue. I've already removed IIS and reinstalled during the process of elimination on the install so it's now a fresh install of IIS. I haven't uninstalled .ASP yet and was waiting on suggestions before I proceed.
AutoIt_Airwolf

@amait - I was explaining that deleting the WSUSCertServer values can cause problems. It is possible to cause further problems by deleting them. So, I was telling you not to delete them.
amait

I understand that, but RichardPwolf wrote

RichardPWolf:Yeah I have success. I went back and looked at some earlier suggestions and also did some digging on the last operation that was being performed "eventlog...." anyway I found two instances of wsus certserver and deleted them. Installed ok.

which i thought meant he deleted those instances and it installed...so thats what I tried too.


⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
RichardPWolf

ASKER
-amait- Your right in one fashion I went against what Airwolf said. I did it based on other searches for answers to my problem. And who's to say that I didn't create another problem like the one trying to get into the console by deleting those keys. However from other research on this and other posts on other sites I felt I didn't have anything to lose by removing those keys "and" I exported them before I did so that if I made things worse I could import them back to the registry. I was and still am faced with the possibility of rebuilding this DC if I can't resolve my issues. These keys and many others were not part of the original registry before installation of WSUS in some ways it's like using a system restore point in XP to clean up a botched install of a program. I didn't have that option as I didn't know what else was going to change as WSUS died on this server over a month ago. The way I look at troubleshooting (30+ years of it) sometimes you have to go with your instincts and hope you don't mess up so bad that it cost you more than what it was worth. So in the end yes it worked to get WSUS installed but I'm not out of the woods yet.
RichardPWolf

ASKER
Been trying to decifer this new problem associated with the reinstall of WSUS. It appears that ASP.NET is having a fit when I try and connect to the WSUS console. I've tried two solutions so far neither has worked. 1st solution was to relax the security on server because it's a DC. the other was to change the temporary folder from the user to windows and reset IIS. Here is the application event that's logged. Unfortunately MS isn't much help on this.

Event Type:      Warning
Event Source:      ASP.NET 2.0.50727.0
Event Category:      Web Event
Event ID:      1310
Date:            7/19/2008
Time:            11:06:02 AM
User:            N/A
Computer:      BELTONDC
Description:
Event code: 3007
Event message: A compilation error has occurred.
Event time: 7/19/2008 11:06:02 AM
Event time (UTC): 7/19/2008 4:06:02 PM
Event ID: dfc07b2415384ddfae106037240fdb99
Event sequence: 3
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1961192208/ROOT/ApiRemoting30-1-128609571611677234
    Trust level: Full
    Application Virtual Path: /ApiRemoting30
    Application Path: C:\Program Files\Update Services\WebServices\ApiRemoting30\
    Machine name: BELTONDC
 
Process information:
    Process ID: 240
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: HttpCompileException
    Exception message: (0): error CS0016: Could not write to output file 'c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\apiremoting30\1f9be86c\afc97076\App_global.asax.yeob1lzb.dll' -- 'Access is denied. '
 
Request information:
    Request URL: http://beltondc:8530/ApiRemoting30/WebService.asmx 
    Request path: /ApiRemoting30/WebService.asmx
    User host address: 192.168.4.3
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 1
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at System.Web.Compilation.AssemblyBuilder.Compile()
   at System.Web.Compilation.BuildProvidersCompiler.PerformBuild()
   at System.Web.Compilation.ApplicationBuildProvider.GetGlobalAsaxBuildResult(Boolean isPrecompiledApp)
   at System.Web.Compilation.BuildManager.CompileGlobalAsax()
   at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
   at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
ASKER CERTIFIED SOLUTION
RichardPWolf

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.