Link to home
Start Free TrialLog in
Avatar of michaelheffernan
michaelheffernan

asked on

Cannot login into AD due to mismatched times

Newly installed XP Pro, SP3, non-OEM.  Successfully joined AD.  Now cannot login into AD due to "The current time on this computer and the current time on the network are different." Local admin login okay; no Windows Time service listed to disable.  This is SP3 v3311.  Suggestions?
Avatar of sk_raja_raja
sk_raja_raja

Avatar of michaelheffernan

ASKER

None of this worked.  REinstalled the OS, still the same problem.
hmmm...

Did you try setting the time closer to the domain controller time manually then try restarting the time service?
Yep. It is well within the allowed five minute differential.  The workstation gives access denied to any attempt to manipulate the net time command, however, and this is on the reinstall as well.  CMOS time and date are correct.  This machine previously ran W2k w/out issue.  This keeps up, it will continue to run W2k.
I am beginning to suspect SP3.  I am going to reinstall again and stay at SP2 and see what happens.
Avatar of William Fulks
Check the machine name and make sure it doesn't conflict with anything else on the network. You may have to rename the PC and then rejoin the domain.
Yeah uninstall service pack 3 and see what happens, then I would try and rename the machine to a different name other than the name you previously used.  Did you name it the same name as the machine on 2000?  If so I would try changing it and rejoining.  
The workstation was originally "station62".  The XP version was "station062".  Then, on the reinstall, "station".  I am wondering what possible connection MS would code in between a machine's name and time sync.  I reinstalled an older XP SP2, got the same result. This is a machine which ran W2k just fine for over a year.
This is only the one machine correct getting this error?  I would try dis-joining a different machine, hopefully you have a spare around and see if you have the same problem.  Trying to figure out if this is a client or server side issue.
Wait, when you login locally using the admin account did you make sure that the time zone was correct, not just the time?
Also, make sure the date is fine too.
If one of these are off I am willing to bet the cmos battery is bad, which is causing the issue of date/time
I am incredulous.  I just reinstalled W2k on this machine, and it is doing the same thing! There are about 120 Workstations in this AD, and this is the first time I have ever encountered this problem.  The CMOS seems correct, it has retained date/time while off AC, time zone's correct, machine date and time are correct.  We have only two DCs, I have tried this with time service on them running and stopped.  I guess I will unjoin and rejoin another workstation and see what happens.
Yeah that will key us in on whether or not this is a server side issue.  Do you domain controllers sync with an outside source?  Here are the instructions and this has to be done on the pdc emulator, so whichever domain controller that is run it on there.

https://www.experts-exchange.com/questions/23093322/Windows-2003-Domain-Controller-Sync-with-Outside-TIme-Server.html

Can you check the system time on CMOS ? try to give a static ip for the machine and join to domain.
Also delete the DNS record before joining to domain.
I am unable to unjoin the AD with another machine; "The specified module cannot be found".  I have rebooted both DCs and tried again, but with no success.  Apparently there is a a problem with AD.  What a surprise.
CMOS time is correct.  We do not use DHCP; all addresses are static. DCs point to time.windows.com. That I cannot unjoin a completely different workstation either is very suspect.  MS time sync caused us monumental problems when the time zones shifted last year; I suspect this may be an AD problem.
So, to recap...new workstation (XP SP2 and SP3 and W2k SP4 join domain properly, cannot log into it with a network time sync error.  An entirely properly functioning workstation cannot be unjoined from the AD with a "module not found" error.  Both DCs rebooted; will next look at their event logs.
Sounds good, let us know what you find, I will try to dig up some info for you.
Are all domain controller times in sync with each other as far as time goes?
Also, im assuming you mean the daylight savings time updates, are all patches installed?
Try this, log on locally and enter this to force network time syncronization::

NET TIME \\ /SET /Y

Or

NET TIME \\ /SET /Y

Here is the article--> http://support.microsoft.com/kb/q193825/

Thank you. Day 2 ... I had tried the NET TIME set initially, and that command returned success.  This is starting to smell like a faux error return (e.g., the mismatch time error).  I'm going to examine the DC logs in a few minutes.  But let me look at that article.  Yes, all TZ patches were installed (not that that did much good last year).  All servers are maintained with WSUS and are current.  This workstation has been all the way up to SP3.  DCs time's match.
Correction, trying the "net time etc." at the DOS prompt results in an Access Denied response.  I am local admin.  Now that makes no sense...
...yet net time works fine elsewhere.  This is a fresh, *fresh* XP Pro install.  Firewall's disabled...
You know what?  I'm going to slap in a differnet NIC just for giggles.  Event logs on both DCs are clean. Perhaps a different MAC will have an effect.
ASKER CERTIFIED SOLUTION
Avatar of swappedsr
swappedsr

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Yep, that fixed it.  Machine's fine (after four frickin' hours of monkeying with it!).  Thank you for your help; I will push these points your way.
Joint conclusion, an oddity at best.  But a solution nonetheless.
No problem, now you can get some sleep tonight ;)