windows server 2003 - cannot run exe, msi files

when I try to run .exe or msi files on windows 2003 server, I am not able to.  I have to go to the file's properties and unblock something which I forgot.  After that, I am able to run.  

Is there a way to do this from the folder level and let it propagate?  Or make configuration somewhere?

Please advise.
search5354Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

debuggerauCommented:
could be that the security settings dont allow unsigned programs, or even disallowed running from the local machine.
Check your security settings with control panel under internet options.
set your local machine in the safe site list and allow unsigned programs to run.
(its all dangerous)...

search5354Author Commented:
Thanks.  This make sense.

Would you show me the exact steps?  I already have https://localhost as a trusted site.  
debuggerauCommented:
the steps will depend on what and where you are trying to run.

If you give me the file, type, location and error when trying and I should be able to elaborate more.
But basically, there will be warning that tells you that its either an unsigned executable, or outside your trusted zone where you get to change the settings.
If its a permissions issue, again an appropriate message will be displayed..
adkinsmatthewCommented:
The behavior you are describing is called "File Protection Control".  I forget when this was introduced.....it may have been SP2 of Windows 2003 or possibly it was with the release of R2.  In addition, this behavior is also seen on Vista SP1.

Nevertheless.....you can disable it.....it can really be annoying at times.

Open gpedit.msc then browse to the following:

User Configuration > Administrative Templates > Windows Components > Attachment Manager.

There are a couple of policies related to this feature, but to disable it you'll want to ENABLE the policy called "Do not preserve zone information in file attachments".

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
adkinsmatthewCommented:
Here is a pic of the Group Policy object I was referring to.   Set it to "Enable".  Also, take a look at the description of the policy...very interesting.  



zone-information.png
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.