Link to home
Create AccountLog in
Avatar of donkey001
donkey001

asked on

DNS not responding to requests and logging 4004 and 4015 EventIDs continuously!

Recently our dns server decided to malfunction!
luckily  we have a child domain off site that  is able to serves dns requests
through Routing and Remote Access but this is not a permanent solution because Active
Directory sites and services fails generate anything when asked to check Replication Topology .

These two errors appear continuously

Source: DNS  
EventID: 4004
Type: Error

Description:
The DNS server was unable to complete directory service enumeration of zone .. This DNS server is configured to use information obtained from Active Directory for this zone and is unable to load the zone without it. Check that the Active Directory is functioning properly and repeat enumeration of the zone. The event data contains the error.

Source: DNS
EventID: 4015
Type: Error

Description:
The DNS server has encountered a critical error from the Active Directory. Check that the Active Directory is functioning properly. The event data contains the error.

and when i run NSLOOKUP I receive the following:

C:\>nslookup
DNS request timed out.
         timeout was 2 seconds.
*** Can't find server name for address 192.168.0.4: Timed out
Default Server: richardsbaai.rbay.armature.co.za
Address: 192.168.1.4

help would help allot I'm losing sleep over this
Thanks!
Avatar of cdbeste
cdbeste

Avatar of donkey001

ASKER

When we try to restart the dns server we get a popup stating

dns.exe - Application Error

The instruction at "0x10017680" referenced momory at "0xddb70elc".
The memory could not be "written".

Click on OK to terminate the program.

Sorry this should have been posted in the original Question.
Ensure that your reverse lookup files is correct
Even better - try the following:-

1.) Stop netlogon services
2.) Delete Active Directory Ingegrated Zones
3.) Restart DNS service
4.) Stop DNS service
5.) Uninstall DNS
6.) REBOOT machine
7.) Stop netlogon service
7.) Reinstall DNS
8.) Recreate DNS zones (Remember the Reverse Look-up Zone)
9.) issue at command prompt: ipconfig /flushdns && ipconfig /registerdns
10.) Start netlogon service


This has worked for me in the past.

If M$ can explain this, I would appreciate the comment.

Even better - CHANGE TO LINUX - You will not have these ridiculous type of issues....
ASKER CERTIFIED SOLUTION
Avatar of Wicus001
Wicus001

Link to home
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
See answer
The accepted solution has worked but it has eaten up most of our bandwith!