Avatar of akuma6099

asked on 

How do I debug and or log a terminal service/MSTSC connection?

Here's my dilema. I have a fresh install of XP SP3 Corp. Currently I have OpenSSH running on my PDC and I forward tunnels for port 3389 to map terminal services internally. This has worked great for a year. After doing this fresh SP3 install, I cannot connect and establish a session via MSTSC. This only happends to the SP3 machine. Symptoms are the same wheater I'm using putty or from inside the network. The problem lies in the SP3 machine.

When I try to connect I am asked for credentials. I provide them, hit connect and then all buttons except for cancel are grayed out. There is no "connecting" dialog. After 1-2 seconds all buttons are re-enabled and I can hit connect again and it will ask for credentials. There are no error messages. I'm 100% positive Terminal services is setup properly. There is no firewall's or antivirus. I've been doing this for years and have never run across this. I have also copied over a different version of termsrv.dll in system32. There was no copy in dllcache. Tried from multiple computers.

I'm stuck as far as debugging. Not sure how to go about it. Any pointers or people who have experianced this issue? Google turned up dead ends for me.

Phenom 9750 Quad core
Gigabyte GA-MA78G-DS3H AM2/AM2+ Systemboard
2G DDR-1066  PC2-8500
XP Corp SP3
(Zotac) Geforce 9850GTX
2x400G SATA2

Microsoft Server OSMicrosoft ApplicationsWindows XP

Avatar of undefined
Last Comment

8/22/2022 - Mon